View Issue Details

IDProjectCategoryView StatusLast Update
0006070unrealircdpublic2022-03-23 08:11
ReporterValware Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0.2 
Fixed in Version6.0.3 
Summary0006070: The MOTD which displays to connecting users doesn't include lines added from SVSMOTD
DescriptionConnecting MOTD example:
[12:14:04] - irc.valware.uk Message of the Day -
-
[12:14:04] - 1/2/2022 6:46
[12:14:04] -
[12:14:04] - Welcome to my test network.
[12:14:04] - Main channel is #PossumsOnly
[12:14:04] -
[12:14:04] - Please report any bugs in #bugs
[12:14:04] - If you are interested in running Dalek IRC Services,
[12:14:04] - please ask in #PossumsOnly
[12:14:04] -
[12:14:04] - Don't worry if you're not a possum, you are still allowed in.
[12:14:04] - =]
-
[12:14:04] End of /MOTD command.


MOTD command output:

[12:17:11] - irc.valware.uk Message of the Day -
-
[12:17:11] - 2022-02-01 06:46
[12:17:11] -
[12:17:11] - Welcome to my test network.
[12:17:11] - Main channel is #PossumsOnly
[12:17:11] -
[12:17:11] - Please report any bugs in #bugs
[12:17:11] - If you are interested in running Dalek IRC Services,
[12:17:11] - please ask in #PossumsOnly
[12:17:11] -
[12:17:11] - Don't worry if you're not a possum, you are still allowed in.
[12:17:11] - =]
[12:17:11] - Please use client certificates wherever possible, and avoid /ns identify.
[12:17:11] - Services are running in debug mode, which means any messages sent to services may be exposed to Valware.
[12:17:11] - So please use a client cert and add it to NickServ with /ns certfp add
[12:17:11] - and enable SASL EXTERNAL. Thank you. -- Valware
-
[12:17:11] End of /MOTD command.


Extra note: ADDMOTD seems to require a REHASH in order to be applied.
Steps To Reproduce1) Add lines to your MOTD using SVSMOTD.
2) Connect
3) Notice there is not the MOTD that you added
4) type /MOTD which /does/ include lines from SVSMOTD
5) ???
6) relax
Additional InformationAlso take a look at ADDMOTD which indeed writes to the file but seems to require a rehash to apply. not sure if intended behaviour =]
TagsNo tags attached.
3rd party modules

Activities

Valware

2022-02-18 00:22

reporter   ~0022403

proposed patch:
https://github.com/unrealircd/unrealircd/pull/191

syzop

2022-03-23 07:57

administrator   ~0022417

First some detail out of the way: SVSMOTD does not require a REHASH. You can see it in the code that it writes and re-reads immediately.

Anyway, on to the main issue...
In the default configuration (no files { } or tld { } block) i can reproduce that anything added by SVSMOTD is not shown in the motd on connect but is shown if you manually request a MOTD (without rehash needed).
So yeah, seems you are onto something :D

Your PR removed the whole concept of a short motd though, so that is not the way to fix it.

syzop

2022-03-23 07:58

administrator   ~0022418

(Initial post edited because it makes mantis bugtracker angry)

syzop

2022-03-23 08:11

administrator   ~0022419

Last edited: 2022-03-23 08:11

Fixed now:
commit 89fe8e922734eb215be0586344cd463e0c0d8254 (HEAD -> unreal60_dev, origin/unreal60_dev)
Author: Bram Matthys <syzop@vulnscan.org>
Date:   Wed Mar 23 08:06:23 2022 +0100

    SVSMOTD lines are now shown in the MOTD-on-connect, unless a shortmotd is used.
    What is a SVSMOTD? The SVSMOTD are MOTD lines that are shown at the end of
    an existing MOTD. These lines are added remotely through services.
    
    Previously the SVSMOTD lines were never shown in the MOTD-on-connect, which
    was a bug. We were only supposed to hide it if a short motd is in use.
    
    Reported by Valware in https://bugs.unrealircd.org/view.php?id=6070

Thanks for the report! If you feel like you still have some other issue with (SVS)MOTDs or anything, let us know.

Issue History

Date Modified Username Field Change
2022-02-11 13:22 Valware New Issue
2022-02-18 00:22 Valware Note Added: 0022403
2022-03-23 07:57 syzop Assigned To => syzop
2022-03-23 07:57 syzop Status new => confirmed
2022-03-23 07:57 syzop Note Added: 0022417
2022-03-23 07:58 syzop Description Updated
2022-03-23 07:58 syzop Note Added: 0022418
2022-03-23 08:11 syzop Status confirmed => resolved
2022-03-23 08:11 syzop Resolution open => fixed
2022-03-23 08:11 syzop Fixed in Version => 6.0.3
2022-03-23 08:11 syzop Note Added: 0022419
2022-03-23 08:11 syzop Note Edited: 0022419