View Issue Details

IDProjectCategoryView StatusLast Update
0006091unrealircdpublic2022-04-18 08:54
ReporterPeGaSuS Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version20.04
Product Version6.0.3 
Fixed in Version6.0.4-rc1 
Summary0006091: Duplicated extbans entries
DescriptionRecently, I've found out on #unreal-support that some extbans were being shown duplicated/

/* "/MODE #unreal-support +b" with weechat */
19:00:17 -- [#unreal-support] [1] *!*@Clk-D6DFD7AD.vps.ovh.ca banned by Syzop on Sun, 17 May 2020 18:35:06
19:00:17 -- [#unreal-support] [2] ~nickchange:h3km3k*!*@* banned by ChanServ on Mon, 20 Jan 2020 17:34:57
19:00:17 -- [#unreal-support] [3] ~msgbypass:color:UnrealFeeds!*@*.ircfriends.eu banned by ChanServ on Mon, 20 Jan 2020 17:34:57
19:00:17 -- [#unreal-support] [4] *!*@*.danwin1210.me banned by ChanServ on Mon, 20 Jan 2020 17:34:57
19:00:17 -- [#unreal-support] [5] *!*@*.pool-101-51.dynamic.totbb.net banned by ChanServ on Mon, 20 Jan 2020 17:34:57
19:00:17 -- [#unreal-support] [6] *!*@*.fagz.net banned by ChanServ on Mon, 20 Jan 2020 17:34:57
19:00:17 -- [#unreal-support] [7] *!*@Clk-6B711C32.vectr0n.com banned by ChanServ on Mon, 20 Jan 2020 17:34:57
19:00:17 -- [#unreal-support] [8] *!*@97371B7.71005B2A.8B1D2877.IP banned by Cronus on Sat, 30 May 2020 20:57:30
19:00:17 -- [#unreal-support] [9] *!*@Clk-8CCE6006.cust.vodafonedsl.it banned by Cronus on Sat, 30 May 2020 20:58:45
19:00:17 -- [#unreal-support] [10] *!*@*.C612985E.7DA59F9C.IP banned by GTAXL on Mon, 01 Jun 2020 22:26:25
19:00:17 -- [#unreal-support] [11] *!~lalbornoz@* banned by GTAXL on Tue, 29 Jun 2021 13:18:30
19:00:17 -- [#unreal-support] [12] ~text:block:*#MIDIPIX* banned by PeGaSuS on Tue, 29 Jun 2021 13:23:29
19:00:17 -- [#unreal-support] [13] ~text:block:*#MIDIPIX* banned by PeGaSuS on Tue, 29 Jun 2021 13:23:29
19:00:17 -- [#unreal-support] [14] ~msgbypass:color:UnrealFeeds!*@*.ircfriends.eu banned by ChanServ on Mon, 20 Jan 2020 17:34:57
19:00:17 -- [#unreal-support] [15] ~nickchange:h3km3k*!*@* banned by ChanServ on Mon, 20 Jan 2020 17:34:57
19:00:17 -- [#unreal-support] End of Channel Ban List


/* "/MODE #unreal-support +b" with Hexchat */
[17/04/2022 - 19:09:53] * #unreal-support: *!*@*.C612985E.7DA59F9C.IP on Mon Jun  1 22:26:25 2020 by GTAXL
[17/04/2022 - 19:09:53] * #unreal-support: *!*@Clk-8CCE6006.cust.vodafonedsl.it on Sat May 30 20:58:45 2020 by Cronus
[17/04/2022 - 19:09:53] * #unreal-support: *!*@97371B7.71005B2A.8B1D2877.IP on Sat May 30 20:57:30 2020 by Cronus
[17/04/2022 - 19:09:53] * #unreal-support: *!*@Clk-6B711C32.vectr0n.com on Mon Jan 20 17:34:57 2020 by ChanServ
[17/04/2022 - 19:09:53] * #unreal-support: *!*@*.fagz.net on Mon Jan 20 17:34:57 2020 by ChanServ
[17/04/2022 - 19:09:53] * #unreal-support: *!*@*.pool-101-51.dynamic.totbb.net on Mon Jan 20 17:34:57 2020 by ChanServ
[17/04/2022 - 19:09:53] * #unreal-support: *!*@*.danwin1210.me on Mon Jan 20 17:34:57 2020 by ChanServ
[17/04/2022 - 19:09:53] * #unreal-support: ~msgbypass:color:UnrealFeeds!*@*.ircfriends.eu on Mon Jan 20 17:34:57 2020 by ChanServ
[17/04/2022 - 19:09:53] * #unreal-support: ~nickchange:h3km3k*!*@* on Mon Jan 20 17:34:57 2020 by ChanServ
[17/04/2022 - 19:09:53] * #unreal-support: *!*@Clk-D6DFD7AD.vps.ovh.ca on Sun May 17 18:35:06 2020 by Syzop
[17/04/2022 - 19:09:53] * #unreal-support: *!~lalbornoz@* on Tue Jun 29 13:18:30 2021 by GTAXL
[17/04/2022 - 19:09:53] * #unreal-support: ~text:block:*#MIDIPIX* on Tue Jun 29 13:23:29 2021 by PeGaSuS
[17/04/2022 - 19:09:53] * #unreal-support: ~nickchange:h3km3k*!*@* on Mon Jan 20 17:34:57 2020 by ChanServ
[17/04/2022 - 19:09:53] * #unreal-support: ~msgbypass:color:UnrealFeeds!*@*.ircfriends.eu on Mon Jan 20 17:34:57 2020 by ChanServ
[17/04/2022 - 19:09:53] * #unreal-support: ~text:block:*#MIDIPIX* on Tue Jun 29 13:23:29 2021 by PeGaSuS
[17/04/2022 - 19:09:53] * #unreal-support :End of Channel Ban List


/* "/MODE #unreal-support +b" with IRCCloud */
Since IRCCloud displays those lists in a pop-up window, a screenshot was been attached
Steps To Reproduce1) Join #unreal-support
2) Ask for the banlist with "/MODE #unreal-support
3) Extbans will be displayed duplicated
TagsNo tags attached.
3rd party modules

Activities

PeGaSuS

2022-04-17 19:25

reporter  

Ban_List_Double.png (229,529 bytes)

syzop

2022-04-18 08:54

administrator   ~0022463

Thanks for the report, fixed now :)

commit 3451919b0686641bfc128066f09efa02b5968b58 (HEAD -> unreal60_dev, origin/unreal60_dev, origin/HEAD)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Apr 18 08:39:34 2022 +0200

    Fix issue with duplicate entries in the +b/+e/+I list of +P channels.
    This was caused by the transition from letter extbans (eg ~a) to
    named extbans (eg ~account) and a combination of the bug fix in 6.0.2
    (60a70acd865ea772b44805da70d477fa7799f008) and the 'channeldb' module
    not checking for duplicates while reading the database.
    
    Reported by PeGaSuS in https://bugs.unrealircd.org/view.php?id=6091

https://github.com/unrealircd/unrealircd/commit/3451919b0686641bfc128066f09efa02b5968b58

Issue History

Date Modified Username Field Change
2022-04-17 19:25 PeGaSuS New Issue
2022-04-17 19:25 PeGaSuS File Added: Ban_List_Double.png
2022-04-18 08:54 syzop Assigned To => syzop
2022-04-18 08:54 syzop Status new => resolved
2022-04-18 08:54 syzop Resolution open => fixed
2022-04-18 08:54 syzop Fixed in Version => 6.0.4-rc1
2022-04-18 08:54 syzop Note Added: 0022463