View Issue Details

IDProjectCategoryView StatusLast Update
0006099unrealdocumentationpublic2022-05-13 10:22
Reporterlibsys Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version6.0.3 
Fixed in Version6.0.4 
Summary0006099: What is the license for this project? (GPLv1+ or GPLv2)
DescriptionI've looked at the source code of the project and noticed in several files it says license is "GPLv1 or later", which means that I could use it as licensed under GPLv3, but the LICENSE file contains the GPLv2 text.

I wonder if there's any file on the project licensed as "GPLv2 only" or we could consider the project as a whole licensed as "any version of the GPL".

Now that OpenSSL v3 is under Apache 2 license, if this project is licensed under GPLv3 it would no longer have conflicting licenses and allow for packaging into operating system distributions such as Debian.

I've also noticed that some people says the project uses a "non DFSG-free versions of the MD5 algorithm for hostcloaking" so I wonder what's that dependency/code.
TagsNo tags attached.
3rd party modules

Activities

syzop

2022-05-11 08:21

administrator   ~0022473

You mentioned some files have "License: GPLv2". I have now clarified that this was meant to be (and is now) "License: GPLv2 or later". ( https://github.com/unrealircd/unrealircd/commit/b154591a5825980a7b47710abd98f682c13ebcb9 ).

The code of UnrealIRCd consists mostly of a mix of "GPLv1 or later" and "GPLv2 or later". The remaining parts either come from public domain or BSD license WITHOUT advertising clause, so are GPL compatible.

As for MD5: in 2015 our own md5 code was removed and we rely on OpenSSL to provide the routines, see https://github.com/unrealircd/unrealircd/commit/229bcca9967d26b40e8b77880ad9fc368e4d1527

syzop

2022-05-11 10:27

administrator   ~0022474

Also updated /LICENSE in commit https://github.com/unrealircd/unrealircd/commit/cd48fec82656383ae3302a8d7e4471b954a42bbe since that could be potentially confusing as well.

I think that answers all the questions that need to be answered, right?

libsys

2022-05-11 20:42

reporter   ~0022475

it does, thanks a lot

syzop

2022-05-13 10:22

administrator   ~0022481

Good!

Issue History

Date Modified Username Field Change
2022-05-09 20:02 libsys New Issue
2022-05-11 08:21 syzop Note Added: 0022473
2022-05-11 10:27 syzop Note Added: 0022474
2022-05-11 20:42 libsys Note Added: 0022475
2022-05-13 10:22 syzop Assigned To => syzop
2022-05-13 10:22 syzop Status new => resolved
2022-05-13 10:22 syzop Resolution open => fixed
2022-05-13 10:22 syzop Fixed in Version => 6.0.4
2022-05-13 10:22 syzop Note Added: 0022481