View Issue Details

IDProjectCategoryView StatusLast Update
0006189unrealircdpublic2022-12-07 08:34
Reporterdarkex Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0.4.1 
Fixed in Version6.0.5-rc1 
Summary0006189: /stats o returns "(null)" if advanced matching criteria for mask is used
DescriptionI have an oper block that looks like this:

oper joe {
    mask { 1.2.3.4; *.joe.com; };
    password "$argon2id$v=19$m=8192,t=3,p=2$f5wuA2K5pzCMtOHsx8OYUA$Mx2MCoQzLbdy/tDfHlQE5aB6TVjl9FMCA15A0rzrlwQ" { argon2; };
    operclass services-admin-with-override;
    class opers;
};

which corresponds to /stats o output that looks like this:

-- O mask:*.joe.com * joe services-admin-with-override opers
-- O mask:1.2.3.4 * joe services-admin-with-override opers
-- o End of /STATS report

But if I use advanced matching criteria as intended, per https://www.unrealircd.org/docs/Mask_item#Advanced_matching_criteria, I have an oper block that looks like this:

oper joe {
    mask {
        ip { 1.2.3.4; };
        mask { *.joe.com; };
    };
    password "$argon2id$v=19$m=8192,t=3,p=2$f5wuA2K5pzCMtOHsx8OYUA$Mx2MCoQzLbdy/tDfHlQE5aB6TVjl9FMCA15A0rzrlwQ" { argon2; };
    operclass services-admin-with-override;
    class opers;
};

but the output of /stats o then shows this:

-- O mask:(null) * joe services-admin-with-override opers
-- O ip:(null) * joe services-admin-with-override opers
-- o End of /STATS report

Is this intended?
TagsNo tags attached.
3rd party modules

Activities

syzop

2022-12-07 08:34

administrator   ~0022677

Thanks for the report. This should now be fixed, i tested before and after with your oper block example.

Fixed in https://github.com/unrealircd/unrealircd/commit/36a8949d59f3c248d1a39892bc75a89493286c82

commit 36a8949d59f3c248d1a39892bc75a89493286c82 (HEAD -> unreal60_dev)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Wed Dec 7 08:30:52 2022 +0100

    Fix "/STATS o" returning (null) items when advanced matching criteria
    are being used. This also applies to similar use in some other /STATS
    like tld blocks.
    
    Reported by darkex┬áin https://bugs.unrealircd.org/view.php?id=6189

Issue History

Date Modified Username Field Change
2022-11-14 10:11 darkex New Issue
2022-12-07 08:34 syzop Assigned To => syzop
2022-12-07 08:34 syzop Status new => resolved
2022-12-07 08:34 syzop Resolution open => fixed
2022-12-07 08:34 syzop Fixed in Version => 6.0.5-rc1
2022-12-07 08:34 syzop Note Added: 0022677