View Issue Details

IDProjectCategoryView StatusLast Update
0006211unrealircdpublic2023-01-09 09:06
Reporterrafaelgrether Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0.5 
Fixed in Version6.0.6 
Summary0006211: Exempt Bans with wildcard ~a:* is matching unauthenticated users too
DescriptionHi folks,

The wildcard ~a:* is matching unauthenticated users too.

I do a test, I created extban for nickchange, and an exception for only authenticated users with services can change nicks.
But the wildcard ~a:* is not working. If I use ~a:SomeNick works perfectly.

Above, steps to reproduce.
Steps To ReproduceI create ban for nickchange:

/mode #chan +b ~n:*!*@*

After, an exception for only authenticated users with services can change nicks:

/mode #chan +e ~a:*
Additional InformationServices used is Anope.
Tested on irc.unrealircd.org too.
TagsNo tags attached.
3rd party modules

Activities

GHF

2023-01-09 04:29

reporter   ~0022698

Hello,

there is another solution for nickchanges until this bug is getting fixed:

      restrict-commands {
           nick { exempt-identified yes; }
     };

(If my answer is irrelevant, please delete)

syzop

2023-01-09 08:43

administrator   ~0022699

I think https://github.com/unrealircd/unrealircd/commit/991f9f347e8d2891e293e483d23d8e7b8a9a2474 broke it. That is since 5.2.1 (July 2021) though.

syzop

2023-01-09 09:02

administrator   ~0022700

Thanks for the report. Fixed now.
Commit: https://github.com/unrealircd/unrealircd/commit/c5d8bc5d9bd170600720c5eec283ba0583fb1d6d

commit c5d8bc5d9bd170600720c5eec283ba0583fb1d6d (HEAD -> unreal60_dev, origin/unreal60_dev, origin/HEAD)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Mon Jan 9 08:58:10 2023 +0100

    Fix ~account:* matching both logged in and logged out users (so quite useless).
    This bug exists since 5.2.1 already, so i guess the functionality is
    not used much ;). Makes sense, since for simple ~account:* you have +R already,
    so it is only useful in stacked bans such as +e ~nickchange:~account:*
    
    We now have a test case so that this bug won't "ever" reoccur.
    
    Reported by rafaelgretherĀ in https://bugs.unrealircd.org/view.php?id=6211

syzop

2023-01-09 09:06

administrator   ~0022701

Also good suggestion from GHF if you wanted to prevent nick changes everywhere indeed (in all channels, and even when the user is in no channel at all).

Issue History

Date Modified Username Field Change
2023-01-09 01:24 rafaelgrether New Issue
2023-01-09 04:29 GHF Note Added: 0022698
2023-01-09 08:43 syzop Note Added: 0022699
2023-01-09 08:44 syzop Assigned To => syzop
2023-01-09 08:44 syzop Status new => confirmed
2023-01-09 09:02 syzop Status confirmed => resolved
2023-01-09 09:02 syzop Resolution open => fixed
2023-01-09 09:02 syzop Fixed in Version => 6.0.6
2023-01-09 09:02 syzop Note Added: 0022700
2023-01-09 09:06 syzop Note Added: 0022701