View Issue Details

IDProjectCategoryView StatusLast Update
0006417unrealinstallingpublic2024-06-14 10:50
Reporterhnj Assigned Tosyzop  
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSLinux 
Product Version6.1.5 
Fixed in Version6.1.7-rc1 
Summary0006417: Inconsistent option handling in Config script
DescriptionThe `Config` script is not consistent when it comes to option handling:
* the option `--help` shows that the three other available options do not follow the same scheme of two dashes followed by a word but instead use only one dash while …
* the option `-help` is ignored even though its scheme of "one dash followed by one word" would be consistent with all other options that it would work.

Desired behaviour:
`./Config -h` should either display the help or show an error that an unknown argument was given. Just ignoring the argument is not good style.
`./Config -help` should display the help to be in line with the scheme used for other options like `-nointro`: one dash followed by one word.
`./Config --help` should either display the help or show an error that an unknown argument was given. The prevalent scheme seems to be "one dash followed by one word" for options and this does not follow it.
Steps To Reproduce./Config -h
./Config -help
./Config --help
TagsNo tags attached.
3rd party modules

Activities

syzop

2024-06-14 10:50

administrator   ~0023218

Not that important but yeah easy fix ;)

Issue History

Date Modified Username Field Change
2024-05-31 22:11 hnj New Issue
2024-06-14 10:50 syzop Assigned To => syzop
2024-06-14 10:50 syzop Status new => resolved
2024-06-14 10:50 syzop Resolution open => fixed
2024-06-14 10:50 syzop Fixed in Version => 6.1.7-rc1
2024-06-14 10:50 syzop Note Added: 0023218