View Issue Details

IDProjectCategoryView StatusLast Update
0006419unrealircdpublic2024-07-12 08:53
ReporterPeGaSuS Assigned Tosyzop  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version22.04
Product Version6.1.5 
Fixed in Version6.1.7-rc1 
Summary0006419: Multiple ports in one listen block
DescriptionCurrently we can only specify one port or a range for UnrealIRCd listen to inside a listen block.

If we try something like
listen {
    ip *;
    port 6776,6777;
}

UnrealIRCd does error or warns about a bad setting on rehash and the `configtest` command line argument also says that the config has no issues and it'll listen *only* on port 6776.

It'd be useful if we could specify more than one port on the same `port` setting, via something like `port 6776,6777` or `port { 6776; 6777; }`.
Steps To Reproduce- Create listen block like the following:
listen {
    ip *;
    port 6776,6777;
}

- Rehash UnrealIRCd
- No errors or warnings are displayed and UnrealIRCd will only listen on port 6776.
TagsNo tags attached.
3rd party modules

Relationships

related to 0006281 acknowledged Allow commas in "port" or multiplie "port" lines in listen{} blocks 

Activities

PeGaSuS

2024-06-05 22:22

reporter   ~0023211

Correction: "UnrealIRCd doesn't error or warns about a bad setting..."

syzop

2024-07-12 08:53

administrator   ~0023258

Last edited: 2024-07-12 08:53

Indeed, we should error because otherwise it is clearly confusing. Let's fix that now.. that's easy.

Fixed in https://github.com/unrealircd/unrealircd/commit/89e6c2c06fef01ac2f22a14169ff40320761d567

The feature request to allow multiple ports is https://bugs.unrealircd.org/view.php?id=6281 and is still open.

Issue History

Date Modified Username Field Change
2024-06-05 22:20 PeGaSuS New Issue
2024-06-05 22:22 PeGaSuS Note Added: 0023211
2024-06-06 17:46 syzop Relationship added related to 0006281
2024-07-12 08:53 syzop Assigned To => syzop
2024-07-12 08:53 syzop Status new => resolved
2024-07-12 08:53 syzop Resolution open => fixed
2024-07-12 08:53 syzop Fixed in Version => 6.1.7-rc1
2024-07-12 08:53 syzop Note Added: 0023258
2024-07-12 08:53 syzop Note Edited: 0023258