View Issue Details

IDProjectCategoryView StatusLast Update
0000008unrealircdpublic2015-07-29 10:46
ReporterstskeepsAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version3.2-beta5 
Target VersionFixed in Version3.4-beta3 
Summary0000008: IPv6 in UnrealIRCd/32 - for windows XP
DescriptionMake our IPv6 code work under XP
TagsNo tags attached.
3rd party modules

Activities

webteyimcom

2003-06-09 17:32

reporter   ~0002952

Reminder sent to 0x3g3n

vorte[x]

2003-06-17 18:00

reporter   ~0002982

Don't forget to 'ipv6 install' in your command prompt on your XP box.

syzop

2013-01-09 10:09

administrator   ~0017312

Should be on TODO for 3.4

nenolod

2013-01-14 12:01

reporter   ~0017369

To do this involves basically removing the current ipv6 code and reimplementing it where it considers the IP stack to be split (as it is in reality on most OS). It will also fix the BSD issues at the same time.

Jobe1986

2013-01-14 14:52

reporter   ~0017374

Last edited: 2013-01-14 14:54

View 2 revisions

For clarification to anyone who doesn't know, the BSD issue being referred to is the issue where on OpenBSD if you compile UnrealIRCd with IPv6 support, you lose IPv4 support because OpenBSD hard restricts the per socket and system wide v6only option for AF_INET6 sockets to enabled so effectively behaves the same as Windows with regard to IPv4 vs IPv6 sockets.

syzop

2013-01-14 18:14

administrator   ~0017375

Yeah, and there's a specific option to turn this behavior on/off in an application (IPV6_V6ONLY), which is quite nice, but those OS's don't support that.

There's no way around it: we have to split the ipv4/ipv6 stuff.
Naturally, when we do this, do this for all OS's, not just for Windows and (Open)BSD. To keep the code clean.

syzop

2015-07-13 22:58

administrator   ~0018506

This is a major job, but we should consider it during 3.4-beta...

syzop

2015-07-29 10:46

administrator   ~0018569

Done past few days. See changes of Jul 27, 2015 until Jul 29, 2015 (too many to paste here).

IPv4/IPv6 socket split has been done, and it works now on Windows too.

Additionally, we always compile with IPv6 support enabled now, as all supported OS's support it. There's set::options::disable-ipv6 to turn it off at runtime.

Obviously the code changes past few days were major so let's see what bugs come up.

Issue History

Date Modified Username Field Change
2003-06-09 17:32 webteyimcom Note Added: 0002952
2003-06-17 18:00 vorte[x] Note Added: 0002982
2013-01-09 10:09 syzop Note Added: 0017312
2013-01-09 10:09 syzop Assigned To codemastr =>
2013-01-09 10:09 syzop Status assigned => acknowledged
2013-01-14 12:01 nenolod Note Added: 0017369
2013-01-14 14:52 Jobe1986 Note Added: 0017374
2013-01-14 14:54 Jobe1986 Note Edited: 0017374 View Revisions
2013-01-14 18:14 syzop Note Added: 0017375
2015-07-13 22:58 syzop Note Added: 0018506
2015-07-29 10:46 syzop Note Added: 0018569
2015-07-29 10:46 syzop Status acknowledged => resolved
2015-07-29 10:46 syzop Fixed in Version => 3.4-beta3
2015-07-29 10:46 syzop Resolution open => fixed
2015-07-29 10:46 syzop Assigned To => syzop