View Issue Details

IDProjectCategoryView StatusLast Update
0001376unrealircdpublic2004-05-27 18:08
Reporterblotter45 Assigned Tocodemastr 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version3.2-beta18 
Summary0001376: show IP in /whois
DescriptionHeya, was just wondering if in a future version of unreal 3.2-beta*, if it would be possible to add the ip address of a client (in addition to the hostname) in whois replies (numeric 378).. Ultimate ircd does this, and I think it would be a great feature fo unreal too ;)
Additional Informationexample:

blotter45 is connecting from blotter45.hostname.com 12.12.34.45
TagsNo tags attached.
3rd party modules

Activities

Praetorian_

2003-11-21 05:30

reporter   ~0004075

possibly might be worth sending this in server <-> server communications as well in a NICK string? or somewhere else? (if its not already done - though i haven't seen it)

Though, implementing it into the whois reply would probably need this anyway...

syzop

2003-11-21 18:30

administrator   ~0004076

Yes not a bad idea, however IPs are (indeed) not known by remote servers at the moment, NICKIP is is somewhere on TODO (0000605 also depends on this).

us44ever

2003-11-24 16:10

reporter   ~0004092

Great suggestion, I've always wanted that feature to be implemented
it's the coders decision now... :)

codemastr

2003-11-25 00:29

reporter   ~0004107

The whole problem revolves around IPv6. IPv4 IPs we can distribute through the network no problem at all. IPv6 isn't so easy. Not all OSes have the functions necessary to decode an IPv6 address in a network byte form (which is the most efficient way to transmit it). Then, even if we can manage to somehow get that working (probably just including an inet_ntop.c or something) we need to write a function that can encode the result of inet_ntop to a base64 string. So far all my attempts at doing this have failed.

White_Magic

2003-12-04 18:08

reporter   ~0004198

O_o why not use the raw to do it for ya??

raw 378:*:{
//dns $6
set %nickip $2
}

ON *:DNS:{
//echo -a %nickip is conneting from $raddress
}

Midnite_Angel01 is CUMIRC@Chatuniverse-3C98028C.nas9.dallas2.tx.us.da.qwest.net * BayBe3 GurL
Midnite_Angel01 is using modes +irx
Midnite_Angel01 is connecting from *@hostwashere
Midnite_Angel01 is a registered nick
Midnite_Angel01 on @#shyne
Midnite_Angel01 using HellRaiSeR.ChatUniverse.net The place Hell Raising is Letting Your Hair Down
Midnite_Angel01 End of /WHOIS list.
-
Midnite_Angel01 is connecting from **.***.***.**

would be the results of this, althou it would be good,

Praetorian_

2003-12-04 18:35

reporter   ~0004202

White_Magic:
Your idea works, yes, will acknowledge that.

The problem is this:
* Not Everyone uses mIRC thankfully
* Looking it up twice means double the work, for no need when the server has it already
* If this was implemented, this wouldn't be limited to only showing up in whois', It could be used by services packages for their needs
* DNS Servers from the server may not have the same records as you do (for whatever reason).
* Its called a numeric, not a raw [Something that irritates me!]

Hope you understand that mIRC cannot solve all your problems... and that i didnt sound like an angry old man :p

White_Magic

2003-12-04 18:39

reporter   ~0004204

Last edited: 2003-12-04 18:41

lol naw i know Praetorian_, lol i know its a numeric too but u know, i ahve to keep it simple ( ish ) ;)

* added syzop instead of Praetorian_ sowwie * blush LOL

edited on: 12-04-03 18:41

thilo

2003-12-06 11:30

reporter   ~0004224

codemastr:
Have a look at

http://thilo.kickchat.com/kickservices/crypt.c

You can tell this base64 function how many bytes long the to-be-encrypted data is. In case of ipv6, it would be of course 16 bytes.

thilo

2003-12-06 11:35

reporter   ~0004225

Last edited: 2003-12-06 11:47

sorry for these multiple bugnotes. I have deleted them now.

NOTE: I have only needed base64 _encoding_ function until now in my project anyways, for SMTP-AUTH. Maybe I can be talked to also create some decoding functions.

NOTE2: When converting an ipv6 address to base64, it will result in a 24 bytes long string.

edited on: 12-06-03 11:47

codemastr

2003-12-06 18:28

reporter   ~0004227

Indeed that does, however that's not the base64 Unreal uses.

thilo

2003-12-06 21:14

reporter   ~0004230

Last edited: 2003-12-06 21:16

weird. in the support.c the base64 functions are doing exactly the same mine do. I was not aware of aln.c ;)

By the way, another reason why I eagerly await the introduction of an IP field in a NICK message: my services have to lookup all hosts that its proxy scanner intends to scan. This is unnecessary overhead that could be solved better by transmitting the IP in the first place.

edited on: 12-06-03 21:16

codemastr

2003-12-08 00:40

reporter   ~0004241

Yeah I agree, it is definately a useful feature. It's just a matter of coming up with an implementation that works the way we need it to.

codemastr

2004-05-27 18:08

reporter   ~0006449

Added in .28

Issue History

Date Modified Username Field Change
2003-11-20 23:57 blotter45 New Issue
2003-11-21 05:30 Praetorian_ Note Added: 0004075
2003-11-21 18:30 syzop Note Added: 0004076
2003-11-21 20:42 syzop Status new => acknowledged
2003-11-21 20:42 syzop ETA none => > 1 month
2003-11-21 20:42 syzop Summary feature request => show IP in /whois
2003-11-24 16:10 us44ever Note Added: 0004092
2003-11-25 00:29 codemastr Note Added: 0004107
2003-12-04 18:08 White_Magic Note Added: 0004198
2003-12-04 18:35 Praetorian_ Note Added: 0004202
2003-12-04 18:39 White_Magic Note Added: 0004204
2003-12-04 18:41 White_Magic Note Edited: 0004204
2003-12-06 11:30 thilo Note Added: 0004224
2003-12-06 11:35 thilo Note Added: 0004225
2003-12-06 11:47 thilo Note Edited: 0004225
2003-12-06 18:28 codemastr Note Added: 0004227
2003-12-06 21:14 thilo Note Added: 0004230
2003-12-06 21:16 thilo Note Edited: 0004230
2003-12-08 00:40 codemastr Note Added: 0004241
2004-05-26 22:04 codemastr Status acknowledged => assigned
2004-05-26 22:04 codemastr Assigned To => codemastr
2004-05-27 18:08 codemastr Status assigned => resolved
2004-05-27 18:08 codemastr Resolution open => fixed
2004-05-27 18:08 codemastr Note Added: 0006449