View Issue Details

IDProjectCategoryView StatusLast Update
0001509unrealircdpublic2005-12-10 17:23
ReporterPAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Platformfreebsd, redhat, slackware, mandOSlinux, bsd (possibly win)OS Version2.4.24
Product Version3.2-beta19 
Target VersionFixed in Version3.2.4 
Summary0001509: link::nodnscache generates flood under certain conditions
Descriptionw00t.nix.org.il has link::nodnscache on magi.nix.org.il
X is an oper with default flags (no eyes)
magi tries to connect to w00t (most of the times everything is ok) but rarly (i suspect temp dns outage) it starts flooding all opers with
-magi.nix.org.il- *** Notice -- Hostname w00t.nix.org.il is unknown for server w00t.nix.org.il (!?).
untill the user disconnects with
*** Quits: X (No such file or directory)
had this on beta 17 too, since then didn't use this directive, but now once back using it started again.
Steps To Reproduceadd a link to a host with link::nodnscache
make it autoconnect (or just do connect)
wait till dns outage and be open when it happens.
Additional Informationloop still runs on a server i can't restart, everything ok as long as no opers on it though once someone /oper's he gets flooded out.
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0001148 closed on /connect sometimes i get a notice flood 

Activities

syzop

2004-01-28 00:05

administrator   ~0004773

yes this is same as 0001148 and should/will be fixed before next release (so in the next few weeks).

syzop

2004-02-01 00:55

administrator   ~0004831

1. Could you do '/quote dns i' and paste me the results? 2. And if you can, give me some other hints how to reproduce this? (see next) 3. Do you have autoconnect enabled?

I've tried the non-existing thing.. then I get 2-4 messages when I do /connect, but then they stop... Even if I /connect like 5 times quickly after each other I only get like 5*3 messages... the duplicates are of course not nice but this isn't the flood we were searching for (on a sidenote the duplicates are caused by nameserver retries).

I'm sure I've seen it before, even at my own pc, but I was unable to reproduce it at that time.. and now too :p.

Also tried existing first, then remove dns entry.. let ik expire.. and I get the same results (like 3-4 messages).

Fryth

2004-05-27 11:02

reporter   ~0006445

I got this bug this morning. Autoconnect was enabled (so was nodnscache). When I get home from work I will try to reproduce it. Wow, these other posts are ancient :)

syzop

2004-05-27 11:07

administrator   ~0006446

Ah, finally someone :p.
How bad was the flood?
Was it really like continuesly sending like 10 notices/sec?

Only thing I was able to do was to get such a message 3 times in 10 seconds instead of just once.. but.. that's not really a flood, so there must be some other way to get a REAL bad flood like here in the report... but how! ;).

Any information is welcome :).

Fryth

2004-05-28 22:56

reporter   ~0006454

It happened again, this time without autoconnect set. I typed /connect yadayada, and I was flooded with the 'hostname is unknown' message, about 4 times/sec. No DNS outage involved. Eventually the server actually crashed, which didn't happen last time. Here's a link to the core dump: http://www.fryth.com/wircd.1492.core.txt

syzop

2004-05-29 00:37

administrator   ~0006455

interresting... 4times/sec? guess it varies then... some have reported being totally flooded off..
Damn, I thought finally something that would be helpful (the wircd*core.txt) but it isn't :(.
Your statement that there was no dns outage is also helpful... You mean you were absolutely sure that the box the ircd server was running on would be able to resolve the host? (like you did /dns on a client @ the same box).
I still wonder how to reproduce it however.. Just to be sure... The ip the hostname points to is ipv4? (not ipv6)
How often does it happen with you doing /connect? 1 out of 3? 1 out of 20? etc..
Oh and, do you have autoconnect enabled for that link?
And... do you have multiple servers with nodnscache? (and do they have autoconnect?)
Thanks :).

codemastr

2004-05-29 13:13

reporter   ~0006457

One interesting thing. He said it crashed as a result of /connect, but the backup buffer says rehash was the last command processed. Granted the backup buffer isn't 100% reliable, but it does at least suggest that the crash *might* be unrelated.

Fryth

2004-07-05 18:53

reporter   ~0006874

Last edited: 2004-07-05 18:57

After months of experiencing no problems it happened again today.
I think it was because my net connection went down momentarily. The problem always happens when Unreal tries to reconnect the server link. "Hostname unknown" floods about 10 times per second (it was worse this time). But the server is running on a local network to me, so I don't know if that gave me any immunity to being kicked off. The DNS flood to my ISP was several K per second, all requesting the same thing - the name of the unlinked server. I'm going to use a DNS proxy to circumvent this problem, but it remains.

I'm no hax0r, but I'd like to help solve this any way I can. I'm probably the only schmoe running a Windows-based server, heh. Did I say that out loud?

edited on: 2004-07-05 18:56

edited on: 2004-07-05 18:57

syzop

2004-07-05 21:13

administrator   ~0006875

Ah.. perhaps that info helps (that it's due to autoconnect). I'll have a look when I've time :).
Could you post a small fragment of the flood you got? (feel free to mark the bugnote as private if you consider it sensitive)

Fryth

2004-07-05 21:46

reporter   ~0006876

[18:50] -irc.fryth.com- *** Notice -- Hostname tenjin.lore.com is unknown for server Tenjin.Lore.Com (!?).

Over and over again. Over 100 times per minute. Obviously the second "Tenjin.Lore.Com" is referring to the label of the link block.

Fryth

2004-10-01 23:48

reporter   ~0007843

Confirmed that this bug affects both Windows and Linux. I can't cause the crash 100% of the time (it seems to happen only about 10% of the time) but it happens when servers labelled 'nodnscache' and 'nohostcheck' try to connect.

aquanight

2004-10-02 05:41

reporter   ~0007847

Last edited: 2004-10-02 05:42

Just for the heck of it, does twiddling with class::connfreq affect this at all? Just a thought...

[quote](feel free to mark the bugnote as private if you consider it sensitive)[/quote]

(For the record, I see no button to do that :P .)

*edit* Shoots typo */edit*

edited on: 2004-10-02 05:42

syzop

2005-12-10 17:23

administrator   ~0010854

This should be fixed in CVS (a few weeks ago), with the new resolver.

Issue History

Date Modified Username Field Change
2004-01-25 12:23 P New Issue
2004-01-28 00:05 syzop Note Added: 0004773
2004-02-01 00:55 syzop Note Added: 0004831
2004-05-27 11:02 Fryth Note Added: 0006445
2004-05-27 11:07 syzop Note Added: 0006446
2004-05-28 22:56 Fryth Note Added: 0006454
2004-05-29 00:37 syzop Note Added: 0006455
2004-05-29 13:13 codemastr Note Added: 0006457
2004-07-05 18:53 Fryth Note Added: 0006874
2004-07-05 18:56 Fryth Note Edited: 0006874
2004-07-05 18:57 Fryth Note Edited: 0006874
2004-07-05 21:13 syzop Note Added: 0006875
2004-07-05 21:46 Fryth Note Added: 0006876
2004-10-01 23:48 Fryth Note Added: 0007843
2004-10-02 05:41 aquanight Note Added: 0007847
2004-10-02 05:42 aquanight Note Edited: 0007847
2004-10-08 03:59 syzop Relationship added has duplicate 0001148
2005-12-10 17:23 syzop Status new => resolved
2005-12-10 17:23 syzop Fixed in Version => 3.2.4
2005-12-10 17:23 syzop Resolution open => fixed
2005-12-10 17:23 syzop Assigned To => syzop
2005-12-10 17:23 syzop Note Added: 0010854