View Issue Details

IDProjectCategoryView StatusLast Update
0001522unrealircdpublic2010-11-15 16:51
ReporterPAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformAnyOSOS Version
Product Version 
Target VersionFixed in Version3.2.9-RC1 
Summary0001522: /rehash -global command
DescriptionAdding the ability to rehash all servers with one line.
This will be pretty usefull when the remote include command will become avaliable.
The way I see this working is a supporting version of unreal linked to a supporting version will pass this line, and supporting linked to unsupporting will pass instructions (remote rehash) for each server behind and including the unsupporting one.
Though this is open for suggestions.
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0003707 closed New feature Global Rehash 
child of 0003776 resolvedsyzop Unreal3.2.9 TODO 

Activities

AngryWolf

2004-02-07 18:11

reporter   ~0004900

Imagine an IRC network with two server admins (A and B) and five servers. The first admin (A) has only one server, the others are owned by the second one (B). Let's say, "B" made a change in his/her servers and now ready to rehash all of them with a single command (that is, /rehashall or something you are talking about). After done, "A" shouts "Hey! Who the hell rehashed my server? I haven't finished making changes in my conf files!" Now imagine what would happen on much bigger networks. :-) [Just my thoughts.]

syzop

2004-02-09 04:41

administrator   ~0004914

[strange I thought I replied to this, ah well.. I guess I didn't hit the button or devel*/my isp was down..]

We COULD consider this... and perhaps only rehash remote includes... I mean, I don't find the idea totally stupid.. I thought about it too when I was on a network with remote includes and X servers, it would be very helpful.

Anyway, currently we are preparing for next release (and thus not really implementing new features), so I'll prolly consider this again at some later stage :).

stskeeps

2007-04-27 06:09

reporter   ~0013857

Bump.

crucialstorm

2008-06-22 22:51

reporter   ~0015310

I also requested this feature it would be so nice to have since i have 10 ircd accounts

syzop

2010-07-14 21:08

administrator   ~0016188

I'll do this for 3.2.9 myself. I could 'assign' it right now, but I'm not yet working on it ;).

syzop

2010-11-15 16:51

administrator   ~0016410

Added in .897:
- Added '/REHASH -global' command which will rehash all servers on the
  network. You can also specify options like '/REHASH -global -motd' to
  rehash only the MOTD/RULES/etc. Just like /REHASH <servername> this is a
  NetAdmin-only command. This command is fully backwards compatible with
  older UnrealIRCd version in the sense that it will also REHASH old
  Unreal's. Suggested by 'P' in 0001522.

Issue History

Date Modified Username Field Change
2004-02-07 14:52 P New Issue
2004-02-07 18:11 AngryWolf Note Added: 0004900
2004-02-09 04:41 syzop Note Added: 0004914
2007-04-27 06:09 stskeeps Note Added: 0013857
2007-04-27 06:09 stskeeps Status new => feedback
2008-06-22 22:51 crucialstorm Note Added: 0015310
2008-06-23 03:45 Stealth Relationship added has duplicate 0003707
2010-07-14 21:07 syzop Relationship added child of 0003776
2010-07-14 21:08 syzop QA => Not touched yet by developer
2010-07-14 21:08 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-07-14 21:08 syzop U4: Upstream notification of bug => Not decided
2010-07-14 21:08 syzop U4: Contributor working on this => None
2010-07-14 21:08 syzop Status feedback => acknowledged
2010-07-14 21:08 syzop Note Added: 0016188
2010-11-15 15:19 syzop Assigned To => syzop
2010-11-15 15:19 syzop Status acknowledged => assigned
2010-11-15 16:51 syzop Note Added: 0016410
2010-11-15 16:51 syzop Status assigned => resolved
2010-11-15 16:51 syzop Fixed in Version => 3.2.9-RC1
2010-11-15 16:51 syzop Resolution open => fixed
2010-11-15 16:51 syzop Summary /rehash all command => /rehash -global command