View Issue Details

IDProjectCategoryView StatusLast Update
0003776unrealircdpublic2012-10-20 10:36
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSAllOS VersionAll
Product Version3.2.9-RC1 
Target VersionFixed in Version3.2.9 
Summary0003776: Unreal3.2.9 TODO
DescriptionParent bug of TODO's for 3.2.9.

Additional InformationUsual disclaimer:
* Some things here might not be done, many other things not mentioned here will be done.
* Please do not post any bugnotes here. Post bugnotes in the original bugreports instead. Understand, though, that mass-posting to every and each issue "this should be in next version" will not be appreciated either.
* There's no clear ETA regarding this release, and if any estimate is given at a later point, then understand that these are date/time ESTIMATES, and are rarely 100% correct.
TagsNo tags attached.
3rd party modules

Relationships

parent of 0003755 resolvedohnobinki IPv4 address display incorrectly in the z-lined message when IPv6 support is enabled 
parent of 0003866 resolvedsyzop New Packet hook 
parent of 0003858 resolvedsyzop link::bind-ip in 1.2.3.4 style breaks links on IPv6-enabled build 
parent of 0003867 resolvedsyzop LocOps don't have oper hosts set properly with get_host flag 
parent of 0003863 resolvedsyzop run-time configuration of files (tune, pid, motd) 
parent of 0003885 resolvedsyzop Unreal3.2.8 with UHNAMES: nickname-list LAG & SendQ High 
parent of 0003720 resolvedsyzop ULines and Server can set channel mode +z when insecure users are present causing an "invalid state" of security 
parent of 0002817 resolvedsyzop Request: Extended Invex 
parent of 0003896 resolvedohnobinki any unknown options in ssl::options make ircd to crash 
parent of 0003907 resolvedohnobinki IPv6/4 addrs (::ffff:w.x.y.z) break NICK connection parsing 
parent of 0002321 resolvedohnobinki ipv6 clones checking 
parent of 0003916 resolvedohnobinki upgrade TRE 
parent of 0003918 resolvedohnobinki unable to compile under windows 
parent of 0003893 resolvedohnobinki Firefox XPS IRC Attack 
parent of 0003358 resolvedsyzop missings operoverride notices 
parent of 0003848 resolvedsyzop installer should disallow choosing encrypted certificate if "install as service" is selected 
parent of 0003133 resolvedohnobinki Add SSL client cert documentation (oper, link blocks, etc) 
parent of 0003928 resolvedsyzop Fix chained/stacked bans 
parent of 0003329 resolvedohnobinki Not unsetting all modes on /umode2 -o 
parent of 0002535 resolvedsyzop Ban/TKL Exception Blocks Clarification 
parent of 0002973 closed override bug 
parent of 0003189 resolvedohnobinki improper use of mode_t for DEFAULT_PERMISSIONS in chmod and open operations 
parent of 0003053 resolvedohnobinki Warning when running as root 
parent of 0002620 resolvedohnobinki copying ircdcron/ircdchk to the destination dir with `make install` 
parent of 0001522 resolvedsyzop /rehash -global command 
parent of 0003192 resolvedohnobinki Add a new simple extban 
parent of 0003930 resolvedohnobinki ./configure: line 12887: I: command not found 
parent of 0003931 resolvedohnobinki ircd no longer compiles with curl 
parent of 0003932 resolvedohnobinki Update c-ares to latest version 
parent of 0003933 resolvedsyzop Update coders, donators, etc 
parent of 0003934 resolvedsyzop Update translations 
parent of 0003943 resolvedsyzop loadmodule permission denied errors on windows 
parent of 0003944 resolvedsyzop FreeBSD, IPv6 build, IPv4 listen blocks and *:port listen blocks 
parent of 0003957 resolvedsyzop Remote server disconnects do not get broadcasted via notice 
parent of 0003950 resolvedohnobinki oper-up message uses vhost instead of realhost 
parent of 0003965 resolvedsyzop Windows: Creating SSL cert even if present 
parent of 0003975 resolvedsyzop update doc/compiling_win32.txt 
parent of 0003990 resolvedsyzop Add aliases/atheme.conf 
parent of 0004017 resolvedohnobinki ./unreal gencloak can produce invalid cloak keys 
parent of 0004274 resolvedohnobinki improper use of mode_t for DEFAULT_PERMISSIONS in chmod and open operations 

Activities

syzop

2010-07-14 16:51

administrator   ~0016159

Ok, I'm going to compile a list of things that should/will be done in 3.2.9.
These will be the only issues that will be looked at. (note to my fellow developer ohnobinki: that means only these ones may be committed and the ones we already talked about).

While I may say here and there in a bug that it will be rescheduled for 3.2.10, I won't do that for all 200+ issues.. so if it's not on the list, you may assume it is not scheduled to be in 3.2.9.

I want to release a 3.2.9 someday, and it does not help when constantly new issues get added to the list and patches being committed which are dubious to do right before release.

I'd like to release 3.2.9 this Summer (northern hemisphere ;p), but don't ask for an exact date or month :).

Please give me a few days or so to compile the full list.

syzop

2010-07-14 17:58

administrator   ~0016181

Ok, I'm like 75% through the bugitems now.

Release Critical: 0003916 0003720 0003893 #2837 (last one is private)

I forgot to mention, any doc bugs (be it in the HTML, the tech docs, or helpop etc), you may commit freely :P. There's a closing window for them, to give translators some time to get everything synchronized, but that's to be decided at a later point, and not within a month I think... I'll post a note here when it happens.

syzop

2010-07-14 21:34

administrator   ~0016191

Ok, I've gone through all bugs now. Quite inspiring ideas you see again when you do that, but most of them are for next release or after that... ;p

syzop

2010-09-06 11:07

administrator   ~0016329

Last edited: 2010-09-06 11:09

Are there any bugids I can offer to you binki?
0003893 0003358 0002535 0002973 come to my mind

I'll do 0003720 and 0001522 myself (in that order), and then move on to any remaining issues.
EDIT: I don't know how quickly I'll finish them, it'll be 'next weekend' again ;)

I wouldn't mind if you did 0003848 and/or 0003943 either, but since it's Windows-related... :p

It would be nice if we could finish our work this month (September), and then go into testing mode...

syzop

2010-12-15 17:36

administrator   ~0016460

3.2.9-rc1 released
See http://forums.unrealircd.com/viewtopic.php?f=2&t=6865

syzop

2011-03-08 21:13

administrator   ~0016615

Release (Candidate) blockers:
1) http://forums.unrealircd.com/viewtopic.php?f=3&t=6906 -- I suggested stuff, but nobody is responding back to anymore...
2) 0003972
If those two are dealt with, then I'm fine with a new RC.

I'm busy with my new apartment myself. There must be other people who can deal with this when I'm not around ? :/

mahdkoosh

2011-03-27 23:40

reporter  

unrealircd.conf (20,816 bytes)

syzop

2011-07-17 23:27

administrator   ~0016696

Last edited: 2011-07-17 23:28

View 2 revisions

Regarding previous comment:
Had no response (or help) for 1.
I've scratched nr 2 as I was unable to trace it by looking at the source etc (nor did anyone else test or look at it AFAICT).

I don't want to delay next RC any longer.

As far as I'm concerned, it won't have to take long after RC2 to go for a real 3.2.9 release (eg: a month later, we'll see).

Issue History

Date Modified Username Field Change
2009-01-04 11:48 syzop New Issue
2009-01-04 11:48 syzop QA => Not touched yet by developer
2009-01-04 11:48 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2009-01-04 11:48 syzop U4: Upstream notification of bug => Not decided
2009-01-04 11:48 syzop U4: Contributor working on this => None
2009-01-04 11:49 syzop Relationship added parent of 0003755
2009-08-17 12:02 syzop Sticky Issue No => Yes
2009-08-17 12:02 syzop Relationship added parent of 0003866
2009-09-07 20:27 syzop Relationship added parent of 0003858
2009-09-26 12:16 syzop Relationship added parent of 0003867
2009-09-30 14:16 syzop Relationship added parent of 0003863
2010-01-10 13:52 syzop Relationship added parent of 0003885
2010-02-17 11:34 syzop Relationship added parent of 0003720
2010-03-01 19:58 syzop Product Version 3.2.8 => 3.2.9-RC1
2010-03-01 19:58 syzop Description Updated
2010-03-01 19:58 syzop Additional Information Updated
2010-03-06 20:19 syzop Relationship added parent of 0002817
2010-03-28 20:45 syzop Relationship added parent of 0003896
2010-05-19 03:35 ohnobinki Relationship added parent of 0003907
2010-07-02 09:54 syzop Relationship added parent of 0002321
2010-07-05 13:22 syzop Relationship added parent of 0003916
2010-07-10 02:00 ohnobinki Relationship added parent of 0003918
2010-07-10 02:00 ohnobinki Relationship added parent of 0003919
2010-07-14 16:51 syzop Note Added: 0016159
2010-07-14 17:07 syzop Relationship added parent of 0003893
2010-07-14 17:14 syzop Relationship added parent of 0003358
2010-07-14 17:21 syzop Relationship added parent of 0003702
2010-07-14 17:26 syzop Relationship deleted parent of 0003702
2010-07-14 17:26 syzop Relationship added parent of 0003848
2010-07-14 17:28 syzop Relationship added parent of 0003133
2010-07-14 17:32 syzop Relationship added parent of 0003928
2010-07-14 17:33 syzop Relationship added parent of 0003329
2010-07-14 17:36 syzop Relationship added parent of 0002535
2010-07-14 17:50 syzop Relationship added parent of 0002973
2010-07-14 17:52 syzop Relationship added parent of 0003189
2010-07-14 17:58 syzop Note Added: 0016181
2010-07-14 20:46 syzop Relationship added parent of 0002379
2010-07-14 20:59 syzop Relationship added parent of 0003053
2010-07-14 21:03 syzop Relationship added parent of 0002620
2010-07-14 21:07 syzop Relationship added parent of 0001522
2010-07-14 21:15 syzop Relationship added parent of 0003192
2010-07-14 21:34 syzop Note Added: 0016191
2010-07-15 12:08 syzop Relationship added parent of 0003930
2010-07-15 12:35 syzop Relationship added parent of 0003931
2010-07-15 13:07 syzop Relationship added parent of 0003932
2010-07-15 13:09 syzop Relationship added parent of 0003933
2010-07-15 13:11 syzop Relationship added parent of 0003934
2010-07-19 11:49 syzop Relationship deleted parent of 0003919
2010-08-13 11:07 syzop Relationship added parent of 0003943
2010-08-15 22:08 ohnobinki Relationship added parent of 0003944
2010-08-16 03:02 ohnobinki Relationship added parent of 0003945
2010-08-16 11:36 syzop Relationship deleted parent of 0003945
2010-09-06 10:19 syzop Relationship deleted parent of 0002379
2010-09-06 11:07 syzop Note Added: 0016329
2010-09-06 11:08 syzop Note Edited: 0016329
2010-09-06 11:08 syzop Note Edited: 0016329
2010-09-06 11:08 syzop Note Edited: 0016329
2010-09-06 11:09 syzop Note Edited: 0016329
2010-09-08 17:08 syzop Relationship added parent of 0003957
2010-09-20 14:31 ohnobinki Relationship added parent of 0003950
2010-11-15 15:11 syzop Relationship added parent of 0003965
2010-12-15 17:29 syzop Relationship added parent of 0003975
2010-12-15 17:36 syzop Note Added: 0016460
2010-12-29 18:19 syzop Relationship added parent of 0003990
2011-03-08 21:13 syzop Note Added: 0016615
2011-03-27 23:40 mahdkoosh File Added: unrealircd.conf
2011-03-29 20:08 syzop Relationship added parent of 0004017
2011-06-05 21:37 syzop Relationship added parent of 0003972
2011-07-17 23:24 syzop Relationship deleted parent of 0003972
2011-07-17 23:27 syzop Note Added: 0016696
2011-07-17 23:28 syzop Note Edited: 0016696 View Revisions
2012-02-08 11:27 syzop Status new => resolved
2012-02-08 11:27 syzop Fixed in Version => 3.2.9
2012-02-08 11:27 syzop Resolution open => fixed
2012-02-08 11:27 syzop Assigned To => syzop
2012-10-20 10:36 syzop Sticky Issue Yes => No