View Issue Details

IDProjectCategoryView StatusLast Update
0001883unrealircdpublic2004-06-23 12:25
ReporterGilouAssigned To 
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionopen 
Product Version3.2 
Target VersionFixed in Version 
Summary0001883: Another weird crash
DescriptionNo idea how this happened, still, here is the backtrace ;)
Additional Information#0 0x401b7c1b in free () from /lib/libc.so.6
(gdb) bt
#0 0x401b7c1b in free () from /lib/libc.so.6
#1 0x401b7aa3 in free () from /lib/libc.so.6
#2 0x08064ab4 in free_user (user=0x847b698, cptr=0x82c1c78) at list.c:242
#3 0x08064c46 in remove_client_from_list (cptr=0x82c1c78) at list.c:312
#4 0x080805ca in exit_one_client (cptr=0x81ea6c0, sptr=0x82c1c78, from=0x82c1c78,
    comment=0x81ea7ae "Quit: Download Gaim: http://gaim.sourceforge.net/", split=0)
    at s_misc.c:708
#5 0x08080373 in exit_client (cptr=0x81ea6c0, sptr=0x82c1c78, from=0x82c1c78,
    comment=0x81ea7ae "Quit: Download Gaim: http://gaim.sourceforge.net/") at s_misc.c:581
#6 0x402c292f in ?? ()
#7 0x08068133 in parse (cptr=0x81ea6c0, buffer=0x81ea7a4 ":teuna ,", bufend=0x81ea7df "")
    at parse.c:440
0000008 0x08066f38 in dopacket (cptr=0x81ea6c0,
    buffer=0x813e100 ":teuna , :Quit: Download Gaim: http://gaim.sourceforge.net/\r\nPK_DN\r\nSOY\n", length=61) at packet.c:138
#9 0x0806d1ef in read_packet (cptr=0x81ea6c0, rfd=0xbffffd2c) at s_bsd.c:1447
#10 0x0806dac1 in read_message (delay=2, listp=0x8155d60) at s_bsd.c:1937
#11 0x080640c1 in main (argc=1, argv=0xbffffe74) at ircd.c:1451
TagsNo tags attached.
3rd party modules

Relationships

related to 0002032 resolvedsyzop Weird crash, maybe parse again, or something else .. 

Activities

codemastr

2004-06-18 23:25

reporter   ~0006703

Is this before or after you upgraded to fix the other problem?

Please type, /info and then give us the ReleaseId number. That will help us figure this out.

Gilou

2004-06-19 04:55

reporter   ~0006704

It was before, as we didn't upgrade yet.
[10:54:36] *** ReleaseID (1.1.1.1.2.16 2004/04/24 23:53:42)

codemastr

2004-06-19 11:40

reporter   ~0006706

Well as Syzop said, don't report a new crash until you upgrade. All of these are probably the exact same bug.

syzop

2004-06-19 14:16

administrator   ~0006709

Last edited: 2004-06-19 14:18

Looks like a different one (other one was OOB read.. so no write/whatever), but this is heap corruption, so.. not exactly tracable by this output.
Still, just as codemastr, I think you should seriously consider upgrading (perhaps not your whole net, just this server) to current CVS, something might be fixed in CVS... I don't know.
Also when doing that, please do NOT use any modifications... so: just a clean 3.2 CVS server.

That's my advice, which would give you the fastest support, if you decide to ignore it and continue to run [whatever] that crashes.. that's your decision.
I don't say it's fixed in latest CVS, I've no idea at all, I'm just saying I could give much better and faster suppot... and to be honest I don't see the advantage for you to keep running the version you have now that is constantly crashing ;p.

NOTE: This is very standard procedure, in fact.. normally we delete bugreports immediately if people are using a modified ircd. These requirements are also mentioned in 'Main' - 'How to post a bug'. Furthermore, we often ask people that had weird crashbugs to use latest CVS since usually several bugs are fixed.

**clarification: really NO source modifications, so not editting the 'Config' script or src/modules/m_whois.c to change how opers show up in whois, or put ifdefs/whatever everywhere.. nothing.**

edited on: 2004-06-19 14:18

Gilou

2004-06-23 09:39

reporter   ~0006770

Last edited: 2004-06-23 09:40

Well... Our Config script modification are to have the curl & ares thing compiled / installed automatically in the way we want it. The modification for whois, the translation of the Config script ... are minor modification. If that's too much, have an easier install for remote includes, and a built-in translation system for the installation script, and take our modification wishes more seriously.
We aren't a small network, we want our IRCds to act the way we expect them to act. And of course, we do appreciate Unreal features, so we would also appreciate it to be reliable ;)

Here's another core file, on an IRCd which was patched with the findsqline thing, maybe you can ignore the first core I submitted then ;)

[15:33:09] *** Info for [besancon3.fr.epiknet.org]
[snip]
[15:33:10] *** Birth Date: sam jun 19 2004 at 13:50:24 CEST, compile # 1
[15:33:10] *** On-line since Wed Jun 23 15:30:00 2004
[15:33:10] *** ReleaseID (1.1.1.1.2.16 2004/04/24 23:53:42)

(gdb) backtrace
#0 0x0806a465 in find_cache_number (rptr=0x0, numb=0x8187e48 "Ùm¯¾\022é")
    at res.c:1301
#1 0x080694c0 in gethost_byaddr (addr=0x8187e48 "Ùm¯¾\022é", lp=0xbffff700)
    at res.c:420
#2 0x0806e0d2 in start_of_normal_client_handshake (acptr=0x8187e48)
    at s_bsd.c:1353
#3 0x0806ddff in add_connection (cptr=0x81a2e30, fd=109) at s_bsd.c:1337
#4 0x0806e8cb in read_message (delay=1, listp=0x81554e0) at s_bsd.c:1872
#5 0x08064677 in main (argc=1087997341, argv=0x0) at ircd.c:1432
#6 0x401a77f7 in __libc_start_main () from /lib/i686/libc.so.6
(gdb)

modifié le : 2004-06-23 09:40

syzop

2004-06-23 12:25

administrator   ~0006771

Well, I can't help it you can't understand english, that you find ./curlinstall too difficult, and that you are unable to understand that we don't accept any idea in the world... UnrealIRCd would be horrible if we did that.

It's not like you changed 1 line of code, the diff is >1000 lines! Who knows what bugs you all introduced! Perhaps 10, perhaps 0.. I'm not trusting it. I even helped you a lot more already than I should.

If you *REFUSE* to meet our support requirements, we cannot help you.
You were well aware of these requirements, you simply decided (*several times*) to ignore them.

Upgrade to latest CVS - unmodified.

I even asked you to _do it just on 1 server_, but nooooo... let's just ignore unreal developers.. they are evil and just love to irritate admins.

If you had just followed all instructions then your crashes could have been resolved days ago.

To save you some time if you perhaps (I'm an optimist!) would actually follow the instructions [which is: latest cvs, unmodified ON 1 SERVER] , also do http://www.vulnscan.org/tmp/unreal_mpatrol.txt when you are at it.

If you would have been a bit more friendly I would have done all this work for you (log into the shell, set it up, debug.. etc), something which I did for several other networks in the past when they experienced problems that required tracing.

Issue History

Date Modified Username Field Change
2004-06-18 13:16 Gilou New Issue
2004-06-18 23:25 codemastr Note Added: 0006703
2004-06-19 04:55 Gilou Note Added: 0006704
2004-06-19 11:40 codemastr Note Added: 0006706
2004-06-19 14:16 syzop Note Added: 0006709
2004-06-19 14:17 syzop Note Edited: 0006709
2004-06-19 14:18 syzop Note Edited: 0006709
2004-06-23 09:39 Gilou Note Added: 0006770
2004-06-23 09:40 Gilou Note Edited: 0006770
2004-06-23 12:25 syzop Status new => closed
2004-06-23 12:25 syzop Note Added: 0006771
2004-10-10 17:55 syzop Relationship added related to 0002032