View Issue Details

IDProjectCategoryView StatusLast Update
0002163unrealircdpublic2006-01-02 14:45
ReporterJoMama Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.2.2 
Summary0002163: Link option "quarantine" is ignored
DescriptionThe ircd seems to completely ignore the option "quarantine".

Hub link block:

link irc.foonet.com
{
username *;
hostname 66.111.59.39;
bind-ip *;
port 7000;
leaf *;
password-connect "link";
password-receive "link";
class servers;
options {
quarantine;
};
};


Leaf link block:

link irc.sourcefields.com {
username *;
hostname 66.111.59.35;
bind-ip *;
port 7000;
hub *;
password-connect "link";
password-receive "link";
class servers;
options {
autoconnect;
};
};


Oper on leaf server:

-irc.foonet.com- *** Permanent G:Line added for *@*asdasasdds.com on Mon Nov 8 20:01:29 2004 GMT (from WS!lol@D3FF4396.DE396002.6592C09E.IP: no reason)
-

Notice on hub server:

-irc.sourcefields.com- *** Permanent G:Line added for *@*asdasasdds.com on Mon Nov 8 20:01:29 2004 GMT (from WS!lol@D3FF4396.DE396002.6592C09E.IP: no reason)
-


user 'WS' can also globally kill anyone on the network, even tho they are an oper on a server that is supposed to be quarantined.
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0002510 resolvedsyzop Server link option "quarantine" doesn't do what it says it does 

Activities

JoMama

2004-11-08 15:14

reporter   ~0008265

Also, I would like to add that if quarantine doesn't already do this, can you make it do this?

I would like quarantine to not only make all opers on the linking server local opers, but also not allow any glines that are on that server to be passed to the rest of the network. I would also like it if any servers that are linked to the quarantined server to also be quarantined.

aquanight

2004-11-08 15:41

reporter   ~0008266

Well, for the local oper stuff, I think there's two ways that it could be fixed:

- The privilege macros add checks for quarantine and return False if the oper's server (is not "me" and) is quarantined.
or...
- The usermode parser simply drops the global oper flags if the server it is received from is quarantined. E.g. drop +oCAaN et al.

JoMama

2004-11-08 15:48

reporter   ~0008267

<EviL_SmUrF> also what about the gline stuff?
<EviL_SmUrF> did u see any code in there for glines?
<aquanight> I haven't looked at GLINE yet
<aquanight> but realize that the server-server bit is done with TKL
<aquanight> so I dunno
<EviL_SmUrF> that could probably be taken care of easily by either an unreal module or anope module
<EviL_SmUrF> ie "if GLINE wasn't added via services.server, remove it"
<aquanight> doesn't stop it from having a brief momentary effect
<EviL_SmUrF> yeah
<aquanight> eg
<EviL_SmUrF> but better than nothing ;)
<aquanight> if 70% of your users are from cableone.net
<aquanight> I can /gline *@*.cableone.net
<aquanight> and 70% of your users get disconnected
<aquanight> even though the gline won't stay long
<EviL_SmUrF> well u wouldnt be able to do that if quarantine was enabled. i just dont want someone to be able to /squit from the network, add the gline, then /connect back up and have the gline pass to the rest of the network via the server
<aquanight> yeah
<aquanight> quarantine probably should not allow glines to slip in
<aquanight> eg, TKL = dropped
<aquanight> but we'll see

JoMama

2004-11-08 16:06

reporter   ~0008268

something else new has been learned. even tho opers on quarentined servers can still send global kills and add glines, services doesnt see them as an oper and denies access to operserv to them.

syzop

2006-01-02 14:45

administrator   ~0010915

See 0002510

Issue History

Date Modified Username Field Change
2004-11-08 15:09 JoMama New Issue
2004-11-08 15:14 JoMama Note Added: 0008265
2004-11-08 15:41 aquanight Note Added: 0008266
2004-11-08 15:48 JoMama Note Added: 0008267
2004-11-08 16:06 JoMama Note Added: 0008268
2006-01-02 14:42 syzop Relationship added duplicate of 0002510
2006-01-02 14:45 syzop Status new => closed
2006-01-02 14:45 syzop Note Added: 0010915
2006-01-02 14:45 syzop Resolution open => fixed