View Issue Details

IDProjectCategoryView StatusLast Update
0002510unrealdocumentationpublic2006-01-02 14:45
ReporterEviL_SmUrFAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSCentOS 4OS Version4
Product Version3.2.3 
Target VersionFixed in Version3.2.4 
Summary0002510: Server link option "quarantine" doesn't do what it says it does
DescriptionAccording to the documentation, the server link option "quarantine" should make it so that any oper on any server linked under that option should only have local oper powers. They still have global powers even if they are linked under that option as far as I can tell. I linked a test server with "quarantine" enabled and the test oper on that server could kill me across the network.

If you guys take a look at this and fix this bug, if you have time I would like some other things enabled, if they aren't already for this option. I would like it so that any server linked to a server with the quarantine option also falls under this quarantine, as well as any server linked under quarantine that has G-lines on it, will not be allowed to pass the G-lines to the rest of the network.
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0001968 closed Link quarantine 
has duplicate 0002163 closed Link option "quarantine" is ignored 

Activities

EviL_SmUrF

2005-05-02 00:45

reporter   ~0009876

oops, meant to put this under "ircd"


also the reason why i put it as major is because of the whole fact that opers that are *supposed* to be only local have full global powers.

aquanight

2005-05-02 12:10

reporter   ~0009877

Funny enough, search for 'quarantine' and you get (now) 5 bug posts about this same thing ... :P

EviL_SmUrF

2005-05-02 13:26

reporter   ~0009881

I wonder when someone plans on addressing this issue... :P

EviL_SmUrF

2005-10-31 16:38

reporter   ~0010622

So, are we gonna have any updates on this bug?

syzop

2005-12-09 16:49

administrator   ~0010845

I'm just going to make it kill, and that's as far as I'm willing to go[*]... it has been explained 423472 times that doing checks for things like glines, etc, is not a complete solution and only causes a false sense of security.

[*] I wished I could simply make it -oN[etc] but that's not possible, or at least not in a backward compatible way, so just a simply kill on +o will do

syzop

2006-01-02 14:45

administrator   ~0010917

Fixed in CVS [.404].

Changelog entry:
- Made the link::options::quarantine actually do something... People that get global
  oper privileges on quarantined servers will be instantly killed. Bit ugly perhaps, but
  then it actually does what it should (prevent opers on quarantine from getting GLOBAL
  oper privileges). This "fixes" 0002510, 0002163 and 0001968.

Issue History

Date Modified Username Field Change
2005-05-02 00:35 EviL_SmUrF New Issue
2005-05-02 00:45 EviL_SmUrF Note Added: 0009876
2005-05-02 12:10 aquanight Note Added: 0009877
2005-05-02 13:26 EviL_SmUrF Note Added: 0009881
2005-10-31 16:38 EviL_SmUrF Note Added: 0010622
2005-12-09 16:49 syzop Note Added: 0010845
2005-12-09 16:49 syzop Assigned To => syzop
2005-12-09 16:49 syzop Status new => assigned
2006-01-02 14:42 syzop Relationship added has duplicate 0001968
2006-01-02 14:42 syzop Relationship added has duplicate 0002163
2006-01-02 14:45 syzop Status assigned => resolved
2006-01-02 14:45 syzop Fixed in Version => 3.2.4
2006-01-02 14:45 syzop Resolution open => fixed
2006-01-02 14:45 syzop Note Added: 0010917