View Issue Details

IDProjectCategoryView StatusLast Update
0002406unrealircdpublic2019-10-14 15:39
ReporterRon2KAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version5.0.0-alpha3 
Summary0002406: [Feature Request] /ELINE - exceptions for /GLINE
DescriptionThis is a request for an /ELINE command; it would place /GLINE exceptions (much like channel mode +e can override channel mode +b).

(Feel free to change the name /ELINE if you don't like it.)

Having such a command would allow GLINE exceptions to be set on the fly (currently, one has to add a ban exceptions block and rehash, which could be impractible in some situations). The command should take the same parameters and have the same syntax as the /GLINE command.

ELINEs could also be set to expire after a set time period, much like GLINEs.

Additionally, services packages should be able to take advantage of this feature (IRCServices would be able to do so if the EnableExclude option was enabled). Currently, IRCServices (and probably other services packages as well) do not set GLINEs if autokill exceptions are enabled, due to the lack of this feature, and instead fall back to issuing a /KILL for users that match autokill masks. This causes more traffic on the network (as well as the possibility that an autokilled user will get a message in before the /KILL is sent if the network is laggy enough).

I thought of this after reading a forum post by Zell; and therefore think that he should be co-credited with this should it be implemented. (Reference: http://www.phpmemx.net/~unrealir/forums/viewtopic.php?t=1592)

Hopefully I've submitted all required information for this request. If there's anything that you think that I've left out, please let me know.
 
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0003078 closed G:line (Autokill) exceptions 
has duplicate 0003365 closed TKL Except for U:Lined Services 

Activities

Zell

2005-03-07 15:45

reporter   ~0009481

Righty-o. Coders of Unreal: should this feature be implemented, a module for Anope will be created forthwith. The closer the code is to the m_tkl code, the easier it will be for Services packages to implement the feature in services.

I (and anyone else who wants to) will make a module for anope upon completion of this feature.
Other services coders, now is your time to be ready for this feature.

vonitsanet

2005-03-09 03:25

reporter   ~0009540

I will be very happy if this was added sometime:P
We need many times akill exceptions but we cant enable it coz ircservices does not add glines..

medice

2005-03-09 03:50

reporter   ~0009542

why do you use akills, since unreal supports gline which is imo easier to handle

vonitsanet

2005-03-09 06:41

reporter   ~0009544

medice this is not the point of this thing.
I said IF i use the akill exception feature for ircservices (and other services packages) and add an akill... services does not add glines because unrealircd does is not supporting glines exceptions (ELINES).
So servces can't manage exceptions with any other way..
They just issue /kill for the akills and allows the exceptions to pass.

Knippy

2005-04-03 21:29

reporter   ~0009701

I like this idea

Ron2K

2006-01-20 12:59

reporter   ~0010985

Syzop/codemaster: any word on this one?

(Yeah, I know, I should have followed up on this a LOT earlier, but my computer has been up the creek without a paddle for the last few months. BTW: I'm not expecting this to go into 3.2.x)

Zell

2006-01-20 15:29

reporter   ~0010986

Time for my two cents again =)

I still think the ELINE is a good command addition. Some servers/ircds already support exemptions... anyone remember AKILLEX/RAKILLEX ? Bingo =)

$0.02 deposited to Bugs forum. :-P

JasonTik

2006-01-20 19:47

reporter   ~0010989

Last edited: 2006-01-21 14:52

I have an issue with this command. What does it exempt you from? gline? ok. how about gzline, shun, kline, zline, and other things like that. will it override config bans?

Whatever you say it will or wont do, I'm a user who wants it the other way. (So really, this is impractical unless we add another field, which breaks TKL compatibility.)

Ron2K

2006-01-22 02:13

reporter   ~0011002

Last edited: 2006-01-22 02:25

Which is why, in my opinion, it should only be added (if at all) when 3.3 gets developed.

Now let's see... it would only affect glines, seeing as that's the only thing that you can have exceptions for in the conf file (EDIT: OK, just opened up the conf file and I'm horribly wrong, but seeing as services programs will probably only support gline exceptions (eg ircservices), let's keep it as gline exceptions only. Feel free to disagree with me here if you want.) I'm not sure whether or not this should override conf bans and I'm prepared to listen to both sides of that argument.

Zell

2006-01-22 16:37

reporter   ~0011020

m, maybe.

As it stands, lets take an example of the opposite.
Suppose you have a config exemption for kline on NiceGuy@*.rr.com
Suppose you /kline *@*.rr.com 0 :Bug off
Mr. NiceGuy does not get klined (the new command issued did not override the config)

So in that sense, the ELINE command shouldnt override config bans...

But on the other side, if you have a nasty config ban (that for some reason is wide but necessary (*.aol.com, anyone?)), then you can on-the-fly exempt specific users.. (StarChat does this with their AOL Registration script on their website)

Ron2K

2006-01-26 12:12

reporter   ~0011065

Zell, you make a valid point. What I'll do is take a look at InspIRCd (if I can get it to compile on Cygwin) and see how they implement it. They have /ELINE, if I remember correctly.

vonitsanet

2006-01-28 16:31

reporter   ~0011094

Is this on TODO for 3.2.4 or is something for the 3.3.x ?

Stealth

2006-01-28 20:55

reporter   ~0011096

If this already is not in 3.2.4, it won't be in it... Maybe next version

Ron2K

2006-02-23 11:25

reporter   ~0011288

OK, I haven't been able to get InspIRCd working (I'm probably doing something stupid) - but I've been thinking about the whole overriding conf bans idea, and I think that Zell is right there - this shouldn't override them.

syzop

2006-02-23 15:00

administrator   ~0011289

Strange I never commented on this one, guess I only talked with codemastr about it (long ago).

I find this a nice feature, and I don't exclude the possibility that it will end up in 3.2* ;).

aquanight

2006-02-25 00:08

reporter   ~0011295

Last edited: 2006-02-25 00:08

If it's going to exempt from gline only then whether or not it overrides conf bans is moot: G:Lines can't be set in the conf.

KnopeX

2010-08-25 10:12

reporter   ~0016311

Last edited: 2010-08-25 10:12

You mean ELINE like except ban { } and/or except tkl { } ?
Nice idea BTW :)

Zell

2010-08-25 15:32

reporter   ~0016313

KnopeX: Yes, exactly.

Coders: Any word on this actually getting implemented?

syzop

2012-10-06 12:25

administrator   ~0017150

Nice idea, but nobody worked on it. Was on TODO for 3.2.10, now being rescheduled to 3.2.11.

syzop

2019-10-14 15:39

administrator   ~0020977

This is done in UnrealIRCd 5 alpha.

Issue History

Date Modified Username Field Change
2005-03-07 13:54 Ron2K New Issue
2005-03-07 15:45 Zell Note Added: 0009481
2005-03-09 03:25 vonitsanet Note Added: 0009540
2005-03-09 03:50 medice Note Added: 0009542
2005-03-09 06:41 vonitsanet Note Added: 0009544
2005-04-03 21:29 Knippy Note Added: 0009701
2006-01-20 12:59 Ron2K Note Added: 0010985
2006-01-20 15:29 Zell Note Added: 0010986
2006-01-20 19:47 JasonTik Note Added: 0010989
2006-01-20 19:48 JasonTik Note Edited: 0010989
2006-01-21 14:52 JasonTik Note Edited: 0010989
2006-01-22 02:13 Ron2K Note Added: 0011002
2006-01-22 02:25 Ron2K Note Edited: 0011002
2006-01-22 16:37 Zell Note Added: 0011020
2006-01-26 12:12 Ron2K Note Added: 0011065
2006-01-28 16:31 vonitsanet Note Added: 0011094
2006-01-28 20:55 Stealth Note Added: 0011096
2006-02-23 11:25 Ron2K Note Added: 0011288
2006-02-23 15:00 syzop Note Added: 0011289
2006-02-25 00:08 aquanight Note Added: 0011295
2006-02-25 00:08 aquanight Note Edited: 0011295
2006-09-30 13:03 aquanight Relationship added has duplicate 0003078
2007-04-27 03:21 stskeeps Status new => acknowledged
2007-05-29 05:46 aquanight Relationship added has duplicate 0003365
2010-07-14 21:31 syzop Relationship added child of 0003915
2010-08-25 10:12 KnopeX Note Added: 0016311
2010-08-25 10:12 KnopeX Note Edited: 0016311
2010-08-25 15:32 Zell Note Added: 0016313
2012-10-06 12:25 syzop Note Added: 0017150
2012-10-06 12:26 syzop Relationship deleted child of 0003915
2019-10-14 15:39 syzop Assigned To => syzop
2019-10-14 15:39 syzop Status acknowledged => resolved
2019-10-14 15:39 syzop Resolution open => fixed
2019-10-14 15:39 syzop Fixed in Version => 5.0.0-alpha3
2019-10-14 15:39 syzop Note Added: 0020977