View Issue Details

IDProjectCategoryView StatusLast Update
0002734unrealircdpublic2006-11-24 15:07
ReporterUnDeRTaKeRAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformi686OSWindowsOS VersionXP SP2
Product Version3.2.3 
Target VersionFixed in Version3.2.6 
Summary0002734: wircd fail to initialize on /restart command
Descriptionwircd fail to initialize on /restart <password> command,
it terminates the server, but dont initialize,
I've given a reason, without a reason, and in any of this ways works.
I've tested the command in other windows and the same thing happened.
WinXP, Win2000 SP4,
different hardware as well, but always i686,
the ircd.log does not log anything,
I installed Unreal all by its default options, I am not the only
person who has experienced this error, but I could not say the winver of
that other people were using...
I attached a image with the message on my computer...
TagsNo tags attached.
3rd party modules

Activities

2006-01-02 03:34

 

report.JPG (27,937 bytes)

UnDeRTaKeR

2006-01-02 03:53

reporter   ~0010913

Im sorry, I forgot to add the /info,
Birth Date: Sun Mar 13 21:40:50 2005, compile # 1
On-line since Mon Jan 02 04:46:20 2006
ReleaseID (1.1.1.1.2.1.2.1.2.2234.2.344 2005/03/13 20:24:29)

syzop

2006-01-02 08:36

administrator   ~0010914

Hm, interesting.. I'm able to reproduce it now (in the past I couldn't).

Issue confirmed.

syzop

2006-01-16 15:05

administrator   ~0010964

half-working workaround now in CVS / .413.
now you can only restart once... ;)

Bock

2006-11-16 04:15

reporter   ~0012664

hm...

"F:\Unreal-cvs>unreal.exe restart
UnrealIRCd NT Service successfully restarted
F:\Unreal-cvs>unreal.exe restart
UnrealIRCd NT Service successfully restarted
F:\Unreal-cvs>unreal.exe restart must be restarted
UnrealIRCd NT Service successfully restarted
F:\Unreal-codepage>
"
in ircd:
 -nol.bynets.org- Server Terminating.


And all is look like ok. restart server from /restart pass reason - ok too..
   Birth Date: Wed Nov 8 00:31:26 2006, compile # 2
   On-line since Thu Nov 16 12:09:23 2006
   ReleaseID (1.1.1.1.2.23 2006/06/16 18:29:12)

Win XPSP2...

BuHHunyx

2006-11-16 10:03

reporter   ~0012667

Last edited: 2006-11-16 10:05

I can't reproduce this too...
Unreal 3.2.5, W2K SP4 Server

syzop

2006-11-16 10:04

administrator   ~0012668

The bug is not in unreal restart, but the /RESTART cmd.

When you /RESTART the first time, it works ok. When you try /RESTART the second time it might error. Try that :P

syzop

2006-11-16 10:05

administrator   ~0012669

Last edited: 2006-11-16 10:06

This was in GUI mode btw. So be sure to mention which mode you use (service or GUI).

EDIT: 'service', not 'services'

Bock

2006-11-16 10:43

reporter   ~0012671

I try do from oper console 5-6 times - all is ok on GUI mode and service. Restarting with reason/without reason - all is ok. :-\

syzop

2006-11-16 10:59

administrator   ~0012672

In which directory do you have Unreal installed? Does it contain spaces? (like C:\Program Files\Unreal3.2)

Bock

2006-11-16 11:05

reporter   ~0012673

Last edited: 2006-11-16 11:09

No, no contains :]

EDIT: renamed directory from Unreal-cvs to "Unreal cvs" and after 2-nd restart no popups, but server not starting.
Problem founded? :]

syzop

2006-11-16 11:14

administrator   ~0012674

Oh I already know that it's because of spaces, it's just so crappy that I have no solution ;). I hate the win32 stuff, as you might know ;P

Bock

2006-11-16 11:24

reporter   ~0012675

So, if I try start from cmd:
"F:\Unreal cvs>wircd 2>123.txt"
it's work fine and restart many times without errors.

If I just double-clicked on wircd.exe from directory contains spaces - after second restart I get:

[19:20:50] -nol.bynets.org- *** Notice -- Server is Restarting by request of Bock
[19:20:50] -nol.bynets.org- *** Notice -- Aieeeee!!! Restarting server... No reason
[19:20:50] * Disconnected
[19:20:55] * Connect retry #1 localhost (6667)
[19:20:56] * Unable to connect to server (Connection refused)
[19:21:01] * Connect retry #2 localhost (6667)
[19:21:02] * Unable to connect to server (Connection refused)

And no error in logs and no popups, but server don't run.

Bock

2006-11-17 03:42

reporter   ~0012682

patch provided by BuHHunyx and Bock. Resolves this bug.

2006-11-17 03:42

 

ircd.c.diff (808 bytes)

syzop

2006-11-24 15:07

administrator   ~0012712

Fixed in CVS of 32* and 33*:
- Fixed belarussian-w1251 charset.. accidently copied a "'" which caused an internal
  error, reported by Bock (0003114).
- Added information about extbans to help.conf (/HELPOP ?EXTBANS). Patch from Bock
  (0003113).
- Made SAPART work for mulitple channels, just like SAJOIN. Patch provided by Bock
  (0003064). This also fixes SAPART now being announced to all opers globally, just
  like SAJOIN.
- Finally fixed /RESTART issue on windows for good, should now always restart correctly.
  Patch provided by BuHHunyx and Bock (0002734).

Issue History

Date Modified Username Field Change
2006-01-02 03:34 UnDeRTaKeR New Issue
2006-01-02 03:34 UnDeRTaKeR File Added: report.JPG
2006-01-02 03:53 UnDeRTaKeR Note Added: 0010913
2006-01-02 08:36 syzop Note Added: 0010914
2006-01-02 08:36 syzop Status new => confirmed
2006-01-16 15:05 syzop Note Added: 0010964
2006-01-16 15:42 syzop Relationship added child of 0002748
2006-04-27 18:28 syzop Relationship deleted child of 0002748
2006-11-16 04:15 Bock Note Added: 0012664
2006-11-16 10:03 BuHHunyx Note Added: 0012667
2006-11-16 10:04 syzop Note Added: 0012668
2006-11-16 10:04 BuHHunyx Note Edited: 0012667
2006-11-16 10:05 BuHHunyx Note Edited: 0012667
2006-11-16 10:05 syzop Note Added: 0012669
2006-11-16 10:06 syzop Note Edited: 0012669
2006-11-16 10:43 Bock Note Added: 0012671
2006-11-16 10:59 syzop Note Added: 0012672
2006-11-16 11:05 Bock Note Added: 0012673
2006-11-16 11:09 Bock Note Edited: 0012673
2006-11-16 11:14 syzop Note Added: 0012674
2006-11-16 11:24 Bock Note Added: 0012675
2006-11-17 03:42 Bock Note Added: 0012682
2006-11-17 03:42 Bock File Added: ircd.c.diff
2006-11-24 15:07 syzop Status confirmed => resolved
2006-11-24 15:07 syzop Fixed in Version => 3.2.6
2006-11-24 15:07 syzop Resolution open => fixed
2006-11-24 15:07 syzop Assigned To => syzop
2006-11-24 15:07 syzop Note Added: 0012712