View Issue Details

IDProjectCategoryView StatusLast Update
0003064unrealircdpublic2006-11-24 15:07
ReporterSeigHartAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformeveryOSeveryOS Versionevery
Product Version3.2.5 
Target VersionFixed in Version3.2.6 
Summary0003064: SAPART not supporting multiple channels
DescriptionWhen you do /sajoin you can do it this way. /sajoin nick #1,#2,#3 At helpop says you can do the same with /sapart so you could use /sapart nick #1,#2,#3 Message. The thing is that doesn't handle the channel sequences properly
It says ---> no such channel: #1,#2,#3
TagsNo tags attached.
3rd party modules

Activities

syzop

2006-09-18 19:27

administrator   ~0012403

beta11? that's very old...

On 3.2.5 this works fine, if you put actual channel names there...
/sajoin nick #a,#b,#c

Works fine

syzop

2006-09-19 06:32

administrator   ~0012404

It has been said that:
a) You are actually on 3.2.5 (not beta11)
b) It's SAPART, not SAJOIN, I misread.
c) The channels are actually specified as #one,#two,#three (in digits) but mantis is hiding them as 1,2,3

We usually close beta* bugs on-sight without reading them. Due to your version field, I thought you were one of those idiots again running 3.2-beta* and complaining about the old sajoin bug that got fixed a few versions ago :P.

Bug is now open again.

syzop

2006-09-19 06:37

administrator   ~0012405

Hm actually I didn't that much "misread"... The TITLE is "/SAJoin" ! :P

I'm renaming it.

Bock

2006-11-16 15:36

reporter   ~0012677

confirmed.
3.2.4 and 3.2.5 both.

Bock

2006-11-18 07:28

reporter   ~0012686

patch written by me, must fix this bug and http://bugs.unrealircd.org/view.php?id=3051

2006-11-18 07:28

 

m_sapart.c.diff (2,474 bytes)

syzop

2006-11-24 15:07

administrator   ~0012714

Added in CVS of 32* and 33*:
- Fixed belarussian-w1251 charset.. accidently copied a "'" which caused an internal
  error, reported by Bock (0003114).
- Added information about extbans to help.conf (/HELPOP ?EXTBANS). Patch from Bock
  (0003113).
- Made SAPART work for mulitple channels, just like SAJOIN. Patch provided by Bock
  (0003064). This also fixes SAPART now being announced to all opers globally, just
  like SAJOIN.
- Finally fixed /RESTART issue on windows for good, should now always restart correctly.
  Patch provided by BuHHunyx and Bock (0002734).

Issue History

Date Modified Username Field Change
2006-09-18 19:22 SeigHart New Issue
2006-09-18 19:27 syzop Status new => closed
2006-09-18 19:27 syzop Note Added: 0012403
2006-09-18 19:27 syzop Resolution open => no change required
2006-09-19 05:54 stskeeps Status closed => new
2006-09-19 06:32 syzop Note Added: 0012404
2006-09-19 06:32 syzop Product Version 3.2-beta11 => 3.2.5
2006-09-19 06:37 syzop Note Added: 0012405
2006-09-19 06:37 syzop Summary /SAJoin => SAPART not supporting multiple channels
2006-11-16 15:36 Bock Note Added: 0012677
2006-11-18 07:28 Bock Note Added: 0012686
2006-11-18 07:28 Bock File Added: m_sapart.c.diff
2006-11-24 15:07 syzop Status new => resolved
2006-11-24 15:07 syzop Fixed in Version => 3.2.6
2006-11-24 15:07 syzop Resolution no change required => fixed
2006-11-24 15:07 syzop Assigned To => syzop
2006-11-24 15:07 syzop Note Added: 0012714