View Issue Details

IDProjectCategoryView StatusLast Update
0002864unrealdocumentationpublic2006-11-16 16:36
ReporteraquanightAssigned Toaquanight 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSLinux GentooOS Version2.6.12
Product Version3.2.4 
Target VersionFixed in Version3.3-alpha0 
Summary0002864: link::leaf-depth incorrect, also link::hub/leaf
Descriptionlink::leaf-depth is listed in the unreal32docs.html, but s_conf.c expects leafdepth (with no dash).

Also, I think we need slightly better documentation about the effects of the hub and leaf directives. Particularly I don't really think the documentation is clear/accurate on what the leaf directive actually does (judging from modules/m_server.c, it should be documented as the mask of servers a hub can't link :) ).
Steps To ReproduceFrom grep -n leafdepth s_conf.c :
5893: else if (!strcmp(cep->ce_varname, "leafdepth"))
6105: else if (!strcmp(cep->ce_varname, "leafdepth"))
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0003083 resolvedaquanight leaf-depth should be leafdepth 
duplicate of 0002623 resolvedaquanight Hub vs. Leaf 

Activities

JasonTik

2006-03-23 17:32

reporter   ~0011427

Last edited: 2006-03-23 17:32

Also, I was unclear as to how a hub *; leaf *.com; would be processed.

How about a leaf *.com; with no other hub/leaf?

Or a hub *; leaf *.com; hub *.coolguys.com;

aquanight

2006-03-23 17:33

reporter   ~0011428

The third would probably give you a "duplicate directive" error :P. And then the hub couldn't link anything because iirc the second directive applies :P .

syzop

2006-03-23 18:47

administrator   ~0011430

Personally I've never understood it either, so I guess that says it all.. :P

Then again, I never had a XX server net, so I never cared to look at it.. personally (lazy... hub *;)

aquanight

2006-11-16 16:36

reporter   ~0012680

Fixed in devel CVS .2299.

Issue History

Date Modified Username Field Change
2006-03-23 17:29 aquanight New Issue
2006-03-23 17:32 JasonTik Note Added: 0011427
2006-03-23 17:32 JasonTik Note Edited: 0011427
2006-03-23 17:33 aquanight Note Added: 0011428
2006-03-23 18:47 syzop Note Added: 0011430
2006-11-16 16:34 aquanight Relationship added duplicate of 0003083
2006-11-16 16:34 aquanight Relationship added duplicate of 0002623
2006-11-16 16:36 aquanight Note Added: 0012680
2006-11-16 16:36 aquanight Assigned To => aquanight
2006-11-16 16:36 aquanight Status new => resolved
2006-11-16 16:36 aquanight Resolution open => fixed
2006-11-16 16:36 aquanight Fixed in Version => 3.3-alpha0