View Issue Details

IDProjectCategoryView StatusLast Update
0002902unrealircdpublic2006-11-11 14:21
ReporterMr_SmokeAssigned Toaquanight 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi586OSLinuxOS Version2.6.10
Product Version3.2.4 
Target VersionFixed in Version3.2.6 
Summary0002902: Failed oper notices not all global'ed
DescriptionThere are several cases of failed oper attempts. However, only the FAILEDAUTH will result in a GLOBAL server notice. Yet, it might be of interest to make other failed attemps issue a global as well.

From the conversation on #unreal-support :
[20:27:08] aquanight it's just baduid/badhost/maxlogins don't get globaled
[20:27:10] aquanight they probably should be

[20:28:22] aquanight maybe there should be a +O snomask for remote oper fails

That would be very nice indeed. An auto-zline after 3 failed attempts was also suggested, for the record :)
Additional InformationJust for the record.. this is in 3.3* (not 3.2*) :P.
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0002930 closed Not receiving remote failed oper-up notices 
child of 0002936 resolvedsyzop 3.2.6 Release 

Activities

syzop

2006-05-30 06:19

administrator   ~0011800

Sounds logical... just making the behavior the same as with FAILEDAUTH.

As for the +O snomask, if you mean (which it looks like) moving all remote oper attempt failures to this snomask, maybe that would be a good idea yes...

aquanight

2006-08-19 15:13

reporter   ~0012189

As of .2247, all successful and failed opering notices are now going to snomask +o, globally (with the sole exception of sucessful localopers, which is only local snomask +o).

syzop

2006-11-11 14:21

administrator   ~0012622

Decided to do this for 32* as well, anyway ;p.
Is now in 32* CVS.

Issue History

Date Modified Username Field Change
2006-05-06 13:48 Mr_Smoke New Issue
2006-05-30 06:16 syzop Relationship added has duplicate 0002930
2006-05-30 06:19 syzop Note Added: 0011800
2006-05-30 06:19 syzop Status new => acknowledged
2006-05-31 07:23 syzop Relationship added child of 0002936
2006-08-18 14:11 aquanight Status acknowledged => assigned
2006-08-18 14:11 aquanight Assigned To => aquanight
2006-08-19 15:13 aquanight Note Added: 0012189
2006-08-19 15:13 aquanight Status assigned => resolved
2006-08-19 15:13 aquanight Resolution open => fixed
2006-08-19 15:20 syzop Fixed in Version => 3.3-alpha0
2006-08-19 15:20 syzop Additional Information Updated
2006-11-11 14:21 syzop Note Added: 0012622
2006-11-11 14:21 syzop Fixed in Version 3.3-alpha0 => 3.2.6