View Issue Details

IDProjectCategoryView StatusLast Update
0002937unrealinstallingpublic2012-11-25 18:20
ReporterraymondvrolijkAssigned Tonenolod 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSLinuxOS Version2.6.8
Product Version3.2.4 
Target Version3.3-alpha0Fixed in Version3.4-alpha1 
Summary0002937: update config.h: remove disabling of THROTTLING, FAST_BADWORD_REPLACE, possibly more...
DescriptionWhen i remove the following line from ./include/config.h :

#define THROTTLING

Then I will get an error when I run 'make':

$ make
Building src
make[1]: Entering directory `/home/irc/Unreal3.2/src'
gcc -I../include -I/home/irc/Unreal3.2/extras/regexp/include -I/home/irc/Unreal3.2/extras/c-ares/include -pipe -g -O2 -funsigned-char -fno-strict-aliasing -export-dynamic -c res.c
In file included from res.c:46:
../include/h.h:683: error: syntax error before "cFlagTab"
../include/h.h:683: warning: data definition has no type or storage class
../include/h.h:683: warning: array 'cFlagTab' assumed to have one element
make[1]: *** [res.o] Error 1
make[1]: Leaving directory `/home/irc/Unreal3.2/src'
make: *** [build] Error 2
Steps To Reproduce1. Go to the Unreal directory

2. Start an editor to edit ./include/config.h

   vi ./include/config.h

3. Remove line 116 from the file
   (the line containing "#define THROTTLING")

4. Save the file and go back to the Unreal directory

   cd ..

5. Type 'make'
TagsNo tags attached.
3rd party modules

Relationships

related to 0002970 resolvedsyzop #define SIXBONE_HACK deprecated 

Activities

avenger

2006-05-31 17:09

reporter   ~0011813

What if you change from:

#define THROTTLING 1

to

#undef THROTTLING

note: i have not tested this, but usually it is how things work.

Stealth

2006-05-31 18:26

reporter   ~0011816

This isn't a bug, you need to make it #undef THROTTLING

If you are going to change things, you should know how :)

raymondvrolijk

2006-06-01 06:26

reporter   ~0011818

#undef THROTTLING

doesn't work... still the same error

syzop

2006-06-03 10:12

administrator   ~0011832

I don't think I'm still going to support this type of configuration (disabling throttling via a define), IMO there's no reason to turn it off.

Why was it there in the first place? Because it was experimental, it was first turned off, later turned on.

Now it has been in use for 2 years (or something), there's no reason to still have a define setting. Same applies to FAST_BADWORD_REPLACE and possibly other settings as well.

Thanks for the report though, now I know the setting is broken and should be removed :P

2006-08-09 00:16

 

throttle-cleanup.diff (11,749 bytes)

tabrisnet

2006-08-09 00:18

reporter   ~0012161

trivial patch removing the #ifdef and #elsif

looks like I missed a piece tho, the actual def in config.h

I am expecting I will have to start doing this work in svn, to make this easier. I get too much noise as it is, comparing a clean tree vs a built/configured tree.

syzop

2006-09-25 20:34

administrator   ~0012442

When we are at it, also clean up ./Config and configure and setup.h. Things like the Hub-or-leaf question can go, same for hostname (is already in bugtracker), etc etc.

syzop

2006-09-25 20:36

administrator   ~0012443

Reassigned from 3.2* to 3.3* tree.

Trocotronic

2006-12-28 12:29

reporter   ~0012945

Fixed in .2320

nenolod

2012-11-25 18:19

reporter   ~0017246

Various compile-time defines have been removed in 3.4 which were required to build the IRCd regardless.

Issue History

Date Modified Username Field Change
2006-05-31 13:52 raymondvrolijk New Issue
2006-05-31 17:09 avenger Note Added: 0011813
2006-05-31 18:26 Stealth Note Added: 0011816
2006-06-01 06:26 raymondvrolijk Note Added: 0011818
2006-06-03 10:12 syzop Note Added: 0011832
2006-06-03 10:13 syzop Severity block => minor
2006-06-03 10:13 syzop Summary Trottling in config.h removed makes the build fail => update config.h: remove disabling of THROTTLING, FAST_BADWORD_REPLACE, possibly more...
2006-06-03 10:14 syzop Relationship added child of 0002936
2006-06-13 05:15 syzop Relationship added related to 0002970
2006-08-09 00:16 tabrisnet File Added: throttle-cleanup.diff
2006-08-09 00:18 tabrisnet Note Added: 0012161
2006-09-25 20:34 syzop Note Added: 0012442
2006-09-25 20:35 syzop Relationship deleted child of 0002936
2006-09-25 20:36 syzop Note Added: 0012443
2006-12-28 12:29 Trocotronic Status new => resolved
2006-12-28 12:29 Trocotronic Fixed in Version => 3.3-alpha0
2006-12-28 12:29 Trocotronic Resolution open => fixed
2006-12-28 12:29 Trocotronic Assigned To => Trocotronic
2006-12-28 12:29 Trocotronic Note Added: 0012945
2011-07-19 13:58 syzop Assigned To Trocotronic =>
2011-07-19 13:58 syzop Status resolved => needs re porting
2011-07-19 17:11 syzop Target Version => 3.3-alpha0
2012-11-25 18:19 nenolod Note Added: 0017246
2012-11-25 18:19 nenolod Status needs re porting => resolved
2012-11-25 18:19 nenolod Fixed in Version 3.3-alpha0 => 3.4-alpha1
2012-11-25 18:19 nenolod Assigned To => nenolod