View Issue Details

IDProjectCategoryView StatusLast Update
0002970unrealircdpublic2006-11-12 14:51
ReportertabrisnetAssigned Tosyzop 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux/x86OSDebian LinuxOS Versiontesting
Product Version3.2.4 
Target VersionFixed in Version3.2.6 
Summary0002970: #define SIXBONE_HACK deprecated
Description6bone shutdown last week.
if ip6.arpa hasn't been delegated, it never will be.

You can probably rip this code out by the throat now.
Additional InformationFor those who care, it was shutdown 06-06-06. I guess somebody's idea of a joke.
TagsNo tags attached.
3rd party modules

Relationships

related to 0002937 resolvednenolod update config.h: remove disabling of THROTTLING, FAST_BADWORD_REPLACE, possibly more... 

Activities

Robby22

2006-06-15 05:46

reporter   ~0011956

Ah yes, I made that patch 3 years ago (submitted that thing under the name "Onliner" back then ;p) so that both ip6.arpa and ip6.int could be resolved since it did only do ip6.int at first, the code is already gone.. I think since C-ares was put in to use... but the define was still left in config.h, it can indeed be removed safely.

tabrisnet

2006-08-08 23:06

reporter   ~0012160

searched the code in 3.2.5, and I cannot find any ref to it anywhere except in config.h

syzop

2006-11-12 14:51

administrator   ~0012648

Removing define in config.h

In my cvs queue.

Thanks

Issue History

Date Modified Username Field Change
2006-06-12 21:35 tabrisnet New Issue
2006-06-13 05:15 syzop Relationship added related to 0002937
2006-06-15 05:46 Robby22 Note Added: 0011956
2006-08-08 23:06 tabrisnet Note Added: 0012160
2006-11-12 14:51 syzop Status new => resolved
2006-11-12 14:51 syzop Fixed in Version => 3.2.6
2006-11-12 14:51 syzop Resolution open => fixed
2006-11-12 14:51 syzop Assigned To => syzop
2006-11-12 14:51 syzop Note Added: 0012648