View Issue Details

IDProjectCategoryView StatusLast Update
0003025unrealdocumentationpublic2006-08-19 15:33
ReporterFiXatoAssigned Toaquanight 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSLinuxOS Version2.6.11-1
Product Version3.2.5 
Target VersionFixed in Version3.3-alpha0 
Summary0003025: SVSNLINE doesn't remove realnamebans
DescriptionWhen trying to remove an n:line/realnameban via SVSNLINE - reason:regex through an u:lined server, the realnameban doesn't get removed.
Tried this on both 3.2.3 as well as 3.2.5
Steps To Reproduce/os raw svsnline + HDC_Drones_are_banned :Hacked by H.D.C

/stats n
  n Hacked by H.D.C HDC Drones are banned

/os raw svsnline - HDC_Drones_are_banned :Hacked by H.D.C

/stats n
  n Hacked by H.D.C HDC Drones are banned
(so it is still listed in the stats n report after trying to remove it)

The same applies when letting for instance anope try the adding and removing through their /os sgline command.
TagsNo tags attached.
3rd party modulesantibear,tklexport,tklimport,rmban,nocolorumode,clones,staff ,ircops,getinfo,chansno,activeusers

Relationships

related to 0003141 resolvedsyzop svsnline syntax in help.conf 

Activities

FiXato

2006-08-17 19:23

reporter   ~0012185

after more fiddling, it does seem to work when trying to remove with:

/os svsnline - :realnamemask

so, leaving the reason out...
Either the command should be fixed to allow for reasons, or the helpop should be updated to show the correct way to remove instead of:

***** Svsnline *****
 -
 Adds a global realname ban.
 Must be sent through an U:Lined server.
 The reason must be a single parameter therefore
 spaces are indicated by _, Unreal will internally
 translate these to spaces
 -
 Syntax: SVSNLINE +/- <reason_for_ban> :<realname>
 Example: SVSNLINE + sub7_drone :*sub7*

aquanight

2006-08-19 15:33

reporter   ~0012190

Documentation fixed in .2248 (3.3 devel branch).

Issue History

Date Modified Username Field Change
2006-08-17 18:57 FiXato New Issue
2006-08-17 18:57 FiXato 3rd party modules => antibear,tklexport,tklimport,rmban,nocolorumode,clones,staff ,ircops,getinfo,chansno,activeusers
2006-08-17 19:23 FiXato Note Added: 0012185
2006-08-19 15:33 aquanight Note Added: 0012190
2006-08-19 15:33 aquanight Assigned To => aquanight
2006-08-19 15:33 aquanight Status new => resolved
2006-08-19 15:33 aquanight Resolution open => fixed
2006-08-19 15:33 aquanight Category ircd => documentation
2006-08-19 15:33 aquanight Fixed in Version => 3.3-alpha0
2006-12-09 13:42 syzop Relationship added related to 0003141