View Issue Details

IDProjectCategoryView StatusLast Update
0003141unrealdocumentationpublic2006-12-11 06:18
ReportervonitsanetAssigned Tosyzop 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformOS-OS Version-
Product Version3.2.6 
Target VersionFixed in Version3.2.6 
Summary0003141: svsnline syntax in help.conf
DescriptionNEW BUG DESCRIPTION:
/helpop ?svsnline says:
..
 Syntax: SVSNLINE +/- <reason_for_ban> :<realname>
 Example: SVSNLINE + sub7_drone :*sub7*
..
This is incorrect. When removing a svsnline the reason_for_ban should be dropped.

ORIGINAL DESCRIPTION:
svsnline can not remove bans?
I'm not sure if this is a bug but...
i think that svsnline (and BR Token) is not be able to remove a realname ban on 6rc1..
Steps To Reproduce/os raw :services.unrealircd.testnet SVSNLINE + testing :*notremoved?*

n *notremoved?* testing
End of /STATS report

/os raw :services.unrealircd.testnet SVSNLINE - testing :*notremoved?*

n *notremoved?* testing
End of /STATS report
TagsNo tags attached.
3rd party modules

Relationships

related to 0003025 resolvedaquanight SVSNLINE doesn't remove realnamebans 

Activities

syzop

2006-12-09 08:46

administrator   ~0012806

svsnline hasn't been touched the past 2 years.

Anyway, the REMOVE syntax is:
SVSNLINE - :*notremoved?*

;)

syzop

2006-12-09 08:47

administrator   ~0012807

When we are at it, this command is missing from serverprotocol.html (and a couple of others) :).. But that probably deserves a separate bugreport :P

syzop

2006-12-09 08:51

administrator   ~0012808

Tagging as docbug. Just noticed help.conf is not showing the correct syntax either :)

penna

2006-12-09 08:51

reporter   ~0012809

Last edited: 2006-12-09 08:52

Just an error in help.conf
To remove a SVSNLINE it's the same as for GLINE etc.
SVSNLINE - ban
and not as it appears in the help.conf text SVSNLINE - reason ban

edit: ok typed too slowly :)

aquanight

2006-12-09 11:40

reporter   ~0012810

0003025

penna

2006-12-11 03:42

reporter   ~0012811

And why is this only fixed on 3.3 ?
Is there any good reason that even small documentation fixes don't go in the 3.2 branch?

syzop

2006-12-11 06:10

administrator   ~0012812

Last edited: 2006-12-11 06:11

The actual question is why it wasn't backported. This was simply because that issue was marked as 'resolved' and after that overlooked. Procedures for this have changed now.

EDIT: +actual

Issue History

Date Modified Username Field Change
2006-12-09 08:41 vonitsanet New Issue
2006-12-09 08:46 syzop Note Added: 0012806
2006-12-09 08:47 syzop Note Added: 0012807
2006-12-09 08:48 syzop Status new => closed
2006-12-09 08:48 syzop Resolution open => unable to reproduce
2006-12-09 08:49 syzop Status closed => new
2006-12-09 08:51 syzop Note Added: 0012808
2006-12-09 08:51 syzop Severity minor => text
2006-12-09 08:51 syzop Category ircd => documentation
2006-12-09 08:51 syzop Summary svsnline can not remove bans? => svsnline syntax in help.conf
2006-12-09 08:51 syzop Description Updated
2006-12-09 08:51 penna Note Added: 0012809
2006-12-09 08:52 penna Note Edited: 0012809
2006-12-09 11:40 aquanight Note Added: 0012810
2006-12-09 13:42 syzop Relationship added related to 0003025
2006-12-11 03:42 penna Note Added: 0012811
2006-12-11 06:10 syzop Note Added: 0012812
2006-12-11 06:11 syzop Note Edited: 0012812
2006-12-11 06:18 syzop Status new => resolved
2006-12-11 06:18 syzop Fixed in Version => 3.2.6
2006-12-11 06:18 syzop Resolution unable to reproduce => fixed
2006-12-11 06:18 syzop Assigned To => syzop