View Issue Details

IDProjectCategoryView StatusLast Update
0003050unrealircdpublic2015-05-27 18:35
Reporterdiskman1Assigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSDebianOS Version3.1
Product Version3.2.5 
Target VersionFixed in Version3.2.9 
Summary0003050: alternative hub flag for autoconnects
Descriptionat my network i use autoconnects to relink the network if a link fails.
but with two hubs the ircd wants to connect both at the same time... now hubs get trouble with a leaf which is connected to twice hubs.

i can prevent that with connection rules "if hub1 is connected do not allow link to hub2" but for all that in big networks with many users there are many problems.
ircd is synching and gets disconnected because of the crule.

so i think it could be a nice feature to select the prio one hub which is connected first and if connection fails the ircd tries the alternate hub.

or a wait flag so the link is activated after one connfreq?


diskman
TagsNo tags attached.
3rd party modules

Relationships

child of 0003286 closedsyzop More intelligent link handling 

Activities

monas

2006-10-16 10:33

reporter   ~0012492

How about assigning class with maxclient=1 to both hub connection?

diskman1

2006-10-16 15:13

reporter   ~0012494

at this point there is no connection established i dont think this can help...
server activates all autoconnect links on startup or delink
maxclients is only useful if i want to restrict the max links but this can be done with a crule.

diskman

syzop

2015-05-27 18:34

administrator   ~0018369

Since 3.2.9 it's safe to quickly reconnect, even to multiple targets.
thanks to PROTOCTL SERVERS=

(note: this has been broken by nenolod in 3.4....yeah.. fantastic)

Issue History

Date Modified Username Field Change
2006-09-03 17:48 diskman1 New Issue
2006-10-16 10:33 monas Note Added: 0012492
2006-10-16 15:13 diskman1 Note Added: 0012494
2007-04-19 02:50 stskeeps Relationship added child of 0003286
2007-04-19 02:50 stskeeps Status new => acknowledged
2015-05-27 18:34 syzop Note Added: 0018369
2015-05-27 18:34 syzop Status acknowledged => resolved
2015-05-27 18:34 syzop Fixed in Version => 3.2.9
2015-05-27 18:34 syzop Resolution open => fixed
2015-05-27 18:34 syzop Assigned To => syzop