View Issue Details

IDProjectCategoryView StatusLast Update
0003091unrealinstallingpublic2007-04-24 04:19
ReporteraegisAssigned Tostskeeps 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformanyOSany unix typeOS Versionany
Product Version3.2.5 
Target VersionFixed in Version3.3-alpha0 
Summary0003091: Problems when specifying different directory for binary in Config
DescriptionWhen specifying a different directory for the binary you receive a error such as this...

(courtesy of Neronix)
make[2]: Entering directory `/home/r3b0rn3/Unreal3.2/src/modules'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/home/r3b0rn3/Unreal3.2/src/modules'
make[1]: Leaving directory `/home/r3b0rn3/Unreal3.2/src'
 __________________________________________________
| Compile is now complete. |
| You should now read the documentation and learn |
| how to configure your IRCd. |
| |
| If you really like UnrealIRCd, and would like to |
| make a donation, please read the Donation file in|
| this archive. :) |
| |
| Thanks for using Unreal IRCd! If you are in need |
| for any kind of help regarding the IRCd please |
| read the Unreal.nfo file. |
|__________________________________________________|
/usr/bin/install -m 0700 -d /home/r3b0rn3/eliptex
/usr/bin/install -m 0700 src/ircd /home/r3b0rn3/eliptex/src/ircd
/usr/bin/install: cannot create regular file `/home/r3b0rn3/eliptex/src/ircd': No such file or directory
make: *** [install] Error 1

This can be resolved easily with a patch to Config, unreal.in, ircdcron.in, Makefile.in (provided on this page), or simply creating the directory manually.

This patch however will not permit you to change the name of the ircd binary file itself
Steps To ReproduceSpecify a path to the Unreal binary with at least 1 directory deeper than DATADIR, or to a path which does not already exist.
Additional InformationTo use the patch, put Unreal.patch into you Unreal3.2 directory (adjacent to Config), and type patch -p0 <Unreal.patch
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0003068 resolvedstskeeps error on 'make install' if path to binary not exist. 

Activities

2006-10-16 05:53

 

Unreal.patch (3,727 bytes)

syzop

2006-10-16 07:57

administrator   ~0012490

Some people (like me and another bug reporter a few days ago) like to give different binary names, though :p.

But I like the reminder at the rephrasing of certain text in ./Config (I know, offtopic).

As for the "directory is not created" thing, I *think* this is already in the bugtracker, aquanight was having a look at it at least...
(I know, horrible bugs navigation atm :P)

I'll keep this bug open till I get the rewording done ("What directory *do you want to install* ...".

syzop

2006-10-16 07:59

administrator   ~0012491

On another side note, I never understood why people wanted their ircd in 'src/ircd' and not just 'ircd' :P. But I agree Unreal should create the directory if it doesn't exist, like for situations when 'bin/ircd' is used.

Bock

2006-10-16 18:33

reporter   ~0012495

It's looks like http://bugs.unrealircd.org/view.php?id=3068 :]

stskeeps

2007-04-24 02:47

reporter   ~0013639

Patch (2006-10-16 05:53) broken, does not apply to 3.3-alpha0

aegis

2007-04-24 04:01

reporter   ~0013645

new patch generated, for devel, also removed networks install from Makefile.in, cheers.

http://www.ircwire.net/bindir.patch

stskeeps

2007-04-24 04:19

reporter   ~0013647

Fixed in .2364

Issue History

Date Modified Username Field Change
2006-10-16 05:53 aegis New Issue
2006-10-16 05:53 aegis File Added: Unreal.patch
2006-10-16 07:57 syzop Note Added: 0012490
2006-10-16 07:59 syzop Note Added: 0012491
2006-10-16 18:33 Bock Note Added: 0012495
2007-04-19 02:48 stskeeps Relationship added duplicate of 0003068
2007-04-19 02:48 stskeeps Duplicate ID 0 => 3068
2007-04-19 02:48 stskeeps Status new => resolved
2007-04-19 02:48 stskeeps Resolution open => duplicate
2007-04-19 02:48 stskeeps Assigned To => stskeeps
2007-04-24 02:47 stskeeps Note Added: 0013639
2007-04-24 02:47 stskeeps Status resolved => feedback
2007-04-24 02:47 stskeeps Resolution duplicate => reopened
2007-04-24 04:01 aegis Note Added: 0013645
2007-04-24 04:19 stskeeps Status feedback => resolved
2007-04-24 04:19 stskeeps Fixed in Version => 3.3-alpha0
2007-04-24 04:19 stskeeps Resolution reopened => fixed
2007-04-24 04:19 stskeeps Note Added: 0013647
2007-04-24 04:19 stskeeps Duplicate ID 3068 => 0