View Issue Details

IDProjectCategoryView StatusLast Update
0003117unrealircdpublic2007-12-30 11:30
ReportervonitsanetAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platform-OS-OS Version-
Product Version3.2.6 
Target VersionFixed in Version3.2.8 
Summary0003117: Improve +S , +c
DescriptionI'm suggesting to make +S and +c to Strip out(+S)/ block(+c) BOLD and Underline text just like Colors.
TagsNo tags attached.
3rd party modules

Relationships

child of 0003454 resolvedsyzop Unreal3.2.8 TODO 

Activities

MJ12Helios

2006-11-16 09:38

reporter   ~0012665

good idea, reverse should be blocked/stripped out too...

djGrrr

2006-11-16 10:34

reporter   ~0012670

ummm, this already exists as a module:
http://www.unrealircd.org/index.php?page=modules&mod=module&id=8

syzop

2006-11-16 15:10

administrator   ~0012676

I don't know where I said this, but... I think 'reverse' should be included in color stripping/blocking, since although maybe not technically a "color", in practice it IS a color change (and quite a noticable one, too).
Blocking bold and underline shouldn't be stripped/blocked IMO.

The idea is you can block the annoying colors (and reverse then ;p) while still keeping bold/underline which you can use to highlight things. Don't know if it's still the case, but it's for example used in our support channel to note where the mistake is in an unrealircd.conf line (like underline/bold the part that is incorrect, like a '}'). Blahblah ;)

vonitsanet

2006-11-16 20:15

reporter   ~0012681

Maybe on +S dont block bold/underline.
On +c block them all..
I was thinking for something like this as a protection from flood bots..

WolfSage

2007-04-18 17:18

reporter   ~0013538

Syzop, what say you? Should these be changed or are modules sufficient enough?

Shining Phoenix

2007-04-18 19:31

reporter   ~0013556

How is stripping colour codes going to protect you from flood bots?

WolfSage

2007-04-18 19:38

reporter   ~0013558

+c doesn't strip, it blocks, therefor any bot using the colors would be blocked. And stripping anything but bold and underline sounds good to me. If they aren't being stripped then they should be.

xnemesis

2007-06-05 05:12

reporter   ~0014273

I think reverse should be blocked, and the underline/bold block module should be included as an extra mode by default (incorporating the already written module)

Stealth

2007-06-05 14:37

reporter   ~0014277

Or make a conf option that accepts B, U or R or any combination of which to block/strip... the only downside to that is it may slow Unreal down a little

tabrisnet

2007-06-10 11:35

reporter   ~0014308

It shouldn't slow anything down much, given it's not MORE codepaths being taken, just more branches in that same codepath.

syzop

2007-12-30 11:30

administrator   ~0014942

.697:
- ChanMode +S/+c: reverse is now stripped/blocked as well, because it's
  similar to color, and is just as annoying (..if not worse).

Issue History

Date Modified Username Field Change
2006-11-16 07:46 vonitsanet New Issue
2006-11-16 09:38 MJ12Helios Note Added: 0012665
2006-11-16 10:34 djGrrr Note Added: 0012670
2006-11-16 15:10 syzop Note Added: 0012676
2006-11-16 20:15 vonitsanet Note Added: 0012681
2007-04-18 17:18 WolfSage Note Added: 0013538
2007-04-18 19:31 Shining Phoenix Note Added: 0013556
2007-04-18 19:38 WolfSage Note Added: 0013558
2007-04-19 02:20 stskeeps Status new => acknowledged
2007-06-05 05:12 xnemesis Note Added: 0014273
2007-06-05 13:56 Trocotronic Status acknowledged => assigned
2007-06-05 13:56 Trocotronic Assigned To => Trocotronic
2007-06-05 14:37 Stealth Note Added: 0014277
2007-06-10 11:35 tabrisnet Note Added: 0014308
2007-06-11 12:54 stskeeps Assigned To Trocotronic =>
2007-06-11 12:54 stskeeps Status assigned => acknowledged
2007-07-18 07:28 stskeeps Relationship added child of 0003454
2007-12-30 11:30 syzop QA => Not touched yet by developer
2007-12-30 11:30 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2007-12-30 11:30 syzop Status acknowledged => resolved
2007-12-30 11:30 syzop Fixed in Version => 3.2.8
2007-12-30 11:30 syzop Resolution open => fixed
2007-12-30 11:30 syzop Assigned To => syzop
2007-12-30 11:30 syzop Note Added: 0014942