View Issue Details

IDProjectCategoryView StatusLast Update
0003454unrealircdpublic2012-10-20 10:36
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformAllOSAllOS VersionAll
Product Version3.2.8 
Target VersionFixed in Version3.2.8 
Summary0003454: Unreal3.2.8 TODO
DescriptionParent bug of TODO's for 3.2.8

TARGET (updated 2008-08-07): Release 3.2.8 in Summer 2008 (northern hemisphere ;p). I'll be working on it in my summer vacation.
Additional InformationAs usual, this is a dynamic process, not all issues mentioned here will be resolved, and issues not listed here will be resolved as well. It' just meant as a rough (but quite good) list of things we'd like to see fixed/changed/added.
TagsNo tags attached.
3rd party modules

Relationships

parent of 0003239 closedsyzop More than one NT service on same machine. 
parent of 0003117 resolvedsyzop Improve +S , +c 
parent of 0002446 resolvedsyzop Chroot and uid, gid macros undocumented 
parent of 0003351 resolved m_addmotd and m_svslusers are not compiled 
parent of 0003182 resolvednate SHOW_SECRET (config.h) defined by default 
parent of 0003354 resolvedsyzop Dont allow part message when banned 
parent of 0003453 resolvedsyzop Overflowed unzipbuf increase UNZIP_BUFFER_SIZE 
parent of 0003430 resolvedsyzop invalid banlist entries created by netsplits 
parent of 0003163 resolvedsyzop Allow 1.2.3.4 style IPs in IPv6 mode (not only ::ffff:1.2.3.4) // cgiirc block does not work w/ipv6 
parent of 0003527 resolvedsyzop Fix chroot again 
parent of 0003494 resolvedsyzop IPv4 masks don't work in oper blocks 
parent of 0003311 resolvedsyzop CGI:IRC & IPv6 Issue 
parent of 0003422 resolvedsyzop Must be changed/added to documentation. 
parent of 0003489 closed Errors "1" and "2" when making (Mac OS X/Leopard) 
parent of 0003174 resolvedsyzop Make usermodes non-PERM 
parent of 0003175 resolvedsyzop Make channelmodes non-PERM 
parent of 0003545 resolvedsyzop Remote includes // upgrade c-ares 
parent of 0003554 resolvedsyzop Setting ban on channel with +b ?!*@* 
parent of 0003572 resolvedsyzop Zline with IPv6 
parent of 0003731 closed bug with ziplinks 
parent of 0003680 resolvedsyzop Unrealircd does not compile under Visual studio 2008 
parent of 0003764 resolvedsyzop Need to add in documentation 

Activities

syzop

2008-08-07 09:14

administrator   ~0015339

Last edited: 2008-08-07 09:47

I hope to release a 3.2.8 this summer (bugfix release)... I'll check out attached issues to this, and also go through any (other) crash and major bugs in the bugtracker. As you all might know, I'm recovering from surgery but it's going reasonably well (7wks ago now), and I hope to spend some time on Unreal to get a decent 3.2.8. Of course, especially due to my health, I cannot give any guarantees ;).

As said, will be a bugfix-only release... just to get everything up to date. I will also not be touching/fixing MANY minor issues, seeing the bugtracker has so many issues that would be kinda undoable anyway...
EDIT: not 1000 issues...

syzop

2008-12-14 15:01

administrator   ~0015441

I'd like to release 3.2.8-RC1 to testers in 1-2wks.
I know, there are many many issues left in the bugtracker, but if we try to fix
them all or even all bugs tagged 'major' it will take forever. It's my view
that enough has gone in to warrant a release.

Changes so far, see CVS, or if lazy check out list at time of writing at http://www.vulnscan.org/tmp/328sofar.txt (this might be outdated by the time you read this)

I tried to prod a few people for development to help me a bit with coding/patches in case they felt something was utterly important, but I guess that didn't work. So, TO ALL DEVS: If someone has some important bugfix patch that should get in, this is the time to tell... (actually... yesterday was ;p). Please email your patch to syzop@vulnscan.org
As for people with write access to Unreal3.2 cvs.. feel free to commit fixes, but better not new features or anything big that could risk breakage of 3.2.8.

Personally, I'll concentrate on crash/really major/failedcompile bugs.

3.2.8 will be mostly bugfix only.. see changelog.

tabrisnet

2008-12-14 16:28

reporter   ~0015442

thoughts on 0003739 ? I know it's not a bugfix, but it should be mostly trivial to add a new HOOKTYPE.

tabrisnet

2008-12-14 16:39

reporter   ~0015443

Thank you for 0003494, 0002833 and 0002971

syzop

2009-03-01 19:11

administrator   ~0015803

3.2.8 is being released...

Issue History

Date Modified Username Field Change
2007-07-18 07:24 stskeeps New Issue
2007-07-18 07:25 stskeeps Status new => acknowledged
2007-07-18 07:27 stskeeps Relationship added parent of 0003239
2007-07-18 07:27 stskeeps Relationship added parent of 0002103
2007-07-18 07:27 stskeeps Relationship added parent of 0003256
2007-07-18 07:27 stskeeps Relationship added parent of 0003133
2007-07-18 07:28 stskeeps Relationship added parent of 0003117
2007-07-18 07:28 stskeeps Relationship added parent of 0003217
2007-07-18 07:28 stskeeps Relationship added parent of 0002446
2007-07-18 07:28 stskeeps Relationship added parent of 0002792
2007-07-18 07:28 stskeeps Relationship added parent of 0002330
2007-07-18 07:29 stskeeps Relationship added parent of 0003351
2007-07-18 07:29 stskeeps Relationship added parent of 0003182
2007-07-18 07:29 stskeeps Relationship added parent of 0003354
2007-07-18 07:31 stskeeps Sticky Issue No => Yes
2007-07-19 08:21 stskeeps Relationship added parent of 0003453
2007-09-02 15:25 syzop Relationship added parent of 0003430
2007-09-04 05:28 syzop Relationship added parent of 0003163
2007-09-05 15:46 syzop Relationship added parent of 0003527
2007-09-06 10:01 syzop Relationship added parent of 0003494
2007-09-06 10:07 syzop Relationship added parent of 0003311
2007-09-06 10:10 syzop Relationship added parent of 0002379
2007-09-06 10:10 syzop Relationship added parent of 0002278
2007-09-06 10:10 syzop Relationship added parent of 0002152
2007-09-06 10:10 syzop Relationship added parent of 0002154
2007-09-06 10:13 syzop QA => Not touched yet by developer
2007-09-06 10:13 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2007-09-06 10:13 syzop U4: Upstream notification of bug => Not decided
2007-09-06 10:13 syzop U4: Contributor working on this => None
2007-09-06 10:13 syzop Reporter stskeeps => syzop
2007-09-06 10:13 syzop Severity minor => feature
2007-09-06 10:13 syzop Relationship added parent of 0003422
2007-09-06 10:15 syzop Additional Information Updated
2007-09-06 13:02 syzop Relationship added parent of 0002817
2007-09-10 05:11 syzop Relationship added parent of 0003489
2007-11-01 09:41 syzop Relationship added parent of 0003174
2007-11-01 09:41 syzop Relationship added parent of 0003175
2007-12-12 08:36 syzop Relationship added parent of 0003545
2007-12-22 19:02 syzop Relationship added parent of 0003554
2007-12-30 11:17 syzop Relationship added parent of 0003560
2007-12-30 11:32 syzop Relationship deleted parent of 0003256
2007-12-30 11:33 syzop Relationship deleted parent of 0002103
2007-12-30 11:35 syzop Relationship deleted parent of 0002154
2008-01-06 19:02 syzop Relationship added parent of 0003572
2008-02-11 15:35 syzop Relationship deleted parent of 0002792
2008-02-11 16:16 syzop Relationship deleted parent of 0003217
2008-08-07 09:08 syzop Description Updated
2008-08-07 09:14 syzop Note Added: 0015339
2008-08-07 09:47 syzop Note Edited: 0015339
2008-12-10 09:17 syzop Relationship deleted parent of 0002817
2008-12-10 09:30 syzop Relationship added parent of 0003731
2008-12-10 09:32 syzop Relationship added parent of 0003680
2008-12-14 15:01 syzop Note Added: 0015441
2008-12-14 16:28 tabrisnet Note Added: 0015442
2008-12-14 16:39 tabrisnet Note Added: 0015443
2008-12-23 15:54 syzop Relationship deleted parent of 0002379
2008-12-23 15:55 syzop Relationship deleted parent of 0002278
2008-12-23 16:38 syzop Relationship deleted parent of 0003560
2008-12-23 16:39 syzop Relationship deleted parent of 0003133
2008-12-23 16:40 syzop Relationship deleted parent of 0002152
2008-12-24 12:23 syzop Relationship deleted parent of 0002330
2009-01-02 13:43 syzop Relationship added parent of 0003764
2009-03-01 19:11 syzop Status acknowledged => resolved
2009-03-01 19:11 syzop Fixed in Version => 3.2.8
2009-03-01 19:11 syzop Resolution open => fixed
2009-03-01 19:11 syzop Assigned To => syzop
2009-03-01 19:11 syzop Note Added: 0015803
2012-10-20 10:36 syzop Sticky Issue Yes => No