View Issue Details

IDProjectCategoryView StatusLast Update
0003182unrealinstallingpublic2008-02-08 21:55
ReporterRobby22Assigned Tonate 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Platformi686OSFedora CoreOS Version6
Product Version3.2.6 
Target VersionFixed in Version3.3-alpha0 
Summary0003182: SHOW_SECRET (config.h) defined by default
Description/*
 * Defining this will allow all ircops to see people in +s channels
 * By default, only net/tech admins can see this
 */
#define SHOW_SECRET


By default it is on for ALL ircops, either the description should be changed or preferably it should default to undefined, like the description says :)

Attached is a patch that undefines it, though it may be overkill to have one for a small change like this... ;)
TagsNo tags attached.
3rd party modules

Relationships

child of 0003454 resolvedsyzop Unreal3.2.8 TODO 

Activities

2007-01-02 23:41

 

show_secret_configh.patch (328 bytes)

Robby22

2007-01-02 23:43

reporter   ~0012973

And maybe remove "tech" from the description since it does not exist anymore anyway, it may be a detail but still :P

Bricker

2007-01-02 23:53

reporter   ~0012974

thats what i was going to say ;p (about removing tech)

djGrrr

2007-01-03 08:25

reporter   ~0012982

i think SHOW_SECRET should be kept as on by default, and the description should be changed. Then maybe it could be added as an option in ./Config -advanced

Bricker

2007-01-03 13:07

reporter   ~0012987

yep, i like that idea dj

stskeeps

2007-04-19 18:50

reporter   ~0013609

djGrr: write a ./Config patch?

2008-01-24 07:32

 

show_secret.patch (4,042 bytes)

nate

2008-01-24 07:32

reporter   ~0014984

Patch for setting SHOW_SECRET from ./Config uploaded.

Set to enabled (Yes) by default, tested and seems to work fine.

nate

2008-02-08 21:55

reporter   ~0015056

Implemented in 3.3 dev codebase (.250)

Issue History

Date Modified Username Field Change
2007-01-02 23:41 Robby22 New Issue
2007-01-02 23:41 Robby22 File Added: show_secret_configh.patch
2007-01-02 23:43 Robby22 Note Added: 0012973
2007-01-02 23:53 Bricker Note Added: 0012974
2007-01-03 08:25 djGrrr Note Added: 0012982
2007-01-03 13:07 Bricker Note Added: 0012987
2007-04-19 03:19 stskeeps Status new => acknowledged
2007-04-19 18:50 stskeeps Note Added: 0013609
2007-07-18 07:29 stskeeps Relationship added child of 0003454
2008-01-24 07:32 nate File Added: show_secret.patch
2008-01-24 07:32 nate Note Added: 0014984
2008-02-08 21:52 nate Status acknowledged => assigned
2008-02-08 21:52 nate Assigned To => nate
2008-02-08 21:55 nate QA => No need for QA
2008-02-08 21:55 nate U4: Need for upstream patch => No need for upstream InspIRCd patch
2008-02-08 21:55 nate Status assigned => resolved
2008-02-08 21:55 nate Fixed in Version => 3.3-alpha0
2008-02-08 21:55 nate Resolution open => fixed
2008-02-08 21:55 nate Note Added: 0015056