View Issue Details

IDProjectCategoryView StatusLast Update
0003358unrealircdpublic2010-10-22 15:09
ReporterMareoAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSGNU/Linux (Debian)OS Version2.6.18
Product Version3.2.6 
Target VersionFixed in Version3.2.9-RC1 
Summary0003358: missings operoverride notices
DescriptionHello !
chanops and chanadmins cannot set chanmode +L
chanops set chanmode +N

if an oper set mode +NL as chanop or +L as chanadmin, there is no OperOverride notice.
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0003374 resolvedstskeeps No override notice on /mode $chan +L 
child of 0003776 resolvedsyzop Unreal3.2.9 TODO 

Activities

Mareo

2007-05-23 07:42

reporter   ~0014214

There is a little error, sorry -_-'

Is not chanmode +N but chanmode +u

About +N, if an oper change his nick in a +N channel, there is no oper override notice

driew

2010-04-15 12:15

reporter   ~0016074

As for the nick change in +N; that would be very spammy and annoying.
Just like how I saw a report that there is no oper_override notice for opers talking in a +m channel without voice.. how annoying would that be for other opers?
It just doesn't make sense.

The +u +L notice however, should be fixed. It's probably like that due to the hacks behind operoverride..

syzop

2010-07-14 17:16

administrator   ~0016168

Last edited: 2010-07-14 17:17

while I don't fully understand what exactly is the bug, I presume that setting one or more of the modes mentioned should create an operoverride notice and currently does not.
That is something that should be fixed, as we don't want an oper to silently do things like that ;P.

-> for 3.2.9, but not Release Critical.

PS: these bugs are always hard to fix, and often create another one, so if someone else than me does this, be careful with it ! (well, if I do it myself, I should be careful too ;pp)

syzop

2010-10-22 15:09

administrator   ~0016387

Fixed in .890:
- Fix missing OperOverride notices for +u and +L if not chanowner, reported
  by Mareo (0003358), partial patch from DJ.
Thanks.

If you really insist on the oper nickchanging with chmode +N needing to cause an operoverride notice, then please open up a new bug report... requires special treatment :P

Issue History

Date Modified Username Field Change
2007-05-22 11:38 Mareo New Issue
2007-05-22 15:20 stskeeps Status new => acknowledged
2007-05-23 07:42 Mareo Note Added: 0014214
2007-06-04 10:48 stskeeps Relationship added has duplicate 0003374
2010-04-15 12:15 driew Note Added: 0016074
2010-07-14 17:14 syzop Relationship added child of 0003776
2010-07-14 17:16 syzop Note Added: 0016168
2010-07-14 17:17 syzop Note Edited: 0016168
2010-10-22 15:09 syzop QA => Not touched yet by developer
2010-10-22 15:09 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-10-22 15:09 syzop Note Added: 0016387
2010-10-22 15:09 syzop Status acknowledged => resolved
2010-10-22 15:09 syzop Fixed in Version => 3.2.9-RC1
2010-10-22 15:09 syzop Resolution open => fixed
2010-10-22 15:09 syzop Assigned To => syzop