View Issue Details

IDProjectCategoryView StatusLast Update
0003396unrealinstallingpublic2007-06-22 04:27
ReporterBockAssigned Tostskeeps 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSlinuxOS Version2.6.18-4 debian
Product Version3.3-alpha0 
Target VersionFixed in Version3.3-alpha0 
Summary0003396: not copying server.*.pem on "make install"
Descriptionif choosing on ./Config option with SSL and directory not by default:

 --with-dpath=/home/bock/Unreal-tests/Unreal-etc --with-spath=/home/bock/Unreal-tests/Unreal-test/Unreal-bin

"make install" not copying server.*.pem to dpath and when trying start unreal you get error:
./unreal start


bock@nirvana:~(/home/bock/Unreal-tests/Unreal-etc)> ./unreal start
Starting UnrealIRCd
 _ _ _ ___________ _____ _
| | | | | |_ _| ___ \/ __ \ | |
| | | |_ __ _ __ ___ __ _| | | | | |_/ /| / \/ __| |
| | | | '_ \| '__/ _ \/ _` | | | | | / | | / _` |
| |_| | | | | | | __/ (_| | |_| |_| |\ \ | \__/\ (_| |
 \___/|_| |_|_| \___|\__,_|_|\___/\_| \_| \____/\__,_|
                           v3.3-pre-alpha
                     using TRE 0.7.5 (LGPL)
                     using OpenSSL 0.9.8c 05 Sep 2006
                     using zlib 1.2.3

* Loading IRCd configuration ..
* Configuration loaded without any problems ..
* Initializing SSL.
Possible error encountered (IRCd seemingly not started)
=====================================================
Check above for possible errors, and this output of
ircd.log. If you cannot solve the problem, read
Unreal.nfo on where to get support
=====================================================
[Sat Jun 16 14:25:14 2007] - Failed to load SSL certificate server.cert.pem
TagsNo tags attached.
3rd party modules

Activities

Stealth

2007-06-16 13:31

reporter   ~0014369

Duplicate of 0002313 (resolved)... Doesn't look like it has been fixed (tested on latest devel)

Stealth

2007-06-16 13:32

reporter   ~0014370

It also appears devel does not copy the chanmode modules over yet either

Bock

2007-06-16 15:33

reporter   ~0014373

syzop right about exist files. Script must checking if they exist.

Oh, I write a patch. Diff attached.

2007-06-16 15:34

 

Makefile.in.diff (481 bytes)

stskeeps

2007-06-22 04:27

reporter   ~0014400

Patched in .2448

stskeeps

2007-06-22 04:27

reporter   ~0014401

Patched in .2448

Issue History

Date Modified Username Field Change
2007-06-16 06:26 Bock New Issue
2007-06-16 13:31 Stealth Note Added: 0014369
2007-06-16 13:32 Stealth Note Added: 0014370
2007-06-16 15:33 Bock Note Added: 0014373
2007-06-16 15:34 Bock File Added: Makefile.in.diff
2007-06-17 06:13 stskeeps Status new => confirmed
2007-06-22 04:27 stskeeps Status confirmed => resolved
2007-06-22 04:27 stskeeps Fixed in Version => 3.3-alpha0
2007-06-22 04:27 stskeeps Resolution open => fixed
2007-06-22 04:27 stskeeps Assigned To => stskeeps
2007-06-22 04:27 stskeeps Note Added: 0014400
2007-06-22 04:27 stskeeps Note Added: 0014401