View Issue Details

IDProjectCategoryView StatusLast Update
0003554unrealircdpublic2008-02-11 16:06
ReporterQuisAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSFreeBSDOS Version6.2
Product Version3.2.7 
Target VersionFixed in Version3.2.8 
Summary0003554: Setting ban on channel with +b ?!*@*
DescriptionI wanted to ban all single character nicknames from my channel,
so I added ?*!*@ to the banlist.

After doing it not all bans where set successfully,
+b ~q:*!*@host bans were done successful, but *!*@host didn't work well anymore.
Steps To Reproduce<< MODE #bantest +b test!*@*
>> :Quis!quis@host MODE #bantest +b test!*@*
<< MODE #bantest -b test!*@*
>> :Quis!quis@host MODE #bantest -b test!*@*
<< MODE #bantest +b ?!*@*
>> :Quis!quis@host MODE #bantest +b ?!*@*
<< MODE #bantest +b test!*@*
>> :Quis!quis@host MODE #bantest +b test!*@*
<< MODE #bantest -b test!*@*
>> :Quis!quis@host MODE #bantest -b test!*@*
<< MODE #bantest +b *!*@test
-- Nothing happens
TagsNo tags attached.
3rd party modulesjoinpartsno, getinfo, textban, levellimit, m_banlink (None were in effect on my channel)

Relationships

child of 0003454 resolvedsyzop Unreal3.2.8 TODO 

Activities

aquanight

2007-12-18 01:39

reporter   ~0014912

This is a known issue. Basically unreal is trying to be too smart with ban wildcards. As a workaround for your specific case, try using banmasks like this: ?*!*@host (ie, with an extra ? in front of the * for the nick). The problem is unreal does a pattern match of a new ban against existing bans and blocks the new ban if it matches.

Quis

2007-12-21 13:20

reporter   ~0014921

Typo in my first post: ?*!*@* should be ?!*@* (Banning all single-char nicknames)

Or do you mean use ?*!*@* for new bans (the ones that get blocked now) ?

syzop

2007-12-22 19:02

administrator   ~0014924

I think we should get rid of this smart stuff, nothing should break when we do...

syzop

2008-02-11 16:05

administrator   ~0015080

fixed in .698:

- So called 'smart' banning is now disabled by default, this means you can
  now set a ban on *!*@*h.com and then later add one on *!*@*blah.com without
  any trouble. Previously the second one was rejected due to the former
  already matching it. To change it back edit the include/config.h setting
  SOCALLEDSMARTBANNING.

Issue History

Date Modified Username Field Change
2007-12-17 00:26 Quis New Issue
2007-12-17 00:26 Quis 3rd party modules => joinpartsno, getinfo, textban, levellimit, m_banlink (None were in effect on my channel)
2007-12-18 01:39 aquanight Note Added: 0014912
2007-12-21 13:20 Quis Note Added: 0014921
2007-12-22 19:02 syzop Note Added: 0014924
2007-12-22 19:02 syzop Status new => acknowledged
2007-12-22 19:02 syzop Relationship added child of 0003454
2008-02-11 16:05 syzop QA => Not touched yet by developer
2008-02-11 16:05 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2008-02-11 16:05 syzop Status acknowledged => resolved
2008-02-11 16:05 syzop Fixed in Version => 3.2.8
2008-02-11 16:05 syzop Resolution open => fixed
2008-02-11 16:05 syzop Assigned To => syzop
2008-02-11 16:05 syzop Note Added: 0015080