View Issue Details

IDProjectCategoryView StatusLast Update
0003864unrealircdpublic2009-08-26 12:30
ReporterDragon_LegionAssigned Tosyzop 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnreal 3.2.xOS*NIXOS VersionCentOS 5
Product Version3.2.8 
Target VersionFixed in Version3.2.9-RC1 
Summary0003864: munmap_chunk(): Invalid Pointer: crash
DescriptionIRCD crashes on boot with *** glibc detected *** /path/to/Unreal3.2/src/ircd: munmap_chunk(): invalid pointer: 0x080ab7d4 ***
Additional Information./unreal backtrace

=================== START HERE ======================
BACKTRACE:

warning: Can't read pathname for load map: Input/output error.
Core was generated by `/home/dragon/unreal-test/Unreal3.2/src/ircd'.
Program terminated with signal 6, Aborted.
[New process 17351]
#0 0x00403410 in __kernel_vsyscall ()
#0 0x00403410 in __kernel_vsyscall ()
#1 0x002acd80 in raise () from /lib/libc.so.6
#2 0x002ae691 in abort () from /lib/libc.so.6
#3 0x002e524b in __libc_message () from /lib/libc.so.6
#4 0x002f0ceb in free () from /lib/libc.so.6
#5 0x0806f8b6 in _conf_class (conf=0x8ced488, ce=0x3c3ff4) at s_conf.c:3594
#6 0x0806db32 in config_run () at s_conf.c:2316
#7 0x0806eeaa in init_conf (rootconf=0x80ab7c4 "unrealircd.conf", rehash=0)
    at s_conf.c:1762
0000008 0x0806148d in main (argc=0, argv=<value optimized out>) at ircd.c:1447

#0 0x00403410 in __kernel_vsyscall ()

0x81467c0 <backupbuf>: ""

#0 0x00403410 in __kernel_vsyscall ()
No symbol table info available.
#1 0x002acd80 in raise () from /lib/libc.so.6
No symbol table info available.
#2 0x002ae691 in abort () from /lib/libc.so.6
---Type <return> to continue, or q <return> to quit---
No symbol table info available.
GCC: gcc version 4.1.2 20080704 (Red Hat 4.1.2-44)
UNAME: Linux thor.fusedhosting.net 2.6.18-53.1.4.el5.centos.plusPAE #1 SMP Fri Dec 7 07:40:34 EST 2007 i686 i686 i386 GNU/Linux
UNREAL: Unreal3.2.8.1 build 1.1.1.1.2.26 2009/04/13 11:03:55
CORE: -rw------- 1 dragon dragon 1257472 Aug 10 09:28 core.17351
=================== STOP HERE ======================
TagsNo tags attached.
3rd party modulesnone

Activities

syzop

2009-08-17 12:04

administrator   ~0015927

Last edited: 2009-08-17 12:05

Does this happen consistently? So always crashing?
Is it a crash-on-boot, or after a rehash? (looks like the former)

Could you send your configuration file (unrealircd.conf, and any others if necessary) to syzop@vulnscan.org ?

Thanks.

EDIT: naturally feel free to xxxxx out passwords, cloak keys and IP/hosts, but preferably do not edit the rest.

syzop

2009-08-26 12:30

administrator   ~0015928

Fixed in CVS:
- class name 'default' is reserved. Using it caused the ircd to crash
  on-boot, reported by Dragon_Legion (0003864).

Thanks for the report.

Issue History

Date Modified Username Field Change
2009-08-10 21:00 Dragon_Legion New Issue
2009-08-10 21:00 Dragon_Legion 3rd party modules => none
2009-08-17 12:04 syzop Note Added: 0015927
2009-08-17 12:05 syzop Note Edited: 0015927
2009-08-26 12:30 syzop QA => Not touched yet by developer
2009-08-26 12:30 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2009-08-26 12:30 syzop Note Added: 0015928
2009-08-26 12:30 syzop Status new => resolved
2009-08-26 12:30 syzop Fixed in Version => 3.2.9-RC1
2009-08-26 12:30 syzop Resolution open => fixed
2009-08-26 12:30 syzop Assigned To => syzop