View Issue Details

IDProjectCategoryView StatusLast Update
0003910unrealircdpublic2010-05-30 17:49
Reporterseraph Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionduplicate 
Product Version3.2.9-RC1 
Summary0003910: Feature Request: Remote MOTD and Rules file
DescriptionPlease add the following feature request to the .9 to-do list.

I would like to have the option to use remote MOTD and Rules files settable at the tld block and at set:: block for the default MOTD/Rules files.
The same for shortmotd, opermotd and botmotd.
tld {
motd "https://user:pw@any.domain.com/path/motd-en.motd";
rules "https://user:pw@any.domain.com/path/rules-en.motd";
};
Using libcurl it should be no problem getting them from an other source, just the same way as remote includes.

Also (I think it´s already mentioned anywhere) remote includes should use the latest used config file at rehash if the source server is not avaiable for some reason to allow a running ircd.

Reason: This could save administrators of larger networks a lot of time, because updating each servers motd one by one can be a pain in the ass.
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0001507 resolvedsyzop Remote including of MOTD files 

Activities

syzop

2010-05-30 17:49

administrator   ~0016112

See 0001507... ignore the 3.3* bit, it's ok if it's done for 3.2*, but you need to find someone to do it, and it's not a 1 2 3 job (due to the asynchronous nature) :P.

As for:
"Also (I think it´s already mentioned anywhere) remote includes should use the latest used config file at rehash if the source server is not avaiable for some reason to allow a running ircd."
Yeah I've implemented this in CVS / will be in 3.2.9. It's indeed something quite important / useful.. without it, remote includes can easily prevent a whole server start which sucks bigtime.. on any network...

(oh and no I don't blame you for not searching the bugs, especially since it was on page 2 :P)

Issue History

Date Modified Username Field Change
2010-05-30 10:51 seraph New Issue
2010-05-30 17:46 syzop Relationship added duplicate of 0001507
2010-05-30 17:49 syzop QA => Not touched yet by developer
2010-05-30 17:49 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-05-30 17:49 syzop Note Added: 0016112
2010-05-30 17:49 syzop Status new => closed
2010-05-30 17:49 syzop Resolution open => duplicate