View Issue Details

IDProjectCategoryView StatusLast Update
0001507unrealircdpublic2010-07-14 21:27
ReporteraceAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version3.2.9-RC1 
Summary0001507: Remote including of MOTD files
DescriptionIt would be nice to be able to remotely ircd.motd, ircd.rules, ...files. There would be a block like:

motds {
motd "ircd.motd";
rules "ircd.rules";
...
};

Something like that. If you want to load an MOTD remotely, you'd simply replace the above with a URL, like http://www.domain.com/ircd.motd
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0002209 closed Remote downloading of motd and rules 
has duplicate 0003034 closed Remote MOTD / RULES (like remote includes) 
has duplicate 0003910 closed Feature Request: Remote MOTD and Rules file 
related to 0003202 acknowledged Allow remote includes anywhere a file is expected 

Activities

PHANTOm

2004-02-23 13:21

reporter   ~0005166

and this feature for tld:: would be even more usefull.

codemastr

2004-02-23 16:55

reporter   ~0005167

I'll have to think about this. It definately will not be done until after 3.2 though.

w00t

2004-02-26 18:01

reporter   ~0005219

Hm... A web accessible motd... That could raise some quite interesting possibilities for irc stats pages on websites... :)

aquanight

2004-12-01 22:45

reporter   ~0008450

>Hm... A web accessible motd... That could raise some quite interesting possibilities for irc stats pages on websites... :)

(Except don't forget that you have to /rehash [-motd] every time you update :-P .)

zEkEsTeR

2004-12-09 23:31

reporter   ~0008574

i built a simple perl script to do this, its about time I updated it...
Basically it would download the network MOTD from the network site, merge it with a local MOTD for the individual server, move it to the Unreal dir, connect to the IRCd, oper, and /rehash -motd. Works well, now expanded so it auto-updates, as well as handling other .conf files, as a number of the servers on the network couldn't get curl installed for whatever reason.

aquanight

2004-12-10 12:12

reporter   ~0008581

>connect to the IRCd, oper, and /rehash -motd

For the record, you do know you could just sighup the thing? :P

Anyway, it's also not hard for something like services to read MOTD from an http server and SVSMOTD it out to everywhere... but this could be interesting nonetheless.

On another consideration, if a tld from a remote included .conf specifies an motd, where is that motd read from (it might not make sense to read it from the local machine)? (I guess the same can be asked about confs included from a remote include... :o .)

syzop

2006-09-01 05:19

administrator   ~0012277

Last edited: 2006-09-01 05:19

I think we all agree this idea would be nice. Just need to hook someone to implement it ;p. This would be for Unreal3.3*.

When you're at it, see also 0003034 for some talk about specifying default motd/rules files... Even though I'm unsure if it's that useful since you can get the exact same effect by having a tld *@* block (ok almost, exact effect ;P).

djGrrr

2006-09-07 21:15

reporter   ~0012347

(ok almost, exact effect ;P). <-- exactly, apparantly remote queries of the motd only return the default ones... and well, adding a tld block just for that is kinda annoying :P

syzop

2010-07-14 21:27

administrator   ~0016190

Both specifying default motd/rules files through the files:: block, and now also the remote MOTD/rules/etc thing in CVS (for 3.2.9), are done now.

Issue History

Date Modified Username Field Change
2004-01-24 02:14 ace New Issue
2004-02-23 13:21 PHANTOm Note Added: 0005166
2004-02-23 16:55 codemastr Note Added: 0005167
2004-02-26 18:01 w00t Note Added: 0005219
2004-12-01 18:21 syzop Relationship added has duplicate 0002209
2004-12-01 22:45 aquanight Note Added: 0008450
2004-12-09 23:31 zEkEsTeR Note Added: 0008574
2004-12-10 12:12 aquanight Note Added: 0008581
2006-09-01 05:16 syzop Relationship added has duplicate 0003034
2006-09-01 05:17 syzop Status new => acknowledged
2006-09-01 05:19 syzop Note Added: 0012277
2006-09-01 05:19 syzop Note Edited: 0012277
2006-09-07 21:15 djGrrr Note Added: 0012347
2007-04-19 03:16 stskeeps Relationship added related to 0003202
2010-05-30 17:46 syzop Relationship added has duplicate 0003910
2010-07-14 21:27 syzop QA => Not touched yet by developer
2010-07-14 21:27 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-07-14 21:27 syzop Note Added: 0016190
2010-07-14 21:27 syzop Status acknowledged => resolved
2010-07-14 21:27 syzop Fixed in Version => 3.2.9-RC1
2010-07-14 21:27 syzop Resolution open => fixed
2010-07-14 21:27 syzop Assigned To => syzop
2010-12-24 22:57 Stealth Relationship added has duplicate 0003986
2010-12-25 00:33 ohnobinki Relationship deleted has duplicate 0003986