View Issue Details

IDProjectCategoryView StatusLast Update
0003943unrealircdpublic2010-11-16 20:36
ReportersyzopAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
PlatformAnyOSWindowsOS Version???
Product Version3.2.8 
Target VersionFixed in Version3.2.9-RC1 
Summary0003943: loadmodule permission denied errors on windows
DescriptionIt seems we frequently get users with 'Permission denied' problems in the support channel, and sometimes on the forums. However, there has never been a bugreport about it.

I wonder what's causing these errors, and if we can do something about it to prevent them... either in the installer or in Unreal.

It seems to happen more often than before, when I thought it was just someone incorrectly CACLS'ing or whatever their c:\program files, it seems to be a more general issue now...

I've never experienced the issue myself (XP), so any advice on how to reproduce it would be nice. Stealth, or anyone else? :P
Additional InformationIt's not my idea to add issues this late for release, but if this could be fixed for 3.2.9 it would be nice, it seems like a real issue.. but I don't know how big it is or how easy or hard to fix...
TagsNo tags attached.
3rd party modules

Relationships

child of 0003776 resolvedsyzop Unreal3.2.9 TODO 

Activities

Bock

2010-08-24 22:48

reporter   ~0016310

Unreal installer want admin rights for setup.
http://a.imageshack.us/img26/499/unrealwarn01.png

Cannot run makecert.bat after install under user
http://a.imageshack.us/img90/3699/unrealwarn04.png

Only if I give admin rights for me through Properties - Security to whole folder Unreal 3.2 it give to me write/read files and run unreal just starting wircd.exe

If I check "install as service", service is installed, but makecert.bat have the same problem. I need to open "cmd" as admin and start makecert.bat in Unreal3.2 dir.

I don't see loadmodule error in my Win 7 (x64).

KnopeX

2010-08-27 18:37

reporter   ~0016321

Since i have UnrealIRCd on Win7 i didn't notice a error when i loaded a 3rd party module or something else...

goldenwolf

2010-10-20 01:49

reporter   ~0016386

Last edited: 2010-10-24 20:51

Hey,
The reason a error like:
Unable to create file 'tmp/10D9D743.commands.dll': Permission denied
shows up is because as a normal user we do not have the ability in Windows 7/vista to write to Program Files folder where Unreal folder is located and where tmp folder is created. I think in future, the tmp files should be created in
%AppData%
added a simple patch (just as a idea, would need to fix other tmp directives to match with this if its okay to do something like this.)

2010-10-24 19:57

 

patch2 (530 bytes)

goldenwolf

2010-10-31 15:53

reporter   ~0016394

Actually, looking at the installation script, it would probably be easier to do something like,

[Dirs]
Name: "{app}\tmp\"; Permissions: everyone-modify

Which will basically set the permissions on creation and this indeed does work and is a very easy fix.

2010-10-31 16:17

 

patch2.patch (556 bytes)

syzop

2010-11-15 14:28

administrator   ~0016400

Thanks for tracing this.
I've made a new installer: http://www.vulnscan.org/tmp/Unreal3.2.8.1-ssl-permtest.exe
This one sets permissions of the Unreal3.2 directory (and it's children) to be writable by the user running the install. The user can still decide not to do this, as it's a checkbox item (and is checked by default).
It does this right after installing the files, so before makecert is run.
I decided to go this way, because setting it to everyone sounds a bit overkill, and 'simply' moving tmp to the profile isn't an option either as you then still have problems with ircd.log, ircd.tune, and any other files (think: 3rd party modules) that need to be writable/creatable.

<offtopic>It also prevents trying to both install as a service and encrypt the certificate.</offtopic>

If anyone who normally experiences this problem with UnrealIRCd under windows could test it with this installer, that would be nice :)

syzop

2010-11-15 14:41

administrator   ~0016401

Added in CVS .894, but like I said, I will need confirmation before marking this issue as resolved:
- Win32 installer: Make it so a user can no longer accidentally check both
  'install as service' and 'encrypt SSL certificate', as they are
  incompatible (a service cannot ask a user to enter a password).
- Win32 installer: Fixed long outstanding problem with some Vista / Windows 7
  installations, which has to do with file permissions of the Unreal3.2
  folder. Symptoms were error messages such as:
  Unable to create file 'tmp/10D9D743.commands.dll': Permission denied
  But also failing to create SSL certificates, nothing being logged, etc.
  This is now fixed by setting write access on the Unreal3.2 folder to the
  user running the install, unless the user chooses not to use this new
  option (it can be unchecked), in which case the user is warned that he
  should take care of this himself.
  Reported by various persons, special thanks to Bock and goldenwolf for
  helping us to track down this issue (0003943).

syzop

2010-11-15 14:44

administrator   ~0016402

Bock, 'Unreal installer want admin rights for setup' will still be the case (this is correct), but the 'Cannot run makecert.bat after install under user' should be fixed.

syzop

2010-11-15 14:45

administrator   ~0016403

Last edited: 2010-11-15 14:48

View 2 revisions

ARGH.. why does mantis change bug status if I post a comment? Leave it at 'feedback' damn it...

EDIT: Ah, $g_reassign_on_feedback = OFF !

goldenwolf

2010-11-15 17:52

reporter   ~0016414

Hey,
http://www.vulnscan.org/tmp/Unreal3.2.8.1-ssl-permtest.exe fixes the issue.

Bock

2010-11-16 18:51

reporter   ~0016418

works nice for me. certs are makes correctly, permissions on folder is good too.

syzop

2010-11-16 20:36

administrator   ~0016419

Great, thanks to both of you for your help :)

Issue History

Date Modified Username Field Change
2010-08-13 11:07 syzop New Issue
2010-08-13 11:07 syzop QA => Not touched yet by developer
2010-08-13 11:07 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-08-13 11:07 syzop U4: Upstream notification of bug => Not decided
2010-08-13 11:07 syzop U4: Contributor working on this => None
2010-08-13 11:07 syzop Relationship added child of 0003776
2010-08-13 11:10 syzop Summary Permission denied errors on windows => loadmodule permission denied errors on windows
2010-08-24 20:17 syzop Status new => feedback
2010-08-24 22:48 Bock Note Added: 0016310
2010-08-27 18:37 KnopeX Note Added: 0016321
2010-10-20 01:49 goldenwolf Note Added: 0016386
2010-10-24 18:52 goldenwolf Note Edited: 0016386
2010-10-24 18:53 goldenwolf Note Edited: 0016386
2010-10-24 19:57 goldenwolf File Added: patch2
2010-10-24 19:58 goldenwolf Note Edited: 0016386
2010-10-24 20:51 goldenwolf Note Edited: 0016386
2010-10-31 15:53 goldenwolf Note Added: 0016394
2010-10-31 16:17 goldenwolf File Added: patch2.patch
2010-11-15 14:28 syzop Note Added: 0016400
2010-11-15 14:28 syzop Status feedback => new
2010-11-15 14:30 syzop Assigned To => syzop
2010-11-15 14:30 syzop Status new => feedback
2010-11-15 14:41 syzop Note Added: 0016401
2010-11-15 14:41 syzop Status feedback => assigned
2010-11-15 14:43 syzop Assigned To syzop =>
2010-11-15 14:43 syzop Status assigned => feedback
2010-11-15 14:44 syzop Note Added: 0016402
2010-11-15 14:44 syzop Status feedback => new
2010-11-15 14:45 syzop Note Added: 0016403
2010-11-15 14:45 syzop Status new => feedback
2010-11-15 14:48 syzop Note Edited: 0016403 View Revisions
2010-11-15 17:52 goldenwolf Note Added: 0016414
2010-11-16 18:51 Bock Note Added: 0016418
2010-11-16 20:36 syzop Note Added: 0016419
2010-11-16 20:36 syzop Status feedback => resolved
2010-11-16 20:36 syzop Fixed in Version => 3.2.9-RC1
2010-11-16 20:36 syzop Resolution open => fixed
2010-11-16 20:36 syzop Assigned To => syzop