View Issue Details

IDProjectCategoryView StatusLast Update
0004049unrealinstallingpublic2012-12-25 18:09
ReporterseraphAssigned Tosyzop 
PrioritylowSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.9 
Target VersionFixed in Version3.2.10 
Summary0004049: Using a version named folder at the tarball
DescriptionI recommend the use of a folder named by the current version at the tarball, as it is "Unreal3.2" I and a lot other people were close overwriting their current setup by accident.
TagsNo tags attached.
3rd party modules

Relationships

child of 0003915 resolvedsyzop Unreal3.2.10 TODO 
child of 0004301 resolvedsyzop Unreal3.2.10 TODO 

Activities

warg

2011-11-06 17:26

reporter   ~0016777

Last edited: 2011-11-06 17:32

View 2 revisions

+1

samu

2011-11-06 17:29

reporter   ~0016778

Yes, it is a good idea. I have also overwritten my setup when extracting that tarball. God bless backups.

tom7141

2011-11-06 17:40

reporter   ~0016779

+1 here to i all most did the same thing had one of them last moemnet rebound way from the enter key at the last moment sort of moments followed by a phew lol

xaero

2011-11-06 18:17

reporter   ~0016782

+1 Now that I have the right account. This is just smart, I've trashed an ircd more then once because I was running it from the same directory as it was built in. This forced me to install to a different target to prevent this from happening.

ohnobinki

2011-11-07 01:25

reporter   ~0016783

++

The folder name should be identical to the tarball's basename, as is standard practice.

But, of course, this shouldn't be changed for the current release because that'd invalidate checksums and it is more of a minor issue.

katsklaw

2011-11-20 21:39

reporter   ~0016794

+1

static-x

2011-11-22 02:58

reporter   ~0016796

Most *nux users mv Unreal3.2 - urown.

xaero

2011-11-22 03:17

reporter   ~0016797

That's not the point static-x. having a tarball named UnrealVerision and an untar'd product as UnrealVersion and then having the default --prefix as UnrealVersion makes things very difficult. Now if tarballs and the untar'd product followed the basic convention of ProjectName-Version and --prefix was an entirely different target (say ircd or something similar) then this problem wouldn't be an issue.

Issue History

Date Modified Username Field Change
2011-11-06 17:20 seraph New Issue
2011-11-06 17:26 warg Note Added: 0016777
2011-11-06 17:29 samu Note Added: 0016778
2011-11-06 17:32 warg Note Edited: 0016777 View Revisions
2011-11-06 17:40 tom7141 Note Added: 0016779
2011-11-06 18:17 xaero Note Added: 0016782
2011-11-07 01:25 ohnobinki Note Added: 0016783
2011-11-20 21:39 katsklaw Note Added: 0016794
2011-11-22 02:58 static-x Note Added: 0016796
2011-11-22 03:17 xaero Note Added: 0016797
2011-11-26 19:10 syzop Relationship added child of 0003915
2011-11-26 19:10 syzop Status new => acknowledged
2012-12-25 18:08 syzop Status acknowledged => resolved
2012-12-25 18:08 syzop Fixed in Version => 3.2.10
2012-12-25 18:08 syzop Resolution open => fixed
2012-12-25 18:08 syzop Assigned To => syzop