View Issue Details

IDProjectCategoryView StatusLast Update
0004101unrealircdpublic2020-09-28 08:53
ReporterKindOne Assigned Totmcarthur  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Product Version3.2.9 
Summary0004101: Bypass cmode +S
DescriptionANSI Escaped Color sequence
Steps To ReproduceGet a copy of mIRC (I'm using 7.22)

/join #random channel
/mode #random +S
(Also get another connection into the channel to see it)

(You MUST use double // for this to work, as // makes mIRC evaluate the command)
//raw -n PRIVMSG #random : $+ $+($chr(27),[21;03m, This is a funny little way to get around it)

TagsNo tags attached.
3rd party modules

Activities

syzop

2012-08-17 13:42

administrator   ~0017083

Although the documentation says strip/block mIRC color codes. It probably isn't a bad idea to do the same to ANSI. Any objections?
Not really on my own TODO list, but for someone else.. :)

tmcarthur

2014-06-05 17:22

reporter   ~0018183

Last edited: 2014-06-05 17:23

View 2 revisions

If I have time between modularizing cmodes I can have a look. Should be pretty trivial :)

syzop

2014-07-13 12:57

administrator   ~0018213

KindOne commented in 0004321 (nice bug number) regarding a few things like dropping one of the modes and renaming the characters.

That I see no reason for BUT I'm fine with enhancing +S/+c to respectively strip or block bold/underline codes as well. Any objections?
If there are objections we can make it a config option (and decide on a default).

tmcarthur: something you can do at the same time as this bug?

I've set the bug to feedback to gather some... feedback :D

katsklaw

2015-01-01 18:50

reporter   ~0018279

I fail to see the point with cmode +c to start with. We are just wasting cpu cycles on something that will wont be sent to channel anyway. Most of the time, when an user sends colored text to a channel and it's blocked they generally strip the colors and send again which ends up being the same result as +S anyway. The only time I can see +S being a benefit is as an effective block to large acsii art popups and these can also be blocked by +f.

I noticed in 0004321 the idea of dropping +S and running with +c to strip everything and send to target. I'll conditionally +1 that idea. The condition is that we drop +c and keep +S for the mode character since +S already means "strip".

syzop

2020-09-28 08:53

administrator   ~0021782

UnrealIRCd has the 'nocodes' module for people who want this. This can be closed.

Issue History

Date Modified Username Field Change
2012-04-04 02:11 KindOne New Issue
2012-08-17 13:42 syzop Note Added: 0017083
2014-05-31 22:02 syzop Status new => confirmed
2014-06-05 17:22 tmcarthur Note Added: 0018183
2014-06-05 17:22 tmcarthur Assigned To => tmcarthur
2014-06-05 17:22 tmcarthur Status confirmed => assigned
2014-06-05 17:23 tmcarthur Note Edited: 0018183 View Revisions
2014-07-13 12:57 syzop Note Added: 0018213
2014-07-13 12:57 syzop Status assigned => feedback
2014-07-13 12:57 syzop View Status private => public
2015-01-01 18:50 katsklaw Note Added: 0018279
2015-08-08 17:49 syzop Severity minor => feature
2020-09-28 08:53 syzop Status feedback => closed
2020-09-28 08:53 syzop Resolution open => no change required
2020-09-28 08:53 syzop Note Added: 0021782