View Issue Details

IDProjectCategoryView StatusLast Update
0004144unrealircdpublic2019-10-14 14:56
ReporterCronusAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version5.0.0-alpha3 
Summary0004144: Define Variables in config file.
DescriptionBe able to define variables in the configuration file.
Main first thing this would be good for is defining an ip address such as defining server.ip to be 127.0.0.1(or whatever the ip of box is) and you can use this in bind-ip in the link block and therefore able to remote include your server link blocks and have them work across all servers without the need to change the bind-ip setting for each server.
TagsNo tags attached.
3rd party modules

Relationships

related to 0005281 assignedsyzop Configuration file ideas: define and conditional sections 
has duplicate 0004555 closedsyzop #Define options 

Activities

syzop

2012-12-15 20:30

administrator   ~0017259

Sounds like a good idea, as obvious as it sounds.. I like it ;)

cards

2016-01-27 01:07

reporter   ~0019075

Would it make sense to do the string compare/replace in the AddListItem( section. I'm trying to follow the code (to the best of my ability), and this seems to be where the config items are actually stored to the list for memory access, but I'm not sure. If so, I'll keep working on a possible patch.

syzop

2016-01-27 12:28

administrator   ~0019076

Hmm that wouldn't be a good idea, to do it that way. It probably should be done in some initial parsing stage.

syzop

2019-10-14 14:56

administrator   ~0020964

Done and working since 5.0.0-alpha3. 0005281 is used to track the final bits of it.

Issue History

Date Modified Username Field Change
2012-11-18 00:31 Cronus New Issue
2012-12-15 20:30 syzop Note Added: 0017259
2012-12-15 20:30 syzop Status new => confirmed
2016-01-22 17:47 syzop Relationship added has duplicate 0004555
2016-01-27 01:07 cards Note Added: 0019075
2016-01-27 12:28 syzop Note Added: 0019076
2019-10-14 14:55 syzop Relationship added related to 0005281
2019-10-14 14:56 syzop Assigned To => syzop
2019-10-14 14:56 syzop Status confirmed => resolved
2019-10-14 14:56 syzop Resolution open => fixed
2019-10-14 14:56 syzop Fixed in Version => 5.0.0-alpha3
2019-10-14 14:56 syzop Note Added: 0020964