View Issue Details

IDProjectCategoryView StatusLast Update
0004207unrealircdpublic2015-07-19 18:41
ReporternenolodAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version3.4-alpha1Fixed in Version3.4-beta2 
Summary0004207: RFC: bother with hybrid-style localClient split or not
Descriptiondo we want to split most of aClient structure out, or continue with the 2.8-style hack?

(this can be sorted post-alpha1, but soft-blocks the memory pooling work)
TagsNo tags attached.
3rd party modules

Relationships

related to 0004203 new convert commonly allocated structures to use mempool code 
child of 0004215 closed Unreal 3.4 alpha2 blockers 

Activities

syzop

2013-05-21 20:59

administrator   ~0017649

I'm not familiar with the phrase, but I presume you mean the local / remote client distinction where we only allocate the first part of the struct and not the rest? Which often means new people without knowing it are reading/writing out of bounds data because they have no idea? ;p

What solution do you propose? Move all 'local extra data' to a separate struct referenced from aClient * ? like sptr->user but sptr->local ?

Let me know.

nenolod

2013-05-21 21:17

reporter   ~0017652

Yes, moving it to sptr->local is what I have in mind.

syzop

2013-05-21 21:33

administrator   ~0017653

Yup, sounds good.

nenolod

2013-05-25 00:35

reporter   ~0017667

we definitely need to do this, i just found an arbitrary local vs. remote write causing an issue (0004209).

there are probably other corner-cases where this is presently happening.

we will do it for alpha2.

syzop

2015-07-19 18:41

administrator   ~0018525

Done in beta2

Issue History

Date Modified Username Field Change
2013-05-20 22:36 nenolod New Issue
2013-05-20 22:36 nenolod Relationship added related to 0004203
2013-05-21 20:59 syzop Note Added: 0017649
2013-05-21 21:17 nenolod Note Added: 0017652
2013-05-21 21:33 syzop Note Added: 0017653
2013-05-25 00:35 nenolod Note Added: 0017667
2013-05-25 00:36 nenolod Relationship added child of 0004215
2015-07-19 18:41 syzop Note Added: 0018525
2015-07-19 18:41 syzop Status new => resolved
2015-07-19 18:41 syzop Fixed in Version => 3.4-beta2
2015-07-19 18:41 syzop Resolution open => fixed
2015-07-19 18:41 syzop Assigned To => syzop