View Issue Details

IDProjectCategoryView StatusLast Update
0004333unrealircdpublic2015-07-23 14:31
ReporterhunterkllAssigned Tosyzop 
PriorityhighSeveritycrashReproducibilityrandom
Status resolvedResolutionfixed 
Platformamd64 in XenServer VMOSDebianOS Version7
Product Version3.4-alpha1 
Target VersionFixed in Version3.4-beta2 
Summary0004333: Segfault crashing IRCd after random amount of runtime
DescriptionIRCD crashes. Noted in dmesg were:

[2457016.748237] ircd[29227] general protection ip:7fb0211ec08d sp:7fff88daa450 error:0 in libc-2.11.3.so[7fb02117a000+159000]

and 2nd crash:

[2483466.455864] ircd[12972]: segfault at 4a ip 00007fafde99466e sp 00007fffee880390 error 6 in libc-2.11.3.so[7fafde920000+159000]
Steps To Reproduceinstall and run ircd
Additional Informationsystem is only used for ircd, base install with just system tools, compiler tools, and ssh server.
TagsNo tags attached.
3rd party modulesnone

Activities

syzop

2014-10-24 21:06

administrator   ~0018257

Could you run "./unreal backtrace" and paste the results back to us?

hunterkll

2014-10-26 02:32

reporter   ~0018262

Here ya go.

BACKTRACE:

warning: Can't read pathname for load map: Input/output error.
Error while mapping shared library sections:
tmp/F7D720D4.cloak.so: No such file or directory.
Error while mapping shared library sections:
tmp/724AF6BF.m_sethost.so: No such file or directory.
Error while mapping shared library sections:
tmp/9ABF9622.m_chghost.so: No such file or directory.
Error while mapping shared library sections:
tmp/6D0B0905.m_chgident.so: No such file or directory.
Error while mapping shared library sections:
tmp/B4D379C4.m_setname.so: No such file or directory.
Error while mapping shared library sections:
tmp/DB7C4F56.m_setident.so: No such file or directory.
Error while mapping shared library sections:
tmp/F9A72D3F.m_sdesc.so: No such file or directory.
Error while mapping shared library sections:
tmp/5E312A9D.m_svsmode.so: No such file or directory.
Error while mapping shared library sections:
tmp/AAAC2D67.m_swhois.so: No such file or directory.
Error while mapping shared library sections:
tmp/E5B1E1FB.m_svsmotd.so: No such file or directory.
Error while mapping shared library sections:
tmp/872C9072.m_svsnline.so: No such file or directory.
Error while mapping shared library sections:
tmp/D2799AC.m_who.so: No such file or directory.
Error while mapping shared library sections:
tmp/7B4B6988.m_mkpasswd.so: No such file or directory.
Error while mapping shared library sections:
tmp/66448DD0.m_away.so: No such file or directory.
Error while mapping shared library sections:
tmp/B0893EA6.m_svsnoop.so: No such file or directory.
Error while mapping shared library sections:
tmp/21A019A0.m_svso.so: No such file or directory.
Error while mapping shared library sections:
tmp/900D5F44.m_svsnick.so: No such file or directory.
Error while mapping shared library sections:
tmp/B9DDAA0B.m_adminchat.so: No such file or directory.
Error while mapping shared library sections:
tmp/2EFCCF5C.m_chgname.so: No such file or directory.
Error while mapping shared library sections:
tmp/4E92DBA4.m_guest.so: No such file or directory.
Error while mapping shared library sections:
tmp/B7A7D640.m_kill.so: No such file or directory.
Error while mapping shared library sections:
tmp/54DB5B6D.m_lag.so: No such file or directory.
Error while mapping shared library sections:
tmp/E8BDAD9A.m_message.so: No such file or directory.
Error while mapping shared library sections:
tmp/BCAFE3A4.m_nachat.so: No such file or directory.
Error while mapping shared library sections:
tmp/470E8D08.m_oper.so: No such file or directory.
Error while mapping shared library sections:
tmp/60FBBB1C.m_pingpong.so: No such file or directory.
Error while mapping shared library sections:
tmp/F3EC55D9.m_quit.so: No such file or directory.
Error while mapping shared library sections:
tmp/2B72B041.m_rping.so: No such file or directory.
Error while mapping shared library sections:
tmp/310DD800.m_sendumode.so: No such file or directory.
Error while mapping shared library sections:
tmp/BC272F9F.m_sqline.so: No such file or directory.
Error while mapping shared library sections:
tmp/50311EC8.m_tsctl.so: No such file or directory.
Error while mapping shared library sections:
tmp/E1778C2.m_unkline.so: No such file or directory.
Error while mapping shared library sections:
tmp/831855A.m_unsqline.so: No such file or directory.
Error while mapping shared library sections:
tmp/8C99729.m_unzline.so: No such file or directory.
Error while mapping shared library sections:
tmp/9FD4C528.m_whois.so: No such file or directory.
Error while mapping shared library sections:
tmp/E7A98CFB.m_tkl.so: No such file or directory.
Error while mapping shared library sections:
tmp/F063802.m_vhost.so: No such file or directory.
Error while mapping shared library sections:
tmp/E0468FE2.m_cycle.so: No such file or directory.
Error while mapping shared library sections:
tmp/9C974091.m_svsjoin.so: No such file or directory.
Error while mapping shared library sections:
tmp/6C3C57FA.m_svspart.so: No such file or directory.
Error while mapping shared library sections:
tmp/B3CCA703.m_svswatch.so: No such file or directory.
Error while mapping shared library sections:
tmp/CC29C54E.m_svssilence.so: No such file or directory.
Error while mapping shared library sections:
tmp/43C55A0D.m_sendsno.so: No such file or directory.
Error while mapping shared library sections:
tmp/FE7CD1C2.m_svssno.so: No such file or directory.
Error while mapping shared library sections:
tmp/68F55952.m_sajoin.so: No such file or directory.
Error while mapping shared library sections:
tmp/FE07AF71.m_sapart.so: No such file or directory.
Error while mapping shared library sections:
tmp/E5DC4B39.m_samode.so: No such file or directory.
Error while mapping shared library sections:
tmp/DB48BA5.m_kick.so: No such file or directory.
Error while mapping shared library sections:
tmp/48291CBB.m_topic.so: No such file or directory.
Error while mapping shared library sections:
tmp/98AAAB22.m_invite.so: No such file or directory.
Error while mapping shared library sections:
tmp/BE97A078.m_list.so: No such file or directory.
Error while mapping shared library sections:
tmp/345869AD.m_time.so: No such file or directory.
Error while mapping shared library sections:
tmp/8AB072F0.m_sjoin.so: No such file or directory.
Error while mapping shared library sections:
tmp/675D7183.m_svskill.so: No such file or directory.
Error while mapping shared library sections:
tmp/815906B7.m_pass.so: No such file or directory.
Error while mapping shared library sections:
tmp/12E1828D.m_userhost.so: No such file or directory.
Error while mapping shared library sections:
tmp/AFBF14D0.m_ison.so: No such file or directory.
Error while mapping shared library sections:
tmp/5513D0C4.m_silence.so: No such file or directory.
Error while mapping shared library sections:
tmp/C1E766C.m_knock.so: No such file or directory.
Error while mapping shared library sections:
tmp/EF276F89.m_umode2.so: No such file or directory.
Error while mapping shared library sections:
tmp/A9E9EDBD.m_squit.so: No such file or directory.
Error while mapping shared library sections:
tmp/A0A43F08.m_protoctl.so: No such file or directory.
Error while mapping shared library sections:
tmp/B268315.m_addline.so: No such file or directory.
Error while mapping shared library sections:
tmp/EC6BD3E5.m_addomotd.so: No such file or directory.
Error while mapping shared library sections:
tmp/39512F5F.m_wallops.so: No such file or directory.
Error while mapping shared library sections:
tmp/D7384734.m_admin.so: No such file or directory.
Error while mapping shared library sections:
tmp/6D2052A9.m_globops.so: No such file or directory.
Error while mapping shared library sections:
tmp/4731482E.m_locops.so: No such file or directory.
Error while mapping shared library sections:
tmp/4F875F28.m_chatops.so: No such file or directory.
Error while mapping shared library sections:
tmp/CD7A1612.m_trace.so: No such file or directory.
Error while mapping shared library sections:
tmp/A984344B.m_netinfo.so: No such file or directory.
Error while mapping shared library sections:
tmp/CFAD4A95.m_links.so: No such file or directory.
Error while mapping shared library sections:
tmp/2A65B1A0.m_help.so: No such file or directory.
Error while mapping shared library sections:
tmp/4501D550.m_rules.so: No such file or directory.
Error while mapping shared library sections:
tmp/AF5608C2.m_close.so: No such file or directory.
Error while mapping shared library sections:
tmp/D1FD1533.m_map.so: No such file or directory.
Error while mapping shared library sections:
tmp/C5CABAF4.m_eos.so: No such file or directory.
Error while mapping shared library sections:
tmp/2EF88A38.m_server.so: No such file or directory.
Error while mapping shared library sections:
tmp/25E2072A.m_stats.so: No such file or directory.
Error while mapping shared library sections:
tmp/5BD08231.m_svsfline.so: No such file or directory.
Error while mapping shared library sections:
tmp/4F6C4ADA.m_dccdeny.so: No such file or directory.
Error while mapping shared library sections:
tmp/148FF568.m_undccdeny.so: No such file or directory.
Error while mapping shared library sections:
tmp/2180D657.m_whowas.so: No such file or directory.
Error while mapping shared library sections:
tmp/3F0C892F.m_connect.so: No such file or directory.
Error while mapping shared library sections:
tmp/C748F008.m_dccallow.so: No such file or directory.
Error while mapping shared library sections:
tmp/7A50B6C2.m_userip.so: No such file or directory.
Error while mapping shared library sections:
tmp/C9CAE931.m_nick.so: No such file or directory.
Error while mapping shared library sections:
tmp/989F99F1.m_user.so: No such file or directory.
Error while mapping shared library sections:
tmp/548F0668.m_mode.so: No such file or directory.
Error while mapping shared library sections:
tmp/8DC2021B.m_watch.so: No such file or directory.
Error while mapping shared library sections:
tmp/DB6DA29F.m_part.so: No such file or directory.
Error while mapping shared library sections:
tmp/1AB51501.m_join.so: No such file or directory.
Error while mapping shared library sections:
tmp/3A0CEA64.m_motd.so: No such file or directory.
Error while mapping shared library sections:
tmp/878CF1C0.m_opermotd.so: No such file or directory.
Error while mapping shared library sections:
tmp/C60A65F8.m_botmotd.so: No such file or directory.
Error while mapping shared library sections:
tmp/D98712FD.m_lusers.so: No such file or directory.
Error while mapping shared library sections:
tmp/6A57E550.m_names.so: No such file or directory.
Error while mapping shared library sections:
tmp/86104E88.m_svsnolag.so: No such file or directory.
Error while mapping shared library sections:
tmp/41132FFC.m_addmotd.so: No such file or directory.
Error while mapping shared library sections:
tmp/250C1E3D.m_svslusers.so: No such file or directory.
Error while mapping shared library sections:
tmp/DD26B8CE.m_starttls.so: No such file or directory.
Error while mapping shared library sections:
tmp/70316B32.m_nopost.so: No such file or directory.
Error while mapping shared library sections:
tmp/4C15CA51.m_cap.so: No such file or directory.
Error while mapping shared library sections:
tmp/5C4849A7.m_sasl.so: No such file or directory.
Error while mapping shared library sections:
tmp/DA2E2748.m_md.so: No such file or directory.
Error while mapping shared library sections:
tmp/61236AFE.cap_invitenotify.so: No such file or directory.
Error while mapping shared library sections:
tmp/D80AC404.jointhrottle.so: No such file or directory.
Error while mapping shared library sections:
tmp/33ADDF19.floodprot.so: No such file or directory.
Error while mapping shared library sections:
tmp/256EC42A.nocolor.so: No such file or directory.
Error while mapping shared library sections:
tmp/21B7A1CA.noctcp.so: No such file or directory.
Error while mapping shared library sections:
tmp/2556DE13.stripcolor.so: No such file or directory.
Error while mapping shared library sections:
tmp/5AE5EBF8.issecure.so: No such file or directory.
Error while mapping shared library sections:
tmp/9870680F.permanent.so: No such file or directory.
Error while mapping shared library sections:
tmp/6BF1E227.link.so: No such file or directory.
Error while mapping shared library sections:
tmp/FA90A044.censor.so: No such file or directory.
Error while mapping shared library sections:
tmp/9D31A6F5.delayjoin.so: No such file or directory.
Error while mapping shared library sections:
tmp/7AC850CA.noknock.so: No such file or directory.
Error while mapping shared library sections:
tmp/43F687FB.noinvite.so: No such file or directory.
Error while mapping shared library sections:
tmp/10D90A26.operonly.so: No such file or directory.
Error while mapping shared library sections:
tmp/C03C6E00.adminonly.so: No such file or directory.
Error while mapping shared library sections:
tmp/9FEDFC7.nonotice.so: No such file or directory.
Error while mapping shared library sections:
tmp/54B19E83.regonly.so: No such file or directory.
Error while mapping shared library sections:
tmp/E5BCBA33.nonickchange.so: No such file or directory.
Error while mapping shared library sections:
tmp/2DE41AC1.nokick.so: No such file or directory.
Error while mapping shared library sections:
tmp/A705BC8F.regonlyspeak.so: No such file or directory.
Error while mapping shared library sections:
tmp/851F5EAB.secureonly.so: No such file or directory.
Error while mapping shared library sections:
tmp/6D3E14C2.noctcp.so: No such file or directory.
Error while mapping shared library sections:
tmp/F2B2B327.censor.so: No such file or directory.
Core was generated by `/home/kaiba/unreal34-alpha1-1022/unrealircd-unreal34/src/ircd'.
Program terminated with signal 6, Aborted.
#0 0x00007eff9d1221b5 in raise () from /lib/libc.so.6
#0 0x00007eff9d1221b5 in raise () from /lib/libc.so.6
#1 0x00007eff9d124fc0 in abort () from /lib/libc.so.6
#2 0x00007eff9d1585bb in ?? () from /lib/libc.so.6
#3 0x00007eff9d161e16 in ?? () from /lib/libc.so.6
#4 0x000000000041f164 in free_user (user=0x7eff9e3c83b8, cptr=0x1448840) at list.c:282
#5 0x000000000041f464 in remove_client_from_list (cptr=0x1448840) at list.c:334
#6 0x000000000043b7ef in exit_client (cptr=0x14e70f0, sptr=0x1448840, from=0x6, comment=0x7fff96f7ea92 "Quit: http://www.kiwiirc.com/ - A hand crafted IRC client")
    at s_misc.c:739
#7 0x00000000004230f6 in parse (cptr=0x14e70f0, buffer=0x7fff96f7ea80 ":ThetanBait QUIT", bufend=0x3f <Address 0x3f out of bounds>) at parse.c:449
0000008 0x00000000004135a8 in parse_client_queued (cptr=0x14e70f0) at s_bsd.c:1395
#9 0x0000000000413908 in read_packet (fd=5, revents=<value optimized out>, data=<value optimized out>) at s_bsd.c:1478
#10 0x00000000004397c5 in fd_select (delay=<value optimized out>) at s_dispatch.c:482
#11 0x000000000041e5fd in main (argc=0, argv=0x7fff96f7ef68) at ircd.c:1669

#0 0x00007eff9d1221b5 in raise () from /lib/libc.so.6

0x78dc60 <backupbuf>: ":ThetanBait QUIT :Quit: http://www.kiwiirc.com/ - A hand crafted IRC client"

#0 0x00007eff9d1221b5 in raise () from /lib/libc.so.6
No symbol table info available.
#1 0x00007eff9d124fc0 in abort () from /lib/libc.so.6
No symbol table info available.
#2 0x00007eff9d1585bb in ?? () from /lib/libc.so.6
No symbol table info available.
GCC: gcc version 4.4.5 (Debian 4.4.5-8)
UNAME: Linux chaosircd 2.6.32-5-amd64 #1 SMP Tue May 13 16:34:35 UTC 2014 x86_64 GNU/Linux
UNREAL: Unreal3.4-alpha1 build 3.4-alpha1
CORE: -rw------- 1 kaiba kaiba 5468160 Oct 25 18:25 core

syzop

2014-11-10 16:56

administrator   ~0018276

looks like memory corruption. not good :/

the underlying issue can probably only be found by valgrind (or related memory debuggers).

syzop

2015-07-23 14:30

administrator   ~0018546

I fixed quite a number of memory corruption issues (out of bounds writes) in beta1 and beta2. It's quite plausible that this bug was among them.

If you crash again with beta2 (soon to be released) then let us know, with the backtrace again. Thanks for your help!

Issue History

Date Modified Username Field Change
2014-10-24 12:33 hunterkll New Issue
2014-10-24 21:06 syzop Note Added: 0018257
2014-10-26 02:32 hunterkll Note Added: 0018262
2014-11-10 16:56 syzop Note Added: 0018276
2015-07-23 14:30 syzop Note Added: 0018546
2015-07-23 14:30 syzop Status new => resolved
2015-07-23 14:30 syzop Fixed in Version => 3.4-beta2
2015-07-23 14:30 syzop Resolution open => fixed
2015-07-23 14:30 syzop Assigned To => syzop