View Issue Details

IDProjectCategoryView StatusLast Update
0005246unrealircdpublic2019-04-15 08:11
ReporterAlphaeAssigned Tosyzop 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
Product Version3.2.10.7 
Target VersionFixed in Version 
Summary0005246: error unreal3.2.10.7 gives this error in the evening
Description=================== START HERE ======================
BACKTRACE:
[New LWP 5727]
Core was generated by `/home/ozelchat/Unreal3.2.10.7/src/ircd'.
Program terminated with signal 11, Segmentation fault.
#0 0x0807db03 in check_string (s=0x36 <Address 0x36 out of bounds>) at s_misc.c:195
195 if (BadPtr(s))
#0 0x0807db03 in check_string (s=0x36 <Address 0x36 out of bounds>) at s_misc.c:195
#1 make_user_host (name=0x36 <Address 0x36 out of bounds>, host=0x41 <Address 0x41 out of bounds>) at s_misc.c :214
#2 0xf752bd75 in _register_user (cptr=0x9bfe820, sptr=0x9bfe820, nick=<optimized out>, username=0x9bc67d6 "Ozl emSoh", umode=0x0, virthost=0x0, ip=0x0) at m_nick.c:1213
#3 0xf7503954 in m_nospoof (cptr=cptr@entry=0x9bfe820, sptr=sptr@entry=0x9bfe820, parc=parc@entry=2, parv=parv @entry=0x8134ce0 <para>) at m_pingpong.c:184
#4 0xf7503ad8 in m_pong (cptr=0x9bfe820, sptr=0x9bfe820, parc=2, parv=0x8134ce0 <para>) at m_pingpong.c:206
#5 0x08066fe2 in parse (cptr=cptr@entry=0x9bfe820, buffer=buffer@entry=0x9bfe924 "PONG", bufend=<optimized out >) at parse.c:451
#6 0x08065c0a in dopacket (cptr=cptr@entry=0x9bfe820, buffer=buffer@entry=0x80c4e80 <readbuf> "PONG :16963639\ r", length=<optimized out>, length@entry=15) at packet.c:138
#7 0x08056938 in read_packet (cptr=cptr@entry=0x9bfe820, doread=doread@entry=1) at s_bsd.c:1629
0000008 0x08058da9 in read_message (delay=delay@entry=1, listp=<optimized out>, listp@entry=0x8143d20 <busycli_fdli st>) at s_bsd.c:2152
#9 0x08054b01 in main (argc=<optimized out>, argv=<optimized out>) at ircd.c:1865

#0 0x0807db03 in check_string (s=0x36 <Address 0x36 out of bounds>) at s_misc.c:195
195 if (BadPtr(s))

0x814aa40 <backupbuf>: "PONG :16963639"

#0 0x0807db03 in check_string (s=0x36 <Address 0x36 out of bounds>) at s_misc.c:195
        str = 0x36 <Address 0x36 out of bounds>
        star = "*"
#1 make_user_host (name=0x36 <Address 0x36 out of bounds>, host=0x41 <Address 0x41 out of bounds>) at s_misc.c :214
        namebuf = '\000' <repeats 78 times>
        s = 0x81359e0 <namebuf.8501> ""
#2 0xf752bd75 in _register_user (cptr=0x9bfe820, sptr=0x9bfe820, nick=<optimized out>, username=0x9bc67d6 "Ozl emSoh", umode=0x0, virthost=0x0, ip=0x0) at m_nick.c:1213
        userhost = "OzlemSoh", '\000' <repeats 16 times>, "f\372\332\033\000\000\000\000{\374\252\256\000\000\0 00\245\000\000\000\000\203qXW?+\363\036\236\314\022O\324\313\006w]\367\355\273\207\067\063j;=\377\377\377\377\ 243", <incomplete sequence \305>
        bconf = <optimized out>
        parv = {0x9bfe849 "Zenci", 0x0, 0x0}
        tmpstr = <optimized out>
        stripuser = "OzlemSoh\000\071\260"
        u1 = 0x0
        u2 = <optimized out>
        olduser = "E\341\377\246\342\023\bK\024", <incomplete sequence \367>
        userbad = "\000\330F\341\377\246\342\023\b\000\000\000\000 G\341\377@\016\024\b"
        ubad = <optimized out>
        noident = <optimized out>
        xx = <optimized out>
        user = 0x9bc67a0
        nsptr = <optimized out>
        i = <optimized out>
        mo = "OzlemSoh", '\000' <repeats 16 times>, "f\372\332\033\000\000\000\000{\374\252\256\000\000\000\245 \000\000\000\000\203qXW?+\363\036\236\314\022O\324\313\006w]\367\355\273\207\067\063j;=\377\377\377\377\243[?8 \221\030\021a\263\210\260\222\001\336n\200\n#\351\000\000\000\000\020\000\000\000\353\232\006YS\321\023\061\064 E\201\361\005\000\000\000\000\000\000\000\250e\\\367\246\342\023\b G\341\377V4T\367\305b]\367\246\342\023\bT4T\ 367\330F\341\377\324\023Y\367\310y\267\375v>\235,p\265\234L \350\277\t\377\377\377\017\071Dr\367\000\000\000\00 0\000\000\000\000*\351\277\tN4T\017\377\377\377\377"...
        tkllayer = {0x8149889 <me+41> "irc.Mobilcet.Com", 0xf753b456 "+", 0xf753d4ac "z", 0xf753b640 "*", 0x0, 0x0, 0x0, 0x0, 0x0}
        savetkl = 0x0
        tlds = <optimized out>
GCC: gcc version 4.8.5 20150623 (Red Hat 4.8.5-36) (GCC)
UNAME: Linux server.flashsizchat.net 3.10.0-957.10.1.el7.x86_64 #1 SMP Mon Mar 18 15:06:45 UTC 2019 x86_64 x86_ 64 x86_64 GNU/Linux
UNREAL: Unreal3.2.10.7 build 3.2.10.7
CORE: -rw------- 1 ozelchat ozelchat 3518464 Apr 14 23:55 core.5727
=================== STOP HERE ======================

Copy the parts between the START HERE and STOP HERE marker
and report it on http://bugs.unrealircd.org/

But before you do, note the following:
1. We do not support modifications of any unrealircd code
   (except for config.h changes).
2. If you are using 3rd party modules we might request you
   to run without them and verify you still crash. This is
   to eleminate any loss of time due to bugs made by others
3. Always use the latest UnrealIRCd version, we fix (crash)bugs
   all the time so your bug might as well be fixed already.

Thanks!
Tagsbug
3rd party modules

Activities

The_Myth

2019-04-15 00:47

reporter   ~0020580

As per http://tinyurl.com/u32eol the 3.2.x series of UnrealIRCd are now deprecated and no longer supported.
You should consider upgrading your IRCd to the latest stable release, which is UnrealIRCd 4.2.2.

syzop

2019-04-15 08:11

administrator   ~0020581

As The_Myth pointed out, 3.2.x is no longer supported, see https://www.unrealircd.org/docs/UnrealIRCd_3.2.x_deprecated
This was announced in December 2015 and since then there have been multiple repeated warnings as well.

I suggest you upgrade to UnrealIRCd 4.x (see the same URL as above).

Issue History

Date Modified Username Field Change
2019-04-15 00:40 Alphae New Issue
2019-04-15 00:40 Alphae Tag Attached: bug
2019-04-15 00:47 The_Myth Note Added: 0020580
2019-04-15 08:08 syzop Priority high => normal
2019-04-15 08:11 syzop Assigned To => syzop
2019-04-15 08:11 syzop Status new => closed
2019-04-15 08:11 syzop Resolution open => no change required
2019-04-15 08:11 syzop Note Added: 0020581