View Issue Details

IDProjectCategoryView StatusLast Update
0005521unrealircdpublic2020-01-26 09:38
ReporterPeGaSuS Assigned Tosyzop  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformUnixOSUbuntu 
Product Version5.0.0 
Fixed in Version5.0.3 
Summary0005521: /SAPART command doesn't send a /PART to channels with chmode +D
DescriptionWhen a user is /SAPART'ed from a channel with chmode +D, the /PART isn't seen and the nick is still visible in the user list.
If the user does /PART #channel manually, then all works as expected.
Steps To Reproduce1) Set a channel with chmode +D
2) Do: /SAPART nick #channel
3) User is /SAPART'ed from the channel (notice is sent to snomask) but it's still visible in the user list
4) As a normal user, do /PART #channel
5) /PART is sent to the channel, user is seen leaving the channel and user list is updated accordingly
TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0005542 closedsyzop mode +D leaves behind ghost users when users leave channel 

Activities

syzop

2020-01-26 09:07

administrator   ~0021258

I can confirm this, but it is not specific to SAPART, it also affects regular PART.

syzop

2020-01-26 09:38

administrator   ~0021259

Fixed, thanks for the reported.

commit 6fa7dd8b8877d638e15c5865cb561cca5bf770fb (HEAD -> unreal50)
Author: Bram Matthys <syzop@vulnscan.org>
Date: Sun Jan 26 09:32:41 2020 +0100

    Fix (SA)PART and KICK not being shown to chanops in +D channels for invisible
    users (users that have not talked or been otherwise exposed).
    Reported by PeGaSuS and LesterClayton in
    https://bugs.unrealircd.org/view.php?id=5521 and
    https://bugs.unrealircd.org/view.php?id=5542
    
    Bug was due to use of 'CHFL_CHANOP' instead of 'PREFIX_OP' in
    the 'prefix' argument of sendto_channel().... fun.

Issue History

Date Modified Username Field Change
2020-01-03 01:20 PeGaSuS New Issue
2020-01-26 09:06 syzop Relationship added has duplicate 0005542
2020-01-26 09:07 syzop Assigned To => syzop
2020-01-26 09:07 syzop Status new => confirmed
2020-01-26 09:07 syzop Note Added: 0021258
2020-01-26 09:38 syzop Status confirmed => resolved
2020-01-26 09:38 syzop Resolution open => fixed
2020-01-26 09:38 syzop Fixed in Version => 5.0.3
2020-01-26 09:38 syzop Note Added: 0021259