View Issue Details

IDProjectCategoryView StatusLast Update
0005542unrealircdpublic2020-01-26 09:06
ReporterLesterClaytonAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSUbuntuOS Version19.10
Product Version5.0.2 
Target VersionFixed in Version 
Summary0005542: mode +D leaves behind ghost users when users leave channel
DescriptionI've noticed since upgrading from 4.2.4.1 to 5.0.2 on my production network that users appeared to be joining a channel and not leaving. When I tried to use SAPART to make them leave the channel I discovered that they weren't in the channel any more.

I then went to my test server which was a fresh install (i.e. not an upgraded config) and saw the same result. Users remain in the channel even after they leave.
Steps To Reproduce1) Install vanilla 5.0.2
2) Join a channel, become op and set +D
3) Connect a second IRC client, join the same channel, and then part the channel
4) You will notice from the first client that the user is still "there"
Additional InformationVanilla config, no services which might be interfering. Two servers linked (don't know if that makes a difference or not)

Severity only marked as "Minor" as workaround is to not use mode +D
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0005521 resolvedsyzop /SAPART command doesn't send a /PART to channels with chmode +D 

Activities

LesterClayton

2020-01-23 23:33

reporter   ~0021253

N.B. If users QUIT rather than PART, then they are removed from the channel correctly.

syzop

2020-01-26 09:06

administrator   ~0021257

Thanks for reporting the bug. I can reproduce. I will use 0005521 for further updates on this, since it was reported by pegasus too.

Issue History

Date Modified Username Field Change
2020-01-23 23:30 LesterClayton New Issue
2020-01-23 23:33 LesterClayton Note Added: 0021253
2020-01-26 09:06 syzop Assigned To => syzop
2020-01-26 09:06 syzop Status new => closed
2020-01-26 09:06 syzop Resolution open => duplicate
2020-01-26 09:06 syzop Note Added: 0021257
2020-01-26 09:06 syzop Relationship added duplicate of 0005521