View Issue Details

IDProjectCategoryView StatusLast Update
0002817unrealircdpublic2010-08-14 20:40
ReporterDanPMKAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSanyOS Versionany
Product Version3.2.5 
Target VersionFixed in Version3.2.9-RC1 
Summary0002817: Request: Extended Invex
DescriptionExteneded bans is one of my favorite features with Unreal, yet it only works with +b and +e. Any chance this could be added to work with the +I Invite exceptions?
TagsNo tags attached.
3rd party modules

Relationships

related to 0003928 resolvedsyzop Fix chained/stacked bans 
has duplicate 0003487 closed "extended-invite" on chmode +I 
related to 0003860 closed on a channel that is +i, the INVEX +I ~c:#channel is settable but doesn't work 
child of 0003776 resolvedsyzop Unreal3.2.9 TODO 

Activities

Stealth

2006-02-13 23:14

reporter   ~0011231

This could be fun...

Shining Phoenix

2007-01-28 03:06

reporter   ~0013138

Soo...is this going to be implemented?

tabrisnet

2007-04-15 17:38

reporter   ~0013417

fun doesn't mean good.

syzop

2007-05-07 12:38

administrator   ~0014018

I suppose it isn't a too bad idea?
Like +i and +I ~c:#somechan, that's safer than +b *!*@* +e ~c..
just as an example.

oh wait.. I already confirmed it ;)

Shining Phoenix

2007-07-27 04:26

reporter   ~0014610

Like +i and +I ~c:#somechan, that's safer than +b *!*@* +e ~c..
just as an example.
------
That's a good idea, I like to minimise use of exceptions. And I would use +I ~c

syzop

2007-09-06 13:02

administrator   ~0014762

I suppose this would be quite easy to implement, huh? /me looks at aquanight and wolfsage
Would be nice to have at least 1 new interesting feature in 3.2.8, if not too hard.

syzop

2010-08-14 20:39

administrator   ~0016269

Fixed in CVS .863:
- Added Extended Invex. This is very much like extended bans, in fact it
  supports some of the same flags. Syntax: +I ~character:mask
  Currently supported are: ~c (channel), ~r (realname) and ~R (registered).
  This can be useful when setting a channel invite only (+i) and then
  setting invite exceptions such as +I ~c:#chan (or even ~c:+#chan), while
  still being able to ban users.
  Because action modifiers (~q/~n/~j) make no sense here, extended invex
  stacking (+I ~a:~b:c) makes no sense either, and is not supported.
  Suggested by DanPMK (0002817), parts based on patch from ohnobinki.
  Module coders: set EXTBOPT_INVEX in the ExtbanInfo struct used by
  ExtbanAdd() to indicate that your extban may also be used in +I.
- Invex (+I) now always checks cloaked hosts as well. Just like with bans,
  it checks them also when the user is not currently cloaked (eg: did -x, or
  is currently using some VHOST).

Issue History

Date Modified Username Field Change
2006-02-13 11:56 DanPMK New Issue
2006-02-13 23:14 Stealth Note Added: 0011231
2006-11-12 15:20 syzop Status new => confirmed
2007-01-28 03:06 Shining Phoenix Note Added: 0013138
2007-04-15 17:38 tabrisnet Note Added: 0013417
2007-05-07 12:38 syzop Note Added: 0014018
2007-07-27 04:26 Shining Phoenix Note Added: 0014610
2007-08-12 12:04 aquanight Relationship added has duplicate 0003487
2007-09-06 13:02 syzop Note Added: 0014762
2007-09-06 13:02 syzop Relationship added child of 0003454
2008-12-10 09:17 syzop Relationship deleted child of 0003454
2009-07-07 15:34 Stealth Relationship added related to 0003860
2010-03-06 20:19 syzop Relationship added child of 0003776
2010-07-12 14:27 ohnobinki Status confirmed => assigned
2010-07-12 14:27 ohnobinki Assigned To => ohnobinki
2010-08-03 14:01 ohnobinki Relationship added related to 0003928
2010-08-13 19:56 syzop Assigned To ohnobinki => syzop
2010-08-14 20:39 syzop QA => Not touched yet by developer
2010-08-14 20:39 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-08-14 20:39 syzop Note Added: 0016269
2010-08-14 20:39 syzop Status assigned => resolved
2010-08-14 20:39 syzop Fixed in Version => 3.2.9-RC1
2010-08-14 20:39 syzop Resolution open => fixed