View Issue Details

IDProjectCategoryView StatusLast Update
0003019unrealircdpublic2007-04-27 03:03
ReporterpinstrateAssigned Tostskeeps 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSLinuxOS Version2.6 kernel
Product Version3.2.5 
Target VersionFixed in Version3.3-alpha0 
Summary0003019: DNS configuration options have no point at all
DescriptionThe timeout/retry options in unrealircd.conf does not work.

In my config, I have:

        dns {
                nameserver mydnshere;
                timeout 5s;
                retries 4;
        };

however, in ircd, /dns i shows me:

****** DNS Configuration Information ******
 c-ares version: 1.3.0
        timeout: 3
          tries: 2
   # of servers: 1
      server #1: mydnshere
****** End of DNS Configuration Info ******

TagsNo tags attached.
3rd party modules

Activities

pinstrate

2006-08-16 03:51

reporter   ~0012181

please fix this issue.

syzop

2006-08-22 06:52

administrator   ~0012205

Ehm, this won't be "fixed" in 3.2*.

In fact I'm considering removing (or otherwise: moving) the dns block altogether in 3.3* :P.

syzop

2006-08-22 06:56

administrator   ~0012206

Perhaps worth mentioning why this won't be "fixed" in 3.2*: It never worked in 3.2* and thus if we suddenly make the dns block work, it will break hundreds - if not thousands - of installations that will mysteriously suddenly fail to work. (FYI, set::dns::nameserver is also ignored atm, so making it work causes a... ""funny effect"").

djGrrr

2006-08-22 13:59

reporter   ~0012208

well, a better idea would be to remove these options, right now its highly annoying that they are required to be in the config file (or else unreal won't start, giving errors that they are missing), but they have absolutely no purpose at all; at the least, you _should_ remove the requirement of having them in there for 3.2.6; would make a lot more sense, that way there won't be any unrecognized config options, and nothing will break :>

syzop

2006-11-12 13:47

administrator   ~0012637

Done ;)

Fixed in CVS of 32* (.591) and 33* (.2296), part of mass-commit:
- Snomask N: Don't show nickchanges for U-lines, reported by seneces (0002636).
- Fixed set::dns::bind-ip directive seen as duplicate, reported by aegis (0003074).
- set::dns::* block is now no longer mandatory. All info has always been read from
  /etc/resolv.conf (*NIX) or the registry (Win32), and the set::dns block is ignored
  (except for set::dns::bind-ip, but that's a special case). Suggested by many including
  djGrrr to make things slightly more logical (0003019).
- As a consequence of the above, set::dns blocks were removed from doc/example*conf.
- Added two more characters to Catalan charset, reported by rmh (0002995).
- Added set::pingpong-warning [yes|no] which decides whether to send the "** If you are
  having problems connecting due to ping timeouts, please type /quote pong .." message
  to each client when NOSPOOF is enabled (usually on Win32). The default is NO.
  Previously this message was always sent if NOSPOOF was on, which often caused
  confusion among users. The message was intended for non-confirming clients, but these
  should be fixed by now, and those that were not fixed (self-made bots/etc) did often
  not understand the message anyway. Anyway, you can still turn it on ;). (0002680).

Issue History

Date Modified Username Field Change
2006-08-07 13:10 pinstrate New Issue
2006-08-16 03:51 pinstrate Note Added: 0012181
2006-08-22 06:52 syzop Note Added: 0012205
2006-08-22 06:56 syzop Note Added: 0012206
2006-08-22 13:59 djGrrr Note Added: 0012208
2006-11-12 13:47 syzop Note Added: 0012637
2007-04-27 03:03 stskeeps Status new => resolved
2007-04-27 03:03 stskeeps Fixed in Version => 3.3-alpha0
2007-04-27 03:03 stskeeps Resolution open => fixed
2007-04-27 03:03 stskeeps Assigned To => stskeeps