View Issue Details

IDProjectCategoryView StatusLast Update
0003074unrealircdpublic2006-11-12 13:47
ReporteraegisAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformk8OSSUSEOS Version10.1
Product Version3.2.5 
Target VersionFixed in Version3.2.6 
Summary0003074: (1) set::dns::bind-ip directive seen as duplicate
Description(1) set::dns::bind-ip seen as duplicate

[warning] evilirc.conf:12: Duplicate set::dns::bind-ip directive
Steps To Reproduceset the set::dns::bind-ip directive
Additional InformationAcknowledged in #unreal-support 9/28/2006
TagsNo tags attached.
3rd party modulesnone

Activities

syzop

2006-11-12 13:47

administrator   ~0012636

Fixed in CVS of 32* (.591) and 33* (.2296), part of mass-commit:
- Snomask N: Don't show nickchanges for U-lines, reported by seneces (0002636).
- Fixed set::dns::bind-ip directive seen as duplicate, reported by aegis (0003074).
- set::dns::* block is now no longer mandatory. All info has always been read from
  /etc/resolv.conf (*NIX) or the registry (Win32), and the set::dns block is ignored
  (except for set::dns::bind-ip, but that's a special case). Suggested by many including
  djGrrr to make things slightly more logical (0003019).
- As a consequence of the above, set::dns blocks were removed from doc/example*conf.
- Added two more characters to Catalan charset, reported by rmh (0002995).
- Added set::pingpong-warning [yes|no] which decides whether to send the "** If you are
  having problems connecting due to ping timeouts, please type /quote pong .." message
  to each client when NOSPOOF is enabled (usually on Win32). The default is NO.
  Previously this message was always sent if NOSPOOF was on, which often caused
  confusion among users. The message was intended for non-confirming clients, but these
  should be fixed by now, and those that were not fixed (self-made bots/etc) did often
  not understand the message anyway. Anyway, you can still turn it on ;). (0002680).

Issue History

Date Modified Username Field Change
2006-09-28 08:20 aegis New Issue
2006-09-28 08:20 aegis 3rd party modules => none
2006-09-28 08:26 syzop Status new => confirmed
2006-11-12 13:47 syzop Status confirmed => resolved
2006-11-12 13:47 syzop Fixed in Version => 3.2.6
2006-11-12 13:47 syzop Resolution open => fixed
2006-11-12 13:47 syzop Assigned To => syzop
2006-11-12 13:47 syzop Note Added: 0012636