View Issue Details

IDProjectCategoryView StatusLast Update
0003192unrealircdpublic2010-07-22 14:36
ReporterShining PhoenixAssigned Toohnobinki 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSLinuxOS Version2.6.10-1.771_FC2
Product Version3.2.6 
Target VersionFixed in Version3.2.9-RC1 
Summary0003192: Add a new simple extban
DescriptionBan mode +b ~j:stuff would only stop matching users from joining, not nickchanging and speaking. It's corresponding exception (+e ~j:stuff) would only let matching users join, and not affect speaking and nickchanging. If I want to let someone join, but not speak or nickchange, this would do the job well :)
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0003928 resolvedsyzop Fix chained/stacked bans 
child of 0003776 resolvedsyzop Unreal3.2.9 TODO 

Activities

Sakkath

2007-01-09 07:52

reporter   ~0013036

Why not use ~q and ~n?

Sakkath

2007-01-09 07:52

reporter   ~0013037

I mean honestly, why let a person in the channel if they have absolutely no rights? The other extbans I find are useful enough?

Shining Phoenix

2007-01-14 02:51

reporter   ~0013052

There was some specific purpose for this, but now I've forgot it.

Sakkath

2007-01-14 10:01

reporter   ~0013053

Lol.

aquanight

2007-01-15 15:48

reporter   ~0013056

Well, +b ~j I can see useful: you want people of a specific hostmask have to be invited (for example, particularly annoying ISPs like AOL: you can +b ~j:*!*@*.aol.com, and they have to be /invited, but once allowed in, can speak/nickchange freely - you might give a few "known good" people access to /chanserv INVITE themselves), but anyone else can join fine. +e ~j just gets a "free ride" on account of the fact that +b/+e pretty much use the same system (yes I see nearly no use for that).

syzop

2007-01-15 16:01

administrator   ~0013057

thanks for the example aquanight. without it, this had little chance :P

Sakkath

2007-01-15 20:08

reporter   ~0013060

Most people would probably not even see that this function exists, but since so many of us use UnrealIRCd, now that you've posted an example, I guess some would find it useful.

Thanks for the ex :-p.

This might be best as a module too keep the core's "core" functionality and not have stuff some might find unnecessary :-p.

Shining Phoenix

2007-01-21 22:39

reporter   ~0013076

I had a situation where I wanted to use it today :)
This guy was cloning in a channel where I don't allow it, so I set a ban on him, a nickchange exception and a quiet exception. A single ~j ban would be nicer than a ban and two exceptions.
Modifying the core to add this feature would be better than having someone make a module for it, which will crash the IRCd.
/me stabs 3.2.6's handling of parametered channel modes from modules D:<

syzop

2007-01-22 06:21

administrator   ~0013079

This can be perfectly fine implemented in a module. Of course, you're right, if you don't know C or are unable to create a good UnrealIRCd module, then it could crash. Just don't say it's not possible!

aquanight

2007-01-25 11:27

reporter   ~0013110

Added (to core) in devel branch .2333 .

syzop

2010-07-14 21:15

administrator   ~0016189

reopened for 3.2.9

2010-07-20 18:47

 

unreal-3192-m_extban_join.patch (4,726 bytes)

syzop

2010-07-20 20:48

administrator   ~0016231

Ehm.. regarding the patch.
Yes, I understand you want it modulized, as it can be loaded if the user wants it.
But, please just integrate it with the other extbans for now, there's no reason to make an exception to ~j when ~c/r/n and such are already in the core.

Perhaps in 3.2.10 / 3.3 we can choose to modulize stuff some more, but for now just do it like the rest.

ohnobinki

2010-07-20 21:03

reporter   ~0016232

> But, please just integrate it with the other extbans for now, there's no reason to make an exception to ~j when ~c/r/n and such are already in the core.

OK, it just appeared from the thread above that it should be a module ;-).

syzop

2010-07-20 21:19

administrator   ~0016233

ah, now I re-read it, I understand how it appeared that way ;)

2010-07-22 01:04

 

unreal-3192-extban-modej.patch (2,736 bytes)

ohnobinki

2010-07-22 01:05

reporter   ~0016234

unreal-3192-extban-modej.patch: integrates into core using existing conventions.

syzop

2010-07-22 11:47

administrator   ~0016238

Good :)

ohnobinki

2010-07-22 14:36

reporter   ~0016244

In the original patch in help.conf, I refered to ~j as ~r and had grammar mistakes -- fixed before applying.

- Add an extbasn of the schema +b ~j:*!*@* which _only_ prevents a user from joining a channel. (0003192)

in CVS :-).

Issue History

Date Modified Username Field Change
2007-01-06 06:01 Shining Phoenix New Issue
2007-01-09 07:52 Sakkath Note Added: 0013036
2007-01-09 07:52 Sakkath Note Added: 0013037
2007-01-14 02:51 Shining Phoenix Note Added: 0013052
2007-01-14 10:01 Sakkath Note Added: 0013053
2007-01-15 15:48 aquanight Note Added: 0013056
2007-01-15 16:01 syzop Note Added: 0013057
2007-01-15 16:01 syzop Status new => acknowledged
2007-01-15 20:08 Sakkath Note Added: 0013060
2007-01-21 22:39 Shining Phoenix Note Added: 0013076
2007-01-22 06:21 syzop Note Added: 0013079
2007-01-25 11:27 aquanight Note Added: 0013110
2007-01-25 11:27 aquanight Assigned To => aquanight
2007-01-25 11:27 aquanight Status acknowledged => resolved
2007-01-25 11:27 aquanight Resolution open => fixed
2007-01-25 11:27 aquanight Fixed in Version => 3.3-alpha0
2010-07-14 21:15 syzop QA => Not touched yet by developer
2010-07-14 21:15 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-07-14 21:15 syzop U4: Upstream notification of bug => Not decided
2010-07-14 21:15 syzop U4: Contributor working on this => None
2010-07-14 21:15 syzop Note Added: 0016189
2010-07-14 21:15 syzop Assigned To aquanight =>
2010-07-14 21:15 syzop Status resolved => acknowledged
2010-07-14 21:15 syzop Fixed in Version 3.3-alpha0 =>
2010-07-14 21:15 syzop Relationship added child of 0003776
2010-07-14 21:17 syzop Relationship added duplicate of 0003928
2010-07-19 23:46 ohnobinki Status acknowledged => assigned
2010-07-19 23:46 ohnobinki Assigned To => ohnobinki
2010-07-20 18:47 ohnobinki File Added: unreal-3192-m_extban_join.patch
2010-07-20 20:48 syzop Note Added: 0016231
2010-07-20 21:03 ohnobinki Note Added: 0016232
2010-07-20 21:19 syzop Note Added: 0016233
2010-07-22 01:04 ohnobinki File Added: unreal-3192-extban-modej.patch
2010-07-22 01:05 ohnobinki Note Added: 0016234
2010-07-22 11:47 syzop Note Added: 0016238
2010-07-22 14:36 ohnobinki Note Added: 0016244
2010-07-22 14:36 ohnobinki Status assigned => resolved
2010-07-22 14:36 ohnobinki Fixed in Version => 3.2.9-RC1