View Issue Details

IDProjectCategoryView StatusLast Update
0003755unrealircdpublic2010-06-24 03:13
ReporterSkizzerzAssigned Toohnobinki 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSUbuntuOS Version8.04.1
Product Version3.2.8 
Target VersionFixed in Version3.2.8 
Summary0003755: IPv4 address display incorrectly in the z-lined message when IPv6 support is enabled
DescriptionIf IPv6 support is enabled, an IPv4 IP shown in the z-line notice is incorrectly formatted like ::ffff:127.0.0.1. Should be trivial to fix.
Steps To Reproduce1. Enable IPv6 support in ./Config if you have not yet done so
2. Make sure you do not have an except ban block for your IP in unrealircd.conf
3. z-line yourself
4. The notice given to you about you being z-lined contains an incorrectly-formatted IP (like ::ffff:127.0.0.1 instead of 127.0.0.1)
TagsNo tags attached.
3rd party modules

Relationships

child of 0003776 resolvedsyzop Unreal3.2.9 TODO 

Activities

syzop

2009-01-04 11:34

administrator   ~0015608

I've decided not to fix this for 3.2.8. I have a patch but due to buffer handling it has some risks, it's just too risky for such a small text issue ;).

tabrisnet

2010-05-18 23:18

reporter   ~0016087

may be related to 0003907, which is severity major (causes a desync)

ohnobinki

2010-06-24 01:51

reporter   ~0016129

:test.ohnopub.net 292 asef : -
zline *@127.0.0.1 1m test bug 3755
:test.ohnopub.net NOTICE asef :*** Z:Line added for *@127.0.0.1 on Wed Jun 23 23:48:51 2010 GMT (from asef!~a@undisclosed-981307ED to expire at Wed Jun 23 23:49:51 2010 GMT: test bug 3755)
ERROR :Closing Link: asef[localhost] (Z:lined (test bug 3755))
closed

^-- that's the output I get from a server running CVS. I'm pretty sure that this bug doesn't exist anymore, please confirm that the above is correct or tell me what I did wrong with my test ;-).

Thanks

Skizzerz

2010-06-24 03:11

reporter   ~0016131

Tested this on 3.2.8.1 and the message shows up as properly formatted. This bug can be marked as fixed.

ohnobinki

2010-06-24 03:13

reporter   ~0016132

cool :-)

Issue History

Date Modified Username Field Change
2008-12-29 21:01 Skizzerz New Issue
2009-01-04 11:34 syzop Note Added: 0015608
2009-01-04 11:49 syzop Relationship added child of 0003776
2010-05-18 23:18 tabrisnet Note Added: 0016087
2010-06-24 01:51 ohnobinki Note Added: 0016129
2010-06-24 01:52 ohnobinki Assigned To => ohnobinki
2010-06-24 01:52 ohnobinki Status new => feedback
2010-06-24 03:11 Skizzerz Note Added: 0016131
2010-06-24 03:13 ohnobinki QA => Not touched yet by developer
2010-06-24 03:13 ohnobinki U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-06-24 03:13 ohnobinki Note Added: 0016132
2010-06-24 03:13 ohnobinki Status feedback => resolved
2010-06-24 03:13 ohnobinki Fixed in Version => 3.2.8
2010-06-24 03:13 ohnobinki Resolution open => fixed